aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/noson-app/noson-app-4.5.2.ebuild')
-rw-r--r--media-sound/noson-app/noson-app-4.5.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/noson-app/noson-app-4.5.2.ebuild b/media-sound/noson-app/noson-app-4.5.2.ebuild
new file mode 100644
index 000000000..c0f4968b2
--- /dev/null
+++ b/media-sound/noson-app/noson-app-4.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg cmake
+
+DESCRIPTION="The essential to control music from your SONOS devices on Linux platforms"
+HOMEPAGE="http://janbar.github.io/noson-app/index.html"
+SRC_URI="https://github.com/janbar/noson-app/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-qt/qtcore-5.9
+ >=dev-qt/qtdbus-5.9
+ >=dev-qt/qtnetwork-5.9
+ >=dev-qt/qttranslations-5.9
+ >=dev-qt/qtgui-5.9
+ >=dev-qt/qtquickcontrols2-5.9
+ >=dev-qt/qtsvg-5.9
+ dev-libs/openssl:0
+ media-libs/flac
+ media-sound/pulseaudio
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ cmake_src_configure
+}