aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/syncplay/Manifest1
-rw-r--r--media-video/syncplay/syncplay-1.6.5_beta1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/media-video/syncplay/Manifest b/media-video/syncplay/Manifest
index 77f72fdeb..50f13a30b 100644
--- a/media-video/syncplay/Manifest
+++ b/media-video/syncplay/Manifest
@@ -1 +1,2 @@
DIST syncplay-1.6.4_p1.tar.gz 1791803 BLAKE2B ac309c224ad61c94712f18b3cc7216b9a2fe431251feb2d26b1db3d728bd97b89e6aa362b7b64992152b41a25ac107428f910c24ec0ba88e7c6f042ae1628c07 SHA512 7cf41088462b3140836ba5c2d0376fcae78263255280dfb63575ab8015f21953c78c01d0a2e22c5c09902679cb8ae2f1fdbb5d9fbe4150c5ed8d3d4b8edb49e0
+DIST syncplay-1.6.5_beta1.tar.gz 1838573 BLAKE2B 11567daf6a2a6e5163775f8346bcac49f57984aa36f361eb9d2aaa52143260aade69ac98ed035803d269419a512919f07495bfb331ff1010e148f24e46a0d74e SHA512 ee83aaeba8c46d63e22db6f804807d71ed467a4ca510ececc7e5b2ad9410626331e58aa22ee9f6c4e24b9df4aee67067a1ed0a9f26404ab0a4ad4b1b9a381955
diff --git a/media-video/syncplay/syncplay-1.6.5_beta1.ebuild b/media-video/syncplay/syncplay-1.6.5_beta1.ebuild
new file mode 100644
index 000000000..d04acac56
--- /dev/null
+++ b/media-video/syncplay/syncplay-1.6.5_beta1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils xdg
+
+MYPV="${PV/_beta1/-Beta1}"
+
+DESCRIPTION="Client/server to synchronize media playback"
+HOMEPAGE="https://github.com/Syncplay/syncplay https://syncplay.pl"
+SRC_URI="https://github.com/${PN^}/${PN}/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+client +server vlc mpv mplayer"
+REQUIRED_USE="
+ vlc? ( client )
+ mpv? ( client )
+ mplayer? ( client )
+ client? ( || ( vlc mpv mplayer ) )
+"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ vlc? ( media-video/vlc[lua] )
+ mpv? ( media-video/mpv[lua] )
+ mplayer? ( media-video/mplayer )
+"
+
+# RDEPEND on PySide2 for gui, but not packaged here at the moment
+# It is a too big and complex package for me to maintain
+# You can find PySide2 in the ::raiagent overlay
+
+S="${WORKDIR}/${PN}-${MYPV}"
+
+python_install() {
+ local MY_MAKEOPTS=( DESTDIR="${D}" PREFIX=/usr )
+ if use client; then
+ emake "${MY_MAKEOPTS[@]}" install-client
+ fi
+ if use server; then
+ emake "${MY_MAKEOPTS[@]}" install-server
+ newinitd "${FILESDIR}/${PN}-server-init" "${PN}"
+ newconfd "${FILESDIR}/${PN}-server-init-conf" "${PN}"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "using the GUI (you can find it in the raiagent overlay)\n" dev-python/pyside2
+
+ if use client; then
+ elog "Syncplay supports the following players:"
+ elog "media-video/mpv, media-video/mplayer, media-video/vlc\n"
+ optfeature "using Syncplay with VLC" media-video/vlc[lua]
+ optfeature "using Syncplay with MPV" media-video/mpv[lua]
+ optfeature "using Syncplay with MPlayer" media-video/mplayer
+ fi
+}