aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/magma')
-rw-r--r--sci-libs/magma/Manifest1
-rw-r--r--sci-libs/magma/magma-2.6.2-r1.ebuild142
-rw-r--r--sci-libs/magma/magma-2.6.2.ebuild124
-rw-r--r--sci-libs/magma/metadata.xml21
4 files changed, 0 insertions, 288 deletions
diff --git a/sci-libs/magma/Manifest b/sci-libs/magma/Manifest
deleted file mode 100644
index 49e0885d0..000000000
--- a/sci-libs/magma/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST magma-2.6.2.tar.gz 10239690 BLAKE2B b1c13bdc89b05ef1f2d67e0a3c3a2a6152594ea173195190d46f010f5b5e060bb3888dac74e317893bbd8e5a9f8791c3f3b397f3b1b934d5bd6461c1a2e344a4 SHA512 c6c2665e7eedd1a8425c1ac3c053c22b3f7326b796404cf2aa4f99322146a95cf7be0323a88c2d92a713b083db5bc30150142958426a9d5ddb4eaa2a8044d95a
diff --git a/sci-libs/magma/magma-2.6.2-r1.ebuild b/sci-libs/magma/magma-2.6.2-r1.ebuild
deleted file mode 100644
index 7efd69611..000000000
--- a/sci-libs/magma/magma-2.6.2-r1.ebuild
+++ /dev/null
@@ -1,142 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-FORTRAN_STANDARD="77 90"
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake fortran-2 python-any-r1 toolchain-funcs
-
-MY_PV=$(ver_rs 3 '-')
-
-DESCRIPTION="Matrix Algebra on GPU and Multicore Architectures"
-HOMEPAGE="
- https://icl.cs.utk.edu/magma/
- https://bitbucket.org/icl/magma
-"
-SRC_URI="https://icl.cs.utk.edu/projectsfiles/${PN}/downloads/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE_AMDGPU="
- amdgpu_gfx701 amdgpu_gfx702 amdgpu_gfx704
- amdgpu_gfx802 amdgpu_gfx803 amdgpu_gfx805 amdgpu_gfx810
- amdgpu_gfx900 amdgpu_gfx904 amdgpu_gfx906 amdgpu_gfx908 amdgpu_gfx909 amdgpu_gfx90a amdgpu_gfx940
- amdgpu_gfx1010 amdgpu_gfx1011 amdgpu_gfx1012 amdgpu_gfx1030 amdgpu_gfx1031 amdgpu_gfx1032 amdgpu_gfx1034
- amdgpu_gfx1100 amdgpu_gfx1101 amdgpu_gfx1102
-"
-IUSE="doc openblas test ${IUSE_AMDGPU}"
-#IUSE="doc cuda hip openblas test ${IUSE_AMDGPU}"
-
-# TODO: do not enforce openblas
-# hip? ( sci-libs/hipBLAS )
-RDEPEND="
- sci-libs/hipBLAS
- openblas? ( sci-libs/openblas )
- !openblas? (
- virtual/blas
- virtual/lapack
- )
-"
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- dev-util/hip
-"
-# hip? ( dev-util/hip )
-BDEPEND="
- virtual/pkgconfig
- doc? ( >=app-text/doxygen-1.8.14-r1[dot] )
-"
-
-REQUIRED_USE="
- || ( ${IUSE_AMDGPU/+/} )
-"
-# ^^ ( cuda hip )
-RESTRICT="!test? ( test )"
-
-pkg_setup() {
- fortran-2_pkg_setup
- python-any-r1_pkg_setup
- tc-check-openmp || die "Need OpenMP to compile ${P}"
-}
-
-src_prepare() {
- gpu=""
- #if use hip ; then
- for u in ${IUSE_AMDGPU} ; do
- if use ${u} ; then
- gpu="${gpu};${u/amdgpu_/}"
- fi
- done
- #fi
- # remove first character (;)
- gpu="${gpu:1}"
- export gpu
-
- # distributed pc file not so useful so replace it
- cat <<-EOF > ${PN}.pc
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include/${PN}
- Name: ${PN}
- Description: ${DESCRIPTION}
- Version: ${PV}
- URL: ${HOMEPAGE}
- Libs: -L\${libdir} -lmagma
- Libs.private: -lm -lpthread -ldl
- Cflags: -I\${includedir}
- Requires: $(usex openblas "openblas" "blas lapack")
- EOF
-
- #use cuda && echo -e 'BACKEND = cuda' > make.inc
- #use hip && echo -e 'BACKEND = hip' > make.inc
- echo -e 'BACKEND = hip' > make.inc
- echo -e 'FORT = true' >> make.inc
- echo -e "GPU_TARGET = ${gpu}" >> make.inc
- emake generate
-
- rm -r blas_fix || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- # other options: Intel10_64lp, Intel10_64lp_seq, Intel10_64ilp, Intel10_64ilp_seq, Intel10_32, FLAME, ACML, Apple, NAS
- local blasvendor="Generic"
- use openblas && blasvendor="OpenBLAS"
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DCMAKE_CXX_COMPILER=hipcc
- -DMAGMA_ENABLE_CUDA=OFF
- -DMAGMA_ENABLE_HIP=ON
- -DUSE_FORTRAN=ON
-
- -DBLA_VENDOR=${blasvendor}
- -DGPU_TARGET=${gpu}
- )
- # -DMAGMA_ENABLE_CUDA=$(usex cuda)
- # -DMAGMA_ENABLE_HIP=$(usex hip)
-
- #use fortran || mycmakeargs+=( "-DFORTRAN_CONVENTION=-DADD_"
- #use hip && mycmakeargs+=( "-DCMAKE_CXX_COMPILER=hipcc" )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-}
-
-src_install() {
- cmake_src_install
- insinto "/usr/include/${PN}"
- doins include/*.h
- insinto "/usr/$(get_libdir)/pkgconfig"
- doins "${PN}.pc"
- local DOCS=( README ReleaseNotes )
- use doc && local HTML_DOCS=( docs/html/. )
- einstalldocs
-}
diff --git a/sci-libs/magma/magma-2.6.2.ebuild b/sci-libs/magma/magma-2.6.2.ebuild
deleted file mode 100644
index 412739f84..000000000
--- a/sci-libs/magma/magma-2.6.2.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-FORTRAN_STANDARD="77 90"
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit cmake fortran-2 python-any-r1 toolchain-funcs
-
-MY_PV=$(ver_rs 3 '-')
-
-DESCRIPTION="Matrix Algebra on GPU and Multicore Architectures"
-HOMEPAGE="
- https://icl.cs.utk.edu/magma/
- https://bitbucket.org/icl/magma
-"
-SRC_URI="https://icl.cs.utk.edu/projectsfiles/${PN}/downloads/${PN}-${MY_PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE_AMDGPU="
- amdgpu_gfx701 amdgpu_gfx702 amdgpu_gfx704
- amdgpu_gfx802 amdgpu_gfx803 amdgpu_gfx805 amdgpu_gfx810
- amdgpu_gfx900 amdgpu_gfx904 amdgpu_gfx906 amdgpu_gfx908 amdgpu_gfx909 amdgpu_gfx90a amdgpu_gfx940
- amdgpu_gfx1010 amdgpu_gfx1011 amdgpu_gfx1012 amdgpu_gfx1030 amdgpu_gfx1031 amdgpu_gfx1032 amdgpu_gfx1034
- amdgpu_gfx1100 amdgpu_gfx1101 amdgpu_gfx1102
-"
-IUSE="doc openblas test ${IUSE_AMDGPU}"
-
-# TODO: do not enforce openblas
-RDEPEND="
- openblas? ( sci-libs/openblas )
- !openblas? (
- virtual/blas
- virtual/lapack
- )
-"
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- dev-util/hip
-"
-BDEPEND="
- virtual/pkgconfig
- doc? ( >=app-text/doxygen-1.8.14-r1[dot] )
-"
-
-REQUIRED_USE="|| ( ${IUSE_AMDGPU/+/} )"
-RESTRICT="!test? ( test )"
-
-pkg_setup() {
- fortran-2_pkg_setup
- python-any-r1_pkg_setup
- tc-check-openmp || die "Need OpenMP to compile ${P}"
-}
-
-src_prepare() {
- rm -r blas_fix || die
- # distributed pc file not so useful so replace it
- cat <<-EOF > ${PN}.pc
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include/${PN}
- Name: ${PN}
- Description: ${DESCRIPTION}
- Version: ${PV}
- URL: ${HOMEPAGE}
- Libs: -L\${libdir} -lmagma
- Libs.private: -lm -lpthread -ldl
- Cflags: -I\${includedir}
- Requires: $(usex openblas "openblas" "blas lapack")
- EOF
-
- echo -e 'BACKEND = hip\nFORT = true' > make.inc
- emake generate
-
- cmake_src_prepare
-}
-
-src_configure() {
- # other options: Intel10_64lp, Intel10_64lp_seq, Intel10_64ilp, Intel10_64ilp_seq, Intel10_32, FLAME, ACML, Apple, NAS
- local blasvendor="Generic"
- use openblas && blasvendor="OpenBLAS"
-
- local gpu=""
- for u in ${IUSE_AMDGPU} ; do
- if use ${u} ; then
- gpu="${gpu};${u/amdgpu_/}"
- fi
- done
- #remove first character (;)
- gpu="${gpu:1}"
-
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
- -DCMAKE_CXX_COMPILER=hipcc
- -DMAGMA_ENABLE_CUDA=OFF
- -DMAGMA_ENABLE_HIP=ON
- -DUSE_FORTRAN=ON
-
- -DBLA_VENDOR=${blasvendor}
- -DGPU_TARGET=${gpu}
- )
- #use fortran || mycmakeargs+=( "-DFORTRAN_CONVENTION=-DADD_"
- #use hip && mycmakeargs+=( "-DCMAKE_CXX_COMPILER=hipcc" )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-}
-
-src_install() {
- cmake_src_install
- insinto /usr/include/${PN}
- doins include/*.h
- insinto /usr/$(get_libdir)/pkgconfig
- doins ${PN}.pc
- local DOCS=( README ReleaseNotes )
- use doc && local HTML_DOCS=( docs/html/. )
- einstalldocs
-}
diff --git a/sci-libs/magma/metadata.xml b/sci-libs/magma/metadata.xml
deleted file mode 100644
index c3a14ba58..000000000
--- a/sci-libs/magma/metadata.xml
+++ /dev/null
@@ -1,21 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <description>co-maintainers welcome</description>
- <name>Alessandro Barbieri</name>
- <email>lssndrbarbieri@gmail.com</email>
- </maintainer>
- <longdescription lang="en">
-The Matrix Algebra on GPU and Multicore Architecture project aims to
-develop a dense linear algebra library similar to LAPACK but for
-heterogeneous/hybrid architectures, starting with current
-"Multicore+GPU" systems.
- </longdescription>
- <use>
- <flag name="openblas">Use OpenBLAS as the BLAS vendor</flag>
- </use>
- <upstream>
- <remote-id type="bitbucket">icl/magma</remote-id>
- </upstream>
-</pkgmetadata>