aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/KVTree/KVTree-9999.ebuild')
-rw-r--r--sys-cluster/KVTree/KVTree-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-cluster/KVTree/KVTree-9999.ebuild b/sys-cluster/KVTree/KVTree-9999.ebuild
index 0be4f18ec..4b7e15343 100644
--- a/sys-cluster/KVTree/KVTree-9999.ebuild
+++ b/sys-cluster/KVTree/KVTree-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit cmake-utils
+inherit cmake
case "${PV}" in
9999)
@@ -46,7 +46,7 @@ src_prepare() {
#do not install README.md automatically
sed -i '/FILES README.md DESTINATION/d' CMakeLists.txt || die
default
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -55,12 +55,12 @@ src_configure() {
-DKVTREE_FILE_LOCK="$(usex flock FLOCK $(usex fcntl FCNTL NONE))"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
chrpath -d "${BUILD_DIR}/src/kvtree_print_file" || die
- cmake-utils_src_install
+ cmake_src_install
chrpath -d "${ED}/usr/$(get_libdir)/libkvtree.so" || die
dodoc doc/rst/*.rst
docinto "${DOCSDIR}/users"