aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/er/er-0.1.0.ebuild')
-rw-r--r--sys-cluster/er/er-0.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-cluster/er/er-0.1.0.ebuild b/sys-cluster/er/er-0.1.0.ebuild
new file mode 100644
index 000000000..fc1ab6de5
--- /dev/null
+++ b/sys-cluster/er/er-0.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="High-level distributed erasure coding lib combining shuffile and redset"
+HOMEPAGE="https://github.com/ECP-VeloC/er"
+SRC_URI="https://github.com/ECP-VeloC/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ sys-cluster/KVTree[mpi]
+ sys-cluster/redset
+ sys-cluster/shuffile
+ sys-libs/zlib
+ virtual/mpi
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-util/cmake-2.8
+"
+
+PATCHES=( "${FILESDIR}/${P}-no-static.patch" )
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DENABLE_TESTS=$(usex test)
+ -DER_LINK_STATIC=OFF
+ )
+ cmake_src_configure
+}