aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gsl/gsl-4.1.5-r1.ebuild')
-rw-r--r--sys-devel/gsl/gsl-4.1.5-r1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-devel/gsl/gsl-4.1.5-r1.ebuild b/sys-devel/gsl/gsl-4.1.5-r1.ebuild
index 89ffc2238..c42875214 100644
--- a/sys-devel/gsl/gsl-4.1.5-r1.ebuild
+++ b/sys-devel/gsl/gsl-4.1.5-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit toolchain-funcs
+
DESCRIPTION='iMatix GSL code generator'
HOMEPAGE="https://github.com/zeromq/gsl"
SRC_URI="https://github.com/zeromq/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -15,6 +17,15 @@ IUSE="examples"
DEPEND="dev-libs/libpcre:3"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-respect-flags.patch" )
+
+src_prepare() {
+ tc-export RANLIB
+ export CCNAME="$(tc-getCC)"
+ export CCPLUS="$(tc-getCXX)"
+ default
+}
+
src_install() {
DESTDIR="${D}/usr" emake install
if use examples; then