aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/woob/woob-9999.ebuild')
-rw-r--r--www-client/woob/woob-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/www-client/woob/woob-9999.ebuild b/www-client/woob/woob-9999.ebuild
index b0535df1d..51f6d0707 100644
--- a/www-client/woob/woob-9999.ebuild
+++ b/www-client/woob/woob-9999.ebuild
@@ -42,19 +42,20 @@ RDEPEND="
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/unidecode[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
+BDEPEND="test? ( ${RDEPEND} )"
distutils_enable_tests nose
distutils_enable_sphinx docs/source
-src_prepare() {
- default
-
+python_prepare_all() {
sed -i \
-e '/woob.browser.browsers,/d' \
-e '/woob.browser.pages,/d' \
- setup.cfg || die "Failed removing network-dependent tests"
+ -e '/woob.tools.application.formatters.table,/d' \
+ setup.cfg || die
+
+ distutils-r1_python_prepare_all
}
python_install_all() {