aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2021-01-31 14:23:14 +0100
committerQuentin Retornaz <gentoo@retornaz.com>2021-01-31 14:23:14 +0100
commit6a85f6cb40f7537594f48759a82f9a618727a478 (patch)
treebd5c51ecfe20b512f9ff10dd450b54cc53f98877
parentnet-misc/openssh: add missing patches (diff)
downloadlibressl-6a85f6cb.tar.gz
libressl-6a85f6cb.tar.bz2
libressl-6a85f6cb.zip
net-wireless/aircrack-ng: drop package
Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
-rw-r--r--net-wireless/aircrack-ng/Manifest2
-rw-r--r--net-wireless/aircrack-ng/aircrack-ng-1.2_rc1-r1.ebuild138
-rw-r--r--net-wireless/aircrack-ng/aircrack-ng-1.2_rc4-r1.ebuild118
-rw-r--r--net-wireless/aircrack-ng/aircrack-ng-9999.ebuild123
-rw-r--r--net-wireless/aircrack-ng/files/aircrack-ng-1.2_rc4-openssl.patch49
-rw-r--r--net-wireless/aircrack-ng/metadata.xml29
6 files changed, 0 insertions, 459 deletions
diff --git a/net-wireless/aircrack-ng/Manifest b/net-wireless/aircrack-ng/Manifest
deleted file mode 100644
index 694a11c..0000000
--- a/net-wireless/aircrack-ng/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST aircrack-ng-1.2-rc1.tar.gz 2046476 SHA256 cf3134521e1c3d7aed4e384e3e5e7b6959e2d485bd1554474608a3a9328e35fd SHA512 897427c535846c0ede58b2f99ed469bc01f50f9b38fc70d5711261fca7342339192cc0c71a724fc04c99114db7534d825a44f09e7bc5754286ec44933a33e40d WHIRLPOOL 2f8df161c61b8dfa6f4bd5f4af677273f255f01ae84853a80fcde4c07f03e51dcad9dcf007afa5a1120521c641d35c23d07b1edfc51c90d7b8b216b179d27ea9
-DIST aircrack-ng-1.2-rc4.tar.gz 4379880 SHA256 d93ac16aade5b4d37ab8cdf6ce4b855835096ccf83deb65ffdeff6d666eaff36 SHA512 f1e1d465813a5f00fd8f8b287353033ea30b657a4c3a9fe81281ab2546d3238690f0659076bff53703fbc796ba40efb16115804d21f8516adca2c774fefea20c WHIRLPOOL f06d87911492e83c48ea062c8451c2380a8d721795aa875133076e8b81d6a88d68aba354a4150890db3bf1b41d56f9715b595c2eb71f2b7232061be4a9ffd815
diff --git a/net-wireless/aircrack-ng/aircrack-ng-1.2_rc1-r1.ebuild b/net-wireless/aircrack-ng/aircrack-ng-1.2_rc1-r1.ebuild
deleted file mode 100644
index 1caf883..0000000
--- a/net-wireless/aircrack-ng/aircrack-ng-1.2_rc1-r1.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit toolchain-funcs distutils-r1 flag-o-matic
-
-DESCRIPTION="WLAN tools for breaking 802.11 WEP/WPA keys"
-HOMEPAGE="http://www.aircrack-ng.org"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="http://svn.aircrack-ng.org/trunk"
- KEYWORDS=""
- S="${WORKDIR}/${PN}"
-else
- MY_PV=${PV/_/-}
- SRC_URI="http://download.${PN}.org/${PN}-${MY_PV}.tar.gz"
- KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="+airdrop-ng +airgraph-ng kernel_linux kernel_FreeBSD libressl +netlink +pcre +sqlite +unstable"
-
-DEPEND="net-libs/libpcap
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- netlink? ( dev-libs/libnl:3 )
- pcre? ( dev-libs/libpcre )
- airdrop-ng? ( ${PYTHON_DEPS} )
- airgraph-ng? ( ${PYTHON_DEPS} )
- sqlite? ( >=dev-db/sqlite-3.4 )
- unstable? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}
- kernel_linux? (
- net-wireless/iw
- net-wireless/wireless-tools
- sys-apps/ethtool
- sys-apps/usbutils
- sys-apps/pciutils )
- sys-apps/hwids
- airdrop-ng? ( net-wireless/lorcon[python,${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="airdrop-ng? ( ${PYTHON_REQUIRED_USE} )
- airgraph-ng? ( ${PYTHON_REQUIRED_USE} )"
-
-src_compile() {
- if [[ $($(tc-getCC) --version) == clang* ]] ; then
- die "Please use gcc, upstream bug http://trac.aircrack-ng.org/ticket/1144"
- fi
-
- if [[ ${PV} == "9999" ]] ; then
- liveflags=REVFLAGS=-D_REVISION="${ESVN_WC_REVISION}"
- fi
-
- emake \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- LD="$(tc-getLD)" \
- RANLIB="$(tc-getRANLIB)" \
- libnl=$(usex netlink true false) \
- pcre=$(usex pcre true false) \
- sqlite=$(usex sqlite true false) \
- unstable=$(usex unstable true false) \
- ${liveflags}
-
- if use airgraph-ng; then
- cd "${S}/scripts/airgraph-ng"
- distutils-r1_src_compile
- fi
- if use airdrop-ng; then
- cd "${S}/scripts/airdrop-ng"
- distutils-r1_src_compile
- fi
-}
-
-src_test() {
- if [[ ${PV} == "9999" ]] ; then
- liveflags=REVFLAGS=-D_REVISION="${ESVN_WC_REVISION}"
- fi
-
- emake check \
- libnl=$(usex netlink true false) \
- pcre=$(usex pcre true false) \
- sqlite=$(usex sqlite true false) \
- unstable=$(usex unstable true false) \
- ${liveflags}
-}
-
-src_install() {
- if [[ ${PV} == "9999" ]] ; then
- liveflags=REVFLAGS=-D_REVISION="${ESVN_WC_REVISION}"
- fi
-
- emake \
- prefix="${ED}/usr" \
- libnl=$(usex netlink true false) \
- pcre=$(usex pcre true false) \
- sqlite=$(usex sqlite true false) \
- unstable=$(usex unstable true false) \
- ${liveflags} \
- install
-
- dodoc AUTHORS ChangeLog INSTALLING README
-
- if use airgraph-ng; then
- cd "${S}/scripts/airgraph-ng"
- distutils-r1_src_install
- fi
- if use airdrop-ng; then
- cd "${S}/scripts/airdrop-ng"
- distutils-r1_src_install
- fi
-
- #we don't need aircrack-ng's oui updater, we have our own
- rm "${ED}"/usr/sbin/airodump-ng-oui-update
-}
-
-pkg_postinst() {
- # Message is (c) FreeBSD
- # http://www.freebsd.org/cgi/cvsweb.cgi/ports/net-mgmt/aircrack-ng/files/pkg-message.in?rev=1.5
- if use kernel_FreeBSD ; then
- einfo "Contrary to Linux, it is not necessary to use airmon-ng to enable the monitor"
- einfo "mode of your wireless card. So do not care about what the manpages say about"
- einfo "airmon-ng, airodump-ng sets monitor mode automatically."
- echo
- einfo "To return from monitor mode, issue the following command:"
- einfo " ifconfig \${INTERFACE} -mediaopt monitor"
- einfo
- einfo "For aireplay-ng you need FreeBSD >= 7.0."
- fi
-}
diff --git a/net-wireless/aircrack-ng/aircrack-ng-1.2_rc4-r1.ebuild b/net-wireless/aircrack-ng/aircrack-ng-1.2_rc4-r1.ebuild
deleted file mode 100644
index 9bfac5c..0000000
--- a/net-wireless/aircrack-ng/aircrack-ng-1.2_rc4-r1.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit toolchain-funcs distutils-r1 flag-o-matic
-
-DESCRIPTION="WLAN tools for breaking 802.11 WEP/WPA keys"
-HOMEPAGE="http://www.aircrack-ng.org"
-
-MY_PV=${PV/_/-}
-SRC_URI="http://download.${PN}.org/${PN}-${MY_PV}.tar.gz"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="+airdrop-ng +airgraph-ng kernel_linux kernel_FreeBSD libressl +netlink +pcre +sqlite +experimental"
-
-DEPEND="net-libs/libpcap
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- netlink? ( dev-libs/libnl:3 )
- pcre? ( dev-libs/libpcre )
- airdrop-ng? ( ${PYTHON_DEPS} )
- airgraph-ng? ( ${PYTHON_DEPS} )
- experimental? ( sys-libs/zlib )
- sqlite? ( >=dev-db/sqlite-3.4 )"
-RDEPEND="${DEPEND}
- kernel_linux? (
- net-wireless/iw
- net-wireless/wireless-tools
- sys-apps/ethtool
- sys-apps/usbutils
- sys-apps/pciutils )
- sys-apps/hwids
- airdrop-ng? ( net-wireless/lorcon[python,${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="airdrop-ng? ( ${PYTHON_REQUIRED_USE} )
- airgraph-ng? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/${P}-openssl.patch"
-)
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-pkg_setup() {
- MAKE_COMMON=(
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- AR="$(tc-getAR)" \
- LD="$(tc-getLD)" \
- RANLIB="$(tc-getRANLIB)" \
- libnl=$(usex netlink true false) \
- pcre=$(usex pcre true false) \
- sqlite=$(usex sqlite true false) \
- experimental=$(usex experimental true false)
- prefix="${ED}/usr" \
- )
-}
-
-src_compile() {
- if [[ $($(tc-getCC) --version) == clang* ]] ; then
- #https://bugs.gentoo.org/show_bug.cgi?id=472890
- filter-flags -frecord-gcc-switches
- fi
-
- emake "${MAKE_COMMON[@]}"
-
- if use airgraph-ng; then
- cd "${S}/scripts/airgraph-ng"
- distutils-r1_src_compile
- fi
- if use airdrop-ng; then
- cd "${S}/scripts/airdrop-ng"
- distutils-r1_src_compile
- fi
-}
-
-src_test() {
- emake "${MAKE_COMMON[@]}" check
-}
-
-src_install() {
- einstalldocs
- emake "${MAKE_COMMON[@]}" install
-
- if use airgraph-ng; then
- cd "${S}/scripts/airgraph-ng"
- distutils-r1_src_install
- fi
- if use airdrop-ng; then
- cd "${S}/scripts/airdrop-ng"
- distutils-r1_src_install
- fi
-
- #we don't need aircrack-ng's oui updater, we have our own
- rm "${ED}"/usr/sbin/airodump-ng-oui-update
-}
-
-pkg_postinst() {
- # Message is (c) FreeBSD
- # http://www.freebsd.org/cgi/cvsweb.cgi/ports/net-mgmt/aircrack-ng/files/pkg-message.in?rev=1.5
- if use kernel_FreeBSD ; then
- einfo "Contrary to Linux, it is not necessary to use airmon-ng to enable the monitor"
- einfo "mode of your wireless card. So do not care about what the manpages say about"
- einfo "airmon-ng, airodump-ng sets monitor mode automatically."
- echo
- einfo "To return from monitor mode, issue the following command:"
- einfo " ifconfig \${INTERFACE} -mediaopt monitor"
- einfo
- einfo "For aireplay-ng you need FreeBSD >= 7.0."
- fi
-}
diff --git a/net-wireless/aircrack-ng/aircrack-ng-9999.ebuild b/net-wireless/aircrack-ng/aircrack-ng-9999.ebuild
deleted file mode 100644
index 3fceab7..0000000
--- a/net-wireless/aircrack-ng/aircrack-ng-9999.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit toolchain-funcs distutils-r1 flag-o-matic
-
-DESCRIPTION="WLAN tools for breaking 802.11 WEP/WPA keys"
-HOMEPAGE="http://www.aircrack-ng.org"
-
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="http://svn.aircrack-ng.org/trunk"
- KEYWORDS=""
- S="${WORKDIR}/${PN}"
-else
- MY_PV=${PV/_/-}
- SRC_URI="http://download.${PN}.org/${PN}-${MY_PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}-${MY_PV}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="+airdrop-ng +airgraph-ng kernel_linux kernel_FreeBSD libressl +netlink +pcre +sqlite +experimental"
-
-DEPEND="net-libs/libpcap
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- netlink? ( dev-libs/libnl:3 )
- pcre? ( dev-libs/libpcre )
- airdrop-ng? ( ${PYTHON_DEPS} )
- airgraph-ng? ( ${PYTHON_DEPS} )
- experimental? ( sys-libs/zlib )
- sqlite? ( >=dev-db/sqlite-3.4 )"
-RDEPEND="${DEPEND}
- kernel_linux? (
- net-wireless/iw
- net-wireless/wireless-tools
- sys-apps/ethtool
- sys-apps/usbutils
- sys-apps/pciutils )
- sys-apps/hwids
- airdrop-ng? ( net-wireless/lorcon[python,${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="airdrop-ng? ( ${PYTHON_REQUIRED_USE} )
- airgraph-ng? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- MAKE_COMMON=(
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- AR="$(tc-getAR)" \
- LD="$(tc-getLD)" \
- RANLIB="$(tc-getRANLIB)" \
- libnl=$(usex netlink true false) \
- pcre=$(usex pcre true false) \
- sqlite=$(usex sqlite true false) \
- experimental=$(usex experimental true false)
- prefix="${ED}/usr" \
- )
- [[ ${PV} == "9999" ]] && MAKE_COMMON+=(
- liveflags=REVFLAGS=-D_REVISION="${ESVN_WC_REVISION}"
- )
-}
-
-src_compile() {
- if [[ $($(tc-getCC) --version) == clang* ]] ; then
- #https://bugs.gentoo.org/show_bug.cgi?id=472890
- filter-flags -frecord-gcc-switches
- fi
-
- emake "${MAKE_COMMON[@]}"
-
- if use airgraph-ng; then
- cd "${S}/scripts/airgraph-ng"
- distutils-r1_src_compile
- fi
- if use airdrop-ng; then
- cd "${S}/scripts/airdrop-ng"
- distutils-r1_src_compile
- fi
-}
-
-src_test() {
- emake "${MAKE_COMMON[@]}" check
-}
-
-src_install() {
- einstalldocs
- emake "${MAKE_COMMON[@]}" install
-
- if use airgraph-ng; then
- cd "${S}/scripts/airgraph-ng"
- distutils-r1_src_install
- fi
- if use airdrop-ng; then
- cd "${S}/scripts/airdrop-ng"
- distutils-r1_src_install
- fi
-
- #we don't need aircrack-ng's oui updater, we have our own
- rm "${ED}"/usr/sbin/airodump-ng-oui-update
-}
-
-pkg_postinst() {
- # Message is (c) FreeBSD
- # http://www.freebsd.org/cgi/cvsweb.cgi/ports/net-mgmt/aircrack-ng/files/pkg-message.in?rev=1.5
- if use kernel_FreeBSD ; then
- einfo "Contrary to Linux, it is not necessary to use airmon-ng to enable the monitor"
- einfo "mode of your wireless card. So do not care about what the manpages say about"
- einfo "airmon-ng, airodump-ng sets monitor mode automatically."
- echo
- einfo "To return from monitor mode, issue the following command:"
- einfo " ifconfig \${INTERFACE} -mediaopt monitor"
- einfo
- einfo "For aireplay-ng you need FreeBSD >= 7.0."
- fi
-}
diff --git a/net-wireless/aircrack-ng/files/aircrack-ng-1.2_rc4-openssl.patch b/net-wireless/aircrack-ng/files/aircrack-ng-1.2_rc4-openssl.patch
deleted file mode 100644
index a83f622..0000000
--- a/net-wireless/aircrack-ng/files/aircrack-ng-1.2_rc4-openssl.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Index: a/src/crypto.c
-===================================================================
---- a/src/crypto.c (revision 2881)
-+++ b/src/crypto.c (revision 2882)
-@@ -288,7 +288,15 @@
- void calc_mic (struct AP_info *ap, unsigned char pmk[32], unsigned char ptk[80], unsigned char mic[20]) {
- int i;
- unsigned char pke[100];
-+ #if defined(USE_GCRYPT) || OPENSSL_VERSION_NUMBER < 0x10100000L
-+ #define HMAC_USE_NO_PTR
-+ #endif
-+
-+ #ifdef HMAC_USE_NO_PTR
- HMAC_CTX ctx;
-+ #else
-+ HMAC_CTX * ctx;
-+ #endif
-
- memcpy( pke, "Pairwise key expansion", 23 );
-
-@@ -314,6 +322,7 @@
- memcpy( pke + 67, ap->wpa.snonce, 32 );
- }
-
-+ #ifdef HMAC_USE_NO_PTR
- HMAC_CTX_init(&ctx);
- HMAC_Init_ex(&ctx, pmk, 32, EVP_sha1(), NULL);
- for(i = 0; i < 4; i++ )
-@@ -325,6 +334,20 @@
- HMAC_Final(&ctx, ptk + i*20, NULL);
- }
- HMAC_CTX_cleanup(&ctx);
-+ #else
-+ ctx = HMAC_CTX_new();
-+ HMAC_Init_ex(ctx, pmk, 32, EVP_sha1(), NULL);
-+ for(i = 0; i < 4; i++ )
-+ {
-+ pke[99] = i;
-+ //HMAC(EVP_sha1(), values[0], 32, pke, 100, ptk + i * 20, NULL);
-+ HMAC_Init_ex(ctx, 0, 0, 0, 0);
-+ HMAC_Update(ctx, pke, 100);
-+ HMAC_Final(ctx, ptk + i*20, NULL);
-+ }
-+ HMAC_CTX_free(ctx);
-+ #endif
-+ #undef HMAC_USE_NO_PTR
-
- if( ap->wpa.keyver == 1 )
- {
diff --git a/net-wireless/aircrack-ng/metadata.xml b/net-wireless/aircrack-ng/metadata.xml
deleted file mode 100644
index 7e8481f..0000000
--- a/net-wireless/aircrack-ng/metadata.xml
+++ /dev/null
@@ -1,29 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>zerochaos@gentoo.org</email>
- <name>Rick Farina</name>
- <description>Also on the upstream team</description>
-</maintainer>
-<maintainer type="project">
- <email>netmon@gentoo.org</email>
- <name>Gentoo network monitoring and analysis project</name>
-</maintainer>
-<maintainer type="project">
- <email>crypto@gentoo.org</email>
- <name>Crypto</name>
-</maintainer>
-<longdescription>
- aircrack is a set of tools for auditing wireless networks.
- aircrack-ng is the next generation of aircrack with lots of new features.
- (from http://www.aircrack-ng.org)
-</longdescription>
-<use>
- <flag name="airdrop-ng">Build airdrop-ng</flag>
- <flag name="airgraph-ng">Build airgraph-ng</flag>
- <flag name="experimental">Build the "experimental" tools which may randomly fail to run properly</flag>
- <flag name="netlink">Use netlink for channel control instead of WEXT</flag>
- <flag name="unstable">Build the "unstable" tools which may randomly fail to run properly</flag>
-</use>
-</pkgmetadata>