aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-04-12 18:04:45 -0700
committerorbea <orbea@riseup.net>2023-04-12 18:04:45 -0700
commit6f759040d6a00cb55391e07d9bcb039f7d0f8473 (patch)
tree193fa1384b1c8314aecf8499285db276d1329802
parentapp-emulation/spice: stabilize 0.15.1-r1 for ppc64 (diff)
downloadlibressl-6f759040.tar.gz
libressl-6f759040.tar.bz2
libressl-6f759040.zip
app-text/mupdf: drop 1.20.0, 1.20.3
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--app-text/mupdf/Manifest2
-rw-r--r--app-text/mupdf/files/mupdf-1.20.0-lcms2.patch69
-rw-r--r--app-text/mupdf/metadata.xml3
-rw-r--r--app-text/mupdf/mupdf-1.20.0.ebuild160
-rw-r--r--app-text/mupdf/mupdf-1.20.3.ebuild161
5 files changed, 3 insertions, 392 deletions
diff --git a/app-text/mupdf/Manifest b/app-text/mupdf/Manifest
index f87bb21..34a0dc1 100644
--- a/app-text/mupdf/Manifest
+++ b/app-text/mupdf/Manifest
@@ -1,3 +1 @@
DIST mupdf-1.19.1-source.tar.xz 64884172 BLAKE2B a0dc3783c70cee1b7eb48d1658eb48186e35a42513aa9e98f7155bb82ed771ed0c5d5032013d09d93cdca4f49deda65553fe0e1af7645893722dafa855b2c958 SHA512 d6bc5b6adb6a418de50021864f4b3a75da653fa534eeedbfe9875cb202efeb13efdec66b4d108ca8fa6b0dc76733468b214e5fdf331bebc35fc6f722203fa3f7
-DIST mupdf-1.20.0-source.tar.gz 88455853 BLAKE2B 686d8b02972fc6cb7fa4541e4f0561c11e616f800decd20a79f23b577977785633bd3e17e2007f621db97dab6db1fcf500ac8e283984fbe675a25e7a4301b75b SHA512 6837299c589ece9cc443b027433fa3eee545f5155aeb6359b7a43da239d2e99195e9ae3950ddec6cb6ebae77bc877573c6f89a90754c58723d7e87d9739ed1f4
-DIST mupdf-1.20.3-source.tar.gz 88457290 BLAKE2B b16abfd4d9ac8123f1be60350d6124b8f36b6e8260f266d4dc7798610819128519944de8179a9e5453bc28da695ef8557fd8d755439113e520a8cad19039e52f SHA512 ed3fe09971223c500fb85558bb3f8c4a605c82fca3cd2217cdf4758e44bdfe3ef4106c95037d7a8ea536117414e5acbfa14aa736bfb7e33e591050c12c07a0ee
diff --git a/app-text/mupdf/files/mupdf-1.20.0-lcms2.patch b/app-text/mupdf/files/mupdf-1.20.0-lcms2.patch
deleted file mode 100644
index a5cb30e..0000000
--- a/app-text/mupdf/files/mupdf-1.20.0-lcms2.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From d98de0bb0b627772625c1acf050ba0dd4b5ac9df Mon Sep 17 00:00:00 2001
-From: David Seifert <soap@gentoo.org>
-Date: Tue, 5 Jul 2022 11:35:28 +0200
-Subject: [PATCH] Perform type punning via union without undefined behavior
-
-* The previous code from c3d7f491e2daebda2413fb3d2935c51df1c50ac7
- still contains undefined behavior, since it just creates
- temporary pointer variables.
----
- src/cmsplugin.c | 31 +++++++++++++++----------------
- 1 file changed, 15 insertions(+), 16 deletions(-)
-
-This patch slightly differs from the upstream commit, because
-the lcms2 version used in mupdf is slightly behind the upstream
-version.
-
-See: https://github.com/mm2/Little-CMS/commit/d98de0bb0b627772625c1acf050ba0dd4b5ac9df.patch
-
-diff --git a/src/cmsplugin.c b/src/cmsplugin.c
-index 556fbc28..b34e3aab 100644
---- a/thirdparty/lcms2/src/cmsplugin.c
-+++ b/thirdparty/lcms2/src/cmsplugin.c
-@@ -167,17 +167,20 @@ cmsBool CMSEXPORT _cmsReadUInt32Number(cmsContext ContextID, cmsIOHANDLER* io,
-
- cmsBool CMSEXPORT _cmsReadFloat32Number(cmsContext ContextID, cmsIOHANDLER* io, cmsFloat32Number* n)
- {
-- cmsUInt32Number tmp;
-+ union typeConverter {
-+ cmsUInt32Number integer;
-+ cmsFloat32Number floating_point;
-+ } tmp;
-
- _cmsAssert(io != NULL);
-
-- if (io->Read(ContextID, io, &tmp, sizeof(cmsUInt32Number), 1) != 1)
-+ if (io->Read(ContextID, io, &tmp.integer, sizeof(cmsUInt32Number), 1) != 1)
- return FALSE;
-
- if (n != NULL) {
-
-- tmp = _cmsAdjustEndianess32(tmp);
-- *n = *(cmsFloat32Number*)(void*)&tmp;
-+ tmp.integer = _cmsAdjustEndianess32(tmp.integer);
-+ *n = tmp.floating_point;
-
- // Safeguard which covers against absurd values
- if (*n > 1E+20 || *n < -1E+20) return FALSE;
-@@ -304,13 +307,14 @@ cmsBool CMSEXPORT _cmsWriteUInt32Number(cmsContext ContextID, cmsIOHANDLER* io,
-
- cmsBool CMSEXPORT _cmsWriteFloat32Number(cmsContext ContextID, cmsIOHANDLER* io, cmsFloat32Number n)
- {
-- cmsUInt32Number tmp;
--
-- _cmsAssert(io != NULL);
--
-- tmp = *(cmsUInt32Number*) (void*) &n;
-- tmp = _cmsAdjustEndianess32(tmp);
-- if (io -> Write(ContextID, io, sizeof(cmsUInt32Number), &tmp) != 1)
-+ union typeConverter {
-+ cmsUInt32Number integer;
-+ cmsFloat32Number floating_point;
-+ } tmp;
-+
-+ tmp.floating_point = n;
-+ tmp.integer = _cmsAdjustEndianess32(tmp.integer);
-+ if (io -> Write(ContextID, io, sizeof(cmsUInt32Number), &tmp.integer) != 1)
- return FALSE;
-
- return TRUE;
diff --git a/app-text/mupdf/metadata.xml b/app-text/mupdf/metadata.xml
index 5d2f87c..c0d6177 100644
--- a/app-text/mupdf/metadata.xml
+++ b/app-text/mupdf/metadata.xml
@@ -9,4 +9,7 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <use>
+ <flag name="drm">Enable support for Digital rights management (DRM)</flag>
+ </use>
</pkgmetadata>
diff --git a/app-text/mupdf/mupdf-1.20.0.ebuild b/app-text/mupdf/mupdf-1.20.0.ebuild
deleted file mode 100644
index b3865ab..0000000
--- a/app-text/mupdf/mupdf-1.20.0.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Please check upstream git regularly for relevant security-related commits
-# to backport.
-
-inherit desktop flag-o-matic toolchain-funcs xdg
-
-DESCRIPTION="A lightweight PDF viewer and toolkit written in portable C"
-HOMEPAGE="https://mupdf.com/ https://git.ghostscript.com/?p=mupdf.git"
-SRC_URI="https://mupdf.com/downloads/archive/${P}-source.tar.gz"
-S="${WORKDIR}"/${P}-source
-
-LICENSE="AGPL-3"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 x86"
-IUSE="+javascript opengl ssl X"
-REQUIRED_USE="opengl? ( javascript )"
-
-# Although we use the bundled, patched version of freeglut in mupdf (because of
-# bug #653298), the best way to ensure that its dependencies are present is to
-# install system's freeglut.
-RDEPEND="
- dev-libs/gumbo
- media-libs/freetype:2=
- media-libs/harfbuzz:=[truetype]
- media-libs/jbig2dec:=
- media-libs/libpng:0=
- >=media-libs/openjpeg-2.1:2=
- >=media-libs/libjpeg-turbo-1.5.3-r2:0
- javascript? ( >=dev-lang/mujs-1.0.7:= )
- opengl? ( >=media-libs/freeglut-3.0.0 )
- ssl? ( >=dev-libs/openssl-1.1:0= )
- X? (
- x11-libs/libX11
- x11-libs/libXext
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="X? ( x11-base/xorg-proto )
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.15-CFLAGS.patch
- "${FILESDIR}"/${PN}-1.19.0-Makefile.patch
- "${FILESDIR}"/${PN}-1.10a-add-desktop-pc-xpm-files.patch
- "${FILESDIR}"/${PN}-1.19.0-darwin.patch
- # See bugs #662352
- "${FILESDIR}"/${PN}-1.15-openssl-x11.patch
- # General cross fixes from Debian (refreshed)
- "${FILESDIR}"/${PN}-1.19.0-cross-fixes.patch
- "${FILESDIR}"/${P}-lcms2.patch
- "${FILESDIR}"/${PN}-1.20.3-libressl.patch
-)
-
-src_prepare() {
- default
-
- use hppa && append-cflags -ffunction-sections
-
- append-cflags "-DFZ_ENABLE_JS=$(usex javascript 1 0)"
-
- sed -e "1iOS = Linux" \
- -e "1iCC = $(tc-getCC)" \
- -e "1iCXX = $(tc-getCXX)" \
- -e "1iLD = $(tc-getLD)" \
- -e "1iAR = $(tc-getAR)" \
- -e "1iverbose = yes" \
- -e "1ibuild = debug" \
- -i Makerules || die "Failed adding build variables to Makerules in src_prepare()"
-
- # Adjust MuPDF version in .pc file created by the
- # mupdf-1.10a-add-desktop-pc-xpm-files.patch file
- sed -e "s/Version: \(.*\)/Version: ${PV}/" \
- -i platform/debian/${PN}.pc || die "Failed substituting version in ${PN}.pc"
-}
-
-_emake() {
- # When HAVE_OBJCOPY is yes, we end up with a lot of QA warnings.
- #
- # Bundled libs
- # * General
- # Note that USE_SYSTEM_LIBS=yes is a metaoption which will set to upstream's
- # recommendations. It does not mean "always use system libs".
- # See [0] below for what it means in a specific version.
- #
- # * freeglut
- # We don't use system's freeglut because upstream has a special modified
- # version of it that gives mupdf clipboard support. See bug #653298
- #
- # * mujs
- # As of v1.15.0, mupdf started using symbols in mujs that were not part
- # of any release. We then went back to using the bundled version of it.
- # But v1.17.0 looks ok, so we'll go unbundled again. Be aware of this risk
- # when bumping and check!
- # See bug #685244
- #
- # * lmms2
- # mupdf uses a bundled version of lcms2 [0] because Artifex have forked it [1].
- # It is therefore not appropriate for us to unbundle it at this time.
- #
- # [0] https://git.ghostscript.com/?p=mupdf.git;a=blob;f=Makethird;h=c4c540fa4a075df0db85e6fdaab809099881f35a;hb=HEAD#l9
- # [1] https://www.ghostscript.com/doc/lcms2mt/doc/WhyThisFork.txt
- local myemakeargs=(
- GENTOO_PV=${PV}
- HAVE_GLUT=$(usex opengl)
- HAVE_LIBCRYPTO=$(usex ssl)
- HAVE_X11=$(usex X)
- USE_SYSTEM_LIBS=yes
- USE_SYSTEM_MUJS=$(usex javascript)
- USE_SYSTEM_GLUT=no
- HAVE_OBJCOPY=no
- "$@"
- )
-
- emake "${myemakeargs[@]}"
-}
-
-src_compile() {
- tc-export PKG_CONFIG
-
- _emake XCFLAGS="-fPIC"
-}
-
-src_install() {
- if use opengl || use X ; then
- domenu platform/debian/${PN}.desktop
- doicon platform/debian/${PN}.xpm
- else
- rm docs/man/${PN}.1 || die "Failed to remove man page in src_install()"
- fi
-
- sed -i \
- -e "1iprefix = ${ED}/usr" \
- -e "1ilibdir = ${ED}/usr/$(get_libdir)" \
- -e "1idocdir = ${ED}/usr/share/doc/${PF}" \
- -i Makerules || die "Failed adding liprefix, lilibdir and lidocdir to Makerules in src_install()"
-
- _emake install
-
- dosym libmupdf.so.${PV} /usr/$(get_libdir)/lib${PN}.so
-
- if use opengl ; then
- einfo "mupdf symlink points to mupdf-gl (bug 616654)"
- dosym ${PN}-gl /usr/bin/${PN}
- elif use X ; then
- einfo "mupdf symlink points to mupdf-x11 (bug 616654)"
- dosym ${PN}-x11 /usr/bin/${PN}
- fi
-
- # Respect libdir (bug #734898)
- sed -i -e "s:/lib:/$(get_libdir):" platform/debian/${PN}.pc || die "Failed to sed pkgconfig file to respect libdir in src_install()"
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins platform/debian/${PN}.pc
-
- dodoc README CHANGES CONTRIBUTORS
-}
diff --git a/app-text/mupdf/mupdf-1.20.3.ebuild b/app-text/mupdf/mupdf-1.20.3.ebuild
deleted file mode 100644
index a02d3f0..0000000
--- a/app-text/mupdf/mupdf-1.20.3.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Please check upstream git regularly for relevant security-related commits
-# to backport.
-
-inherit desktop flag-o-matic toolchain-funcs xdg
-
-DESCRIPTION="A lightweight PDF viewer and toolkit written in portable C"
-HOMEPAGE="https://mupdf.com/ https://git.ghostscript.com/?p=mupdf.git"
-SRC_URI="https://mupdf.com/downloads/archive/${P}-source.tar.gz"
-S="${WORKDIR}"/${P}-source
-
-LICENSE="AGPL-3"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 x86"
-IUSE="+javascript opengl ssl X"
-REQUIRED_USE="opengl? ( javascript )"
-
-# Although we use the bundled, patched version of freeglut in mupdf (because of
-# bug #653298), the best way to ensure that its dependencies are present is to
-# install system's freeglut.
-RDEPEND="
- dev-libs/gumbo
- media-libs/freetype:2
- media-libs/harfbuzz:=[truetype]
- media-libs/jbig2dec:=
- media-libs/libpng:0=
- >=media-libs/openjpeg-2.1:2=
- >=media-libs/libjpeg-turbo-1.5.3-r2:0=
- javascript? ( >=dev-lang/mujs-1.0.7:= )
- opengl? ( >=media-libs/freeglut-3.0.0 )
- ssl? ( >=dev-libs/openssl-1.1:0= )
- sys-libs/zlib
- X? (
- x11-libs/libX11
- x11-libs/libXext
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="X? ( x11-base/xorg-proto )
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.15-CFLAGS.patch
- "${FILESDIR}"/${PN}-1.19.0-Makefile.patch
- "${FILESDIR}"/${PN}-1.10a-add-desktop-pc-xpm-files.patch
- "${FILESDIR}"/${PN}-1.19.0-darwin.patch
- # See bugs #662352
- "${FILESDIR}"/${PN}-1.15-openssl-x11.patch
- # General cross fixes from Debian (refreshed)
- "${FILESDIR}"/${PN}-1.19.0-cross-fixes.patch
- "${FILESDIR}"/${PN}-1.20.0-lcms2.patch
- "${FILESDIR}"/${PN}-1.20.3-libressl.patch
-)
-
-src_prepare() {
- default
-
- use hppa && append-cflags -ffunction-sections
-
- append-cflags "-DFZ_ENABLE_JS=$(usex javascript 1 0)"
-
- sed -e "1iOS = Linux" \
- -e "1iCC = $(tc-getCC)" \
- -e "1iCXX = $(tc-getCXX)" \
- -e "1iLD = $(tc-getLD)" \
- -e "1iAR = $(tc-getAR)" \
- -e "1iverbose = yes" \
- -e "1ibuild = debug" \
- -i Makerules || die "Failed adding build variables to Makerules in src_prepare()"
-
- # Adjust MuPDF version in .pc file created by the
- # mupdf-1.10a-add-desktop-pc-xpm-files.patch file
- sed -e "s/Version: \(.*\)/Version: ${PV}/" \
- -i platform/debian/${PN}.pc || die "Failed substituting version in ${PN}.pc"
-}
-
-_emake() {
- # When HAVE_OBJCOPY is yes, we end up with a lot of QA warnings.
- #
- # Bundled libs
- # * General
- # Note that USE_SYSTEM_LIBS=yes is a metaoption which will set to upstream's
- # recommendations. It does not mean "always use system libs".
- # See [0] below for what it means in a specific version.
- #
- # * freeglut
- # We don't use system's freeglut because upstream has a special modified
- # version of it that gives mupdf clipboard support. See bug #653298
- #
- # * mujs
- # As of v1.15.0, mupdf started using symbols in mujs that were not part
- # of any release. We then went back to using the bundled version of it.
- # But v1.17.0 looks ok, so we'll go unbundled again. Be aware of this risk
- # when bumping and check!
- # See bug #685244
- #
- # * lmms2
- # mupdf uses a bundled version of lcms2 [0] because Artifex have forked it [1].
- # It is therefore not appropriate for us to unbundle it at this time.
- #
- # [0] https://git.ghostscript.com/?p=mupdf.git;a=blob;f=Makethird;h=c4c540fa4a075df0db85e6fdaab809099881f35a;hb=HEAD#l9
- # [1] https://www.ghostscript.com/doc/lcms2mt/doc/WhyThisFork.txt
- local myemakeargs=(
- GENTOO_PV=${PV}
- HAVE_GLUT=$(usex opengl)
- HAVE_LIBCRYPTO=$(usex ssl)
- HAVE_X11=$(usex X)
- USE_SYSTEM_LIBS=yes
- USE_SYSTEM_MUJS=$(usex javascript)
- USE_SYSTEM_GLUT=no
- HAVE_OBJCOPY=no
- "$@"
- )
-
- emake "${myemakeargs[@]}"
-}
-
-src_compile() {
- tc-export PKG_CONFIG
-
- _emake XCFLAGS="-fPIC"
-}
-
-src_install() {
- if use opengl || use X ; then
- domenu platform/debian/${PN}.desktop
- doicon platform/debian/${PN}.xpm
- else
- rm docs/man/${PN}.1 || die "Failed to remove man page in src_install()"
- fi
-
- sed -i \
- -e "1iprefix = ${ED}/usr" \
- -e "1ilibdir = ${ED}/usr/$(get_libdir)" \
- -e "1idocdir = ${ED}/usr/share/doc/${PF}" \
- -i Makerules || die "Failed adding liprefix, lilibdir and lidocdir to Makerules in src_install()"
-
- _emake install
-
- dosym libmupdf.so.${PV} /usr/$(get_libdir)/lib${PN}.so
-
- if use opengl ; then
- einfo "mupdf symlink points to mupdf-gl (bug 616654)"
- dosym ${PN}-gl /usr/bin/${PN}
- elif use X ; then
- einfo "mupdf symlink points to mupdf-x11 (bug 616654)"
- dosym ${PN}-x11 /usr/bin/${PN}
- fi
-
- # Respect libdir (bug #734898)
- sed -i -e "s:/lib:/$(get_libdir):" platform/debian/${PN}.pc || die "Failed to sed pkgconfig file to respect libdir in src_install()"
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins platform/debian/${PN}.pc
-
- dodoc README CHANGES CONTRIBUTORS
-}