aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-02-07 10:53:29 +0200
committerStefan Strogin <steils@gentoo.org>2020-02-07 10:53:29 +0200
commitca50ec49c022566889fc7d4aed77e60a4f68da77 (patch)
treee64b5d71826c0436d6c8f396e21b2a5899890455
parentnet-libs/nodejs: drop old (diff)
downloadlibressl-ca50ec49.tar.gz
libressl-ca50ec49.tar.bz2
libressl-ca50ec49.zip
app-crypt/qca: sync; 2.2.1 stable for amd64, arm64, x86
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--app-crypt/qca/qca-2.2.1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/app-crypt/qca/qca-2.2.1.ebuild b/app-crypt/qca/qca-2.2.1.ebuild
index dcb155a..48cd52e 100644
--- a/app-crypt/qca/qca-2.2.1.ebuild
+++ b/app-crypt/qca/qca-2.2.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils qmake-utils
+inherit cmake qmake-utils
DESCRIPTION="Qt Cryptographic Architecture (QCA)"
HOMEPAGE="https://userbase.kde.org/QCA"
@@ -11,9 +11,10 @@ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="2"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+KEYWORDS="amd64 ~arm arm64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="botan debug doc examples gcrypt gpg libressl logger nss pkcs11 sasl softstore +ssl test"
+RESTRICT="!test? ( test )"
BDEPEND="
doc? ( app-doc/doxygen )
@@ -66,16 +67,16 @@ src_configure() {
$(qca_plugin_use ssl ossl)
-DBUILD_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
- cmake-utils_src_test
+ cmake_src_test
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use doc; then
pushd "${BUILD_DIR}" >/dev/null || die