aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-04-29 16:40:26 -0700
committerQuentin Retornaz <gentoo@retornaz.com>2022-05-01 02:17:38 +0200
commiteefe807a0f692c62161d6acefc3957bdacba0f22 (patch)
tree291afc3fe720b0bc806391058b9e18d0a24d6024
parentdev-libs/libressl: Update ebuild (diff)
downloadlibressl-eefe807a.tar.gz
libressl-eefe807a.tar.bz2
libressl-eefe807a.zip
dev-libs/libressl: Remove old patches
Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/libressl/pull/399 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
-rw-r--r--dev-libs/libressl/files/libressl-2.9.2-non-glibc.patch32
-rw-r--r--dev-libs/libressl/files/libressl-3.2.2-build.patch56
-rw-r--r--dev-libs/libressl/files/libressl-3.4.0-x509.patch51
3 files changed, 0 insertions, 139 deletions
diff --git a/dev-libs/libressl/files/libressl-2.9.2-non-glibc.patch b/dev-libs/libressl/files/libressl-2.9.2-non-glibc.patch
deleted file mode 100644
index b00316d..0000000
--- a/dev-libs/libressl/files/libressl-2.9.2-non-glibc.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From a9f0b2143c3154da34b8798127263f6f11f61bd5 Mon Sep 17 00:00:00 2001
-From: Ishimoto Shinobu <47295761+protonesso@users.noreply.github.com>
-Date: Tue, 21 May 2019 22:41:05 +0900
-Subject: [PATCH] avoid glibc
-
-cause problems on musl systems
-
-Upstream-Status: Backport
-[https://github.com/libressl-portable/portable/pull/529]
-Signed-off-by: Stefan Strogin <steils@gentoo.org>
----
- crypto/compat/getprogname_linux.c | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/crypto/compat/getprogname_linux.c b/crypto/compat/getprogname_linux.c
-index 2c89743..4e7e31f 100644
---- a/crypto/compat/getprogname_linux.c
-+++ b/crypto/compat/getprogname_linux.c
-@@ -26,9 +26,7 @@ getprogname(void)
- #if defined(__ANDROID_API__) && __ANDROID_API__ < 21
- extern const char *__progname;
- return __progname;
--#elif defined(__GLIBC__)
-- return program_invocation_short_name;
- #else
--#error "Cannot emulate getprogname"
-+ return program_invocation_short_name;
- #endif
- }
---
-2.21.0
-
diff --git a/dev-libs/libressl/files/libressl-3.2.2-build.patch b/dev-libs/libressl/files/libressl-3.2.2-build.patch
deleted file mode 100644
index 586e7a7..0000000
--- a/dev-libs/libressl/files/libressl-3.2.2-build.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 9abd36e3af5876f67c633f27496ad5660ab7fe24 Mon Sep 17 00:00:00 2001
-From: Brent Cook <busterb@gmail.com>
-Date: Sun, 18 Oct 2020 22:14:03 -0500
-Subject: [PATCH] modify nc build to link libcompat objects directly
-
-Rather than assuming the static version of libcrypto exists for pulling in the compatibility functions, link the compat objects directly. This modifies the object file generation script a bit to handle the empty-case properly as well.
----
- apps/nc/Makefile.am | 8 ++++++--
- crypto/Makefile.am | 4 ++--
- 2 files changed, 8 insertions(+), 4 deletions(-)
-
-diff --git a/apps/nc/Makefile.am b/apps/nc/Makefile.am
-index d678f1eda..58b5c0118 100644
---- a/apps/nc/Makefile.am
-+++ b/apps/nc/Makefile.am
-@@ -1,5 +1,7 @@
- include $(top_srcdir)/Makefile.am.common
-
-+-include $(abs_top_builddir)/crypto/libcrypto_la_objects.mk
-+
- if BUILD_NC
-
- if ENABLE_NC
-@@ -12,11 +14,13 @@ endif
- EXTRA_DIST = nc.1
- EXTRA_DIST += CMakeLists.txt
-
--nc_LDFLAGS = $(abs_top_builddir)/crypto/.libs/libcrypto.a
--
- nc_LDADD = $(abs_top_builddir)/tls/libtls.la
- nc_LDADD += $(PLATFORM_LDADD) $(PROG_LDADD)
-
-+nc_LDADD += $(libcrypto_la_objects)
-+nc_LDADD += $(libcompat_la_objects)
-+nc_LDADD += $(libcompatnoopt_la_objects)
-+
- AM_CPPFLAGS += -I$(top_srcdir)/apps/nc/compat
-
- nc_SOURCES = atomicio.c
-diff --git a/crypto/Makefile.am b/crypto/Makefile.am
-index 97a84e1a7..e32ca96c3 100644
---- a/crypto/Makefile.am
-+++ b/crypto/Makefile.am
-@@ -99,10 +99,10 @@ libcrypto_la_objects.mk: Makefile
- | sed 's/ */ $$\(abs_top_builddir\)\/crypto\//g' \
- > libcrypto_la_objects.mk
- @echo "libcompat_la_objects= $(libcompat_la_OBJECTS)" \
-- | sed 's/ */ $$\(abs_top_builddir\)\/crypto\//g' \
-+ | sed 's/compat\// $$\(abs_top_builddir\)\/crypto\/&/g' \
- >> libcrypto_la_objects.mk
- @echo "libcompatnoopt_la_objects= $(libcompatnoopt_la_OBJECTS)" \
-- | sed 's/ */ $$\(abs_top_builddir\)\/crypto\//g' \
-+ | sed 's/compat\// $$\(abs_top_builddir\)\/crypto\/&/g' \
- >> libcrypto_la_objects.mk
-
- libcrypto_la_LDFLAGS = -version-info @LIBCRYPTO_VERSION@ -no-undefined -export-symbols crypto_portable.sym
diff --git a/dev-libs/libressl/files/libressl-3.4.0-x509.patch b/dev-libs/libressl/files/libressl-3.4.0-x509.patch
deleted file mode 100644
index c7d83e0..0000000
--- a/dev-libs/libressl/files/libressl-3.4.0-x509.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/crypto/x509/x509_constraints.c b/crypto/x509/x509_constraints.c
-index fade58c..9ad5d4b 100644
---- a/crypto/x509/x509_constraints.c
-+++ b/crypto/x509/x509_constraints.c
-@@ -339,16 +339,16 @@ x509_constraints_parse_mailbox(uint8_t *candidate, size_t len,
- if (c == '.')
- goto bad;
- }
-- if (wi > DOMAIN_PART_MAX_LEN)
-- goto bad;
- if (accept) {
-+ if (wi > DOMAIN_PART_MAX_LEN)
-+ goto bad;
- working[wi++] = c;
- accept = 0;
- continue;
- }
- if (candidate_local != NULL) {
- /* We are looking for the domain part */
-- if (wi > DOMAIN_PART_MAX_LEN)
-+ if (wi >= DOMAIN_PART_MAX_LEN)
- goto bad;
- working[wi++] = c;
- if (i == len - 1) {
-@@ -363,7 +363,7 @@ x509_constraints_parse_mailbox(uint8_t *candidate, size_t len,
- continue;
- }
- /* We are looking for the local part */
-- if (wi > LOCAL_PART_MAX_LEN)
-+ if (wi >= LOCAL_PART_MAX_LEN)
- break;
-
- if (quoted) {
-@@ -383,6 +383,8 @@ x509_constraints_parse_mailbox(uint8_t *candidate, size_t len,
- */
- if (c == 9)
- goto bad;
-+ if (wi >= LOCAL_PART_MAX_LEN)
-+ goto bad;
- working[wi++] = c;
- continue; /* all's good inside our quoted string */
- }
-@@ -412,6 +414,8 @@ x509_constraints_parse_mailbox(uint8_t *candidate, size_t len,
- }
- if (!local_part_ok(c))
- goto bad;
-+ if (wi >= LOCAL_PART_MAX_LEN)
-+ goto bad;
- working[wi++] = c;
- }
- if (candidate_local == NULL || candidate_domain == NULL)