aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-08-06 14:09:45 -0700
committerorbea <orbea@riseup.net>2023-08-06 14:40:32 -0700
commitef06d6e7097565e96e08ff96f83bad035d1779ac (patch)
tree474a567fbc0df54d314e7e8c9bc438721d721729
parentdev-python/m2crypto: stabilize 0.39.0 for ppc (diff)
downloadlibressl-ef06d6e7.tar.gz
libressl-ef06d6e7.tar.bz2
libressl-ef06d6e7.zip
dev-python/m2crypto: drop 0.38.0
Signed-off-by: orbea <orbea@riseup.net>
-rw-r--r--dev-python/m2crypto/Manifest1
-rw-r--r--dev-python/m2crypto/m2crypto-0.38.0.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/m2crypto/Manifest b/dev-python/m2crypto/Manifest
index 1c1e9fc..7634d00 100644
--- a/dev-python/m2crypto/Manifest
+++ b/dev-python/m2crypto/Manifest
@@ -1,2 +1 @@
-DIST M2Crypto-0.38.0.tar.gz 1241269 BLAKE2B 95433090e08ff72cd2b0779491dc38b89eca159b26812e763b5b8973e3d27249a96d5a2c983b59f414184f64beb8e455dc26979310378db89dd2081741d4d17d SHA512 b1e24e3101ce0dd9f17be4cabeddc2ec0f1228b270d74ef2fb38bae8807c5025b031d0743185f06370786a3dd5c3f42129720534dcff07ea4de3c727613f8d20
DIST M2Crypto-0.39.0.tar.gz 1248372 BLAKE2B f89793b847fae3c51a0ea79c3ba861d26b53fa12b2c8d68c3b3476bb2c944b586e875bea0c4693c213e024024096a06de0734631e546c4284d65fc5494784476 SHA512 5d8210c6204fd71f06d238c5b1fe08dd38d6b8e92db7b1e433a9e4e2fe9af46d6d55df7550716a7d05328fb3c9eed427f015b7d5a1fe33a073f0af15a82ab050
diff --git a/dev-python/m2crypto/m2crypto-0.38.0.ebuild b/dev-python/m2crypto/m2crypto-0.38.0.ebuild
deleted file mode 100644
index 7fe833d..0000000
--- a/dev-python/m2crypto/m2crypto-0.38.0.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 2018-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_EXT=1
-PYTHON_COMPAT=( python3_{9..11} )
-PYPI_NO_NORMALIZE=1
-PYPI_PN="M2Crypto"
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs pypi
-
-DESCRIPTION="A Python crypto and SSL toolkit"
-HOMEPAGE="https://gitlab.com/m2crypto/m2crypto https://pypi.org/project/M2Crypto/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="test abi_mips_n32 abi_mips_n64 abi_mips_o32"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- >=dev-lang/swig-2.0.9
- test? ( dev-python/parameterized[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- dev-libs/openssl:0=
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-libressl-0.38.0.patch"
-)
-
-distutils_enable_tests setup.py
-
-swig_define() {
- local x
- for x; do
- if tc-cpp-is-true "defined(${x})"; then
- SWIG_FEATURES+=" -D${x}"
- fi
- done
-}
-
-src_prepare() {
- # relies on very exact clock behavior which apparently fails
- # with inconvenient CONFIG_HZ*
- sed -e 's:test_server_simple_timeouts:_&:' \
- -i tests/test_ssl.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- # setup.py looks at platform.machine() to determine swig options.
- # For exotic ABIs, we need to give swig a hint.
- local -x SWIG_FEATURES=
-
- # https://bugs.gentoo.org/617946
- swig_define __ILP32__
-
- # https://bugs.gentoo.org/674112
- swig_define __ARM_PCS_VFP
-
- # Avoid similar errors to bug #688668 for MIPS
- if use abi_mips_n32; then
- swig_define _MIPS_SIM = _ABIN32
- elif use abi_mips_n64; then
- swig_define _MIPS_SIM = _ABI64
- elif use abi_mips_o32; then
- swig_define _MIPS_SIM = _ABIO32
- fi
-
- distutils-r1_python_compile --openssl="${ESYSROOT}"/usr
-}