summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2017-12-29 23:35:41 +0100
committerMichael Haubenwallner <haubi@gentoo.org>2017-12-29 23:35:41 +0100
commit05bb5e31e97fc42acb9b229c77e13a40eeb53fbd (patch)
treefd24eda9a678aeb33151c7fe1b3811dfea469ab3
parentdev-lang/python: depend on unzip for Cygwin (diff)
downloadprefix-05bb5e31.tar.gz
prefix-05bb5e31.tar.bz2
prefix-05bb5e31.zip
dev-lang/python-2.7: need -L. first in LDFLAGS
Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--dev-lang/python/python-2.7.12.ebuild13
-rw-r--r--dev-lang/python/python-2.7.14.ebuild14
2 files changed, 13 insertions, 14 deletions
diff --git a/dev-lang/python/python-2.7.12.ebuild b/dev-lang/python/python-2.7.12.ebuild
index 040c3847e2..f038c4b118 100644
--- a/dev-lang/python/python-2.7.12.ebuild
+++ b/dev-lang/python/python-2.7.12.ebuild
@@ -229,6 +229,12 @@ src_configure() {
replace-flags -Os -O3 # comment #14
fi
+ # Set LDFLAGS so we link modules with -lpython2.7 correctly.
+ # Needed on FreeBSD unless Python 2.7 is already installed.
+ # Please query BSD team before removing this!
+ # On AIX this is not needed, but would record '.' as runpath.
+ [[ ${CHOST} == *-aix* ]] ||
+ append-ldflags "-L."
if use prefix ; then
# for Python's setup.py not to do false assumptions (only looking in
@@ -255,13 +261,6 @@ src_configure() {
# http://bugs.python.org/issue15506
export ac_cv_path_PKG_CONFIG=$(tc-getPKG_CONFIG)
- # Set LDFLAGS so we link modules with -lpython2.7 correctly.
- # Needed on FreeBSD unless Python 2.7 is already installed.
- # Please query BSD team before removing this!
- # On AIX this is not needed, but would record '.' as runpath.
- [[ ${CHOST} == *-aix* ]] ||
- append-ldflags "-L."
-
local dbmliborder
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
diff --git a/dev-lang/python/python-2.7.14.ebuild b/dev-lang/python/python-2.7.14.ebuild
index a28d5b2709..2ff87b1a6e 100644
--- a/dev-lang/python/python-2.7.14.ebuild
+++ b/dev-lang/python/python-2.7.14.ebuild
@@ -231,6 +231,13 @@ src_configure() {
replace-flags -Os -O3 # comment #14
fi
+ # Set LDFLAGS so we link modules with -lpython2.7 correctly.
+ # Needed on FreeBSD unless Python 2.7 is already installed.
+ # Please query BSD team before removing this!
+ # On AIX this is not needed, but would record '.' as runpath.
+ [[ ${CHOST} == *-aix* ]] ||
+ append-ldflags "-L."
+
if use prefix ; then
# for Python's setup.py not to do false assumptions (only looking in
# host paths) we need to make explicit where Prefix stuff is
@@ -256,13 +263,6 @@ src_configure() {
# http://bugs.python.org/issue15506
export ac_cv_path_PKG_CONFIG=$(tc-getPKG_CONFIG)
- # Set LDFLAGS so we link modules with -lpython2.7 correctly.
- # Needed on FreeBSD unless Python 2.7 is already installed.
- # Please query BSD team before removing this!
- # On AIX this is not needed, but would record '.' as runpath.
- [[ ${CHOST} == *-aix* ]] ||
- append-ldflags "-L."
-
local dbmliborder
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"