summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-03-02 09:50:32 +0100
committerFabian Groffen <grobian@gentoo.org>2017-03-02 09:50:32 +0100
commit063e827f5a54dcaebe12a019a96e91739b2a0bd1 (patch)
treeeabb1b4a537eb319535eb9346da157a3f20275b5
parentbootstrap-prefix.sh: host gcc should not search binutils from PATH (diff)
downloadprefix-063e827f5a54dcaebe12a019a96e91739b2a0bd1.tar.gz
prefix-063e827f5a54dcaebe12a019a96e91739b2a0bd1.tar.bz2
prefix-063e827f5a54dcaebe12a019a96e91739b2a0bd1.zip
sys-apps/portage: version bump to 2.3.4
Package-Manager: Portage-2.3.4-prefix, Repoman-2.3.2
-rw-r--r--sys-apps/portage/Manifest1
-rw-r--r--sys-apps/portage/metadata.xml14
-rw-r--r--sys-apps/portage/portage-2.3.4.ebuild261
3 files changed, 274 insertions, 2 deletions
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index 9c32f7812c..02c3fa864b 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -1,3 +1,4 @@
DIST prefix-portage-2.2.27.tar.bz2 1230727 SHA256 51bf3f427b23dfd1d050a2071895b5134cf7f515eb00612e0f57adf645a38299 SHA512 bb528ee059c7fc06702882eaa9aad33962ad2eff7e468aa51a8b185e8b3e4ba3eaf88b2ee0f61df9c38493f0f37028e471ba2cc766fa53086ad6b975ead9b332 WHIRLPOOL b0601462462d6dd322ffd9e806c92fd425483fc769a8c6b36c5874a4a28e21e250386ce16479e238577754ab4b194ce700bca7a0407dca919d59fd6ada87970c
DIST prefix-portage-2.2.28.tar.bz2 1187416 SHA256 e4bb6c08a65252cfb3faf777ff9bb6aab162174766202f811154c0bbe301b45e SHA512 ea0661783d421d204272b9a210745aa2040a18ea347299b3d768588e10ca8dd2e24b46975249bf30010bf565514aea640f4edb9db2ca064312c899304a8c1f42 WHIRLPOOL d2d3feab14c4b0dc706db9336e08637897d963d0cbd7e1995431701c8c1914f6f42f57917470a2c89cdc8596d2ed8183c80f3814eba7512b5216611595da38a1
DIST prefix-portage-2.3.2.tar.bz2 1243678 SHA256 36486bebdc6462b5748f6175bdef4547bd3f6986136c61b247a0ca998ae4b674 SHA512 0cb5e2919eb2a1898785f03be0753f9d86a858427539991f182f560c8abcc69ed60d146e6884514b5f8532ffbd57a3f2f0bbeb76b0513545d4faf1be3cb949ed WHIRLPOOL 5e56e64988f680fb5d5a23abbc9e0f58c209c0668957d7f4f430ba624ab908c63fa49f3798a069ee08d34de214cf41f565ee96094a25616736b98f4aecf8efb1
+DIST prefix-portage-2.3.4.tar.bz2 1171093 SHA256 2c76c7a12b6f03d59eb366b17673098672be85471a561bceb8b47cc7a68cbca1 SHA512 50014c2e13faa595a40348cddc327fdc5f3325f988576dd5fa6a2132fe2d05967e34db8b9716b16a366347a50f1cdf7837ce02f97539acf3b77d69e8f5fbc065 WHIRLPOOL 7afdfab97d50800f1db86558bba3d3ad3197bc346c8cfe6a14f805f9304c5f11dc4c8ce317913339cebe904f7bb861622c9b15835af085d665b67f0feab03351
diff --git a/sys-apps/portage/metadata.xml b/sys-apps/portage/metadata.xml
index d043d76d3d..23c04a89b2 100644
--- a/sys-apps/portage/metadata.xml
+++ b/sys-apps/portage/metadata.xml
@@ -11,8 +11,18 @@
</maintainer>
<use>
<flag name="epydoc">Build html API documentation with epydoc.</flag>
- <flag name="ipc">Use inter-process communication between portage and running ebuilds.</flag>
- <flag name="xattr">Preserve extended attributes (filesystem-stored metadata) when installing files. Usually only required for hardened systems.</flag>
+ <flag name="ipc">Use inter-process communication between portage and
+ running ebuilds.
+ </flag>
+ <flag name="native-extensions">
+ Compiles native "C" extensions (speedups, instead of using python
+ backup code). Currently includes libc-locales.
+ This should only be temporarily disabled for some bootstrapping
+ operations. Cross-compilation is not supported.
+ </flag>
+ <flag name="xattr">Preserve extended attributes (filesystem-stored metadata)
+ when installing files. Usually only required for hardened systems.
+ </flag>
<flag name="prefix-chaining">mduft's experimental prefix chaining facilities</flag>
</use>
</pkgmetadata>
diff --git a/sys-apps/portage/portage-2.3.4.ebuild b/sys-apps/portage/portage-2.3.4.ebuild
new file mode 100644
index 0000000000..b6ad353aef
--- /dev/null
+++ b/sys-apps/portage/portage-2.3.4.ebuild
@@ -0,0 +1,261 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=(
+ pypy
+ python3_3 python3_4 python3_5 python3_6
+ python2_7
+)
+PYTHON_REQ_USE='bzip2(+),threads(+)'
+
+inherit eutils distutils-r1 multilib
+
+DESCRIPTION="Portage package manager used in Gentoo Prefix"
+HOMEPAGE="http://prefix.gentoo.org/"
+LICENSE="GPL-2"
+KEYWORDS="~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="build doc epydoc +ipc linguas_ru +native-extensions selinux xattr prefix-chaining"
+
+DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ >=sys-apps/sed-4.0.5 sys-devel/patch
+ doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
+ epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )"
+# Require sandbox-2.2 for bug #288863.
+# For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
+# quite slow, so it's not considered in the dependencies as an alternative to
+# to python-3.3 / pyxattr. Also, xattr support is only tested with Linux, so
+# for now, don't pull in xattr deps for other kernels.
+# For whirlpool hash, require python[ssl] (bug #425046).
+# For compgen, require bash[readline] (bug #445576).
+RDEPEND="
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ !build? (
+ >=sys-apps/sed-4.0.5
+ app-shells/bash:0[readline]
+ >=app-admin/eselect-1.2
+ )
+ elibc_FreeBSD? ( !prefix? ( sys-freebsd/freebsd-bin ) )
+ elibc_glibc? ( !prefix? ( >=sys-apps/sandbox-2.2 ) )
+ elibc_uclibc? ( !prefix? ( >=sys-apps/sandbox-2.2 ) )
+ kernel_linux? ( >=app-misc/pax-utils-0.1.17 )
+ kernel_SunOS? ( >=app-misc/pax-utils-0.1.17 )
+ kernel_FreeBSD? ( >=app-misc/pax-utils-0.1.17 )
+ kernel_Darwin? ( >=app-misc/pax-utils-0.1.18 )
+ kernel_AIX? ( >=sys-apps/aix-miscutils-0.1.1634 )
+ selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+ xattr? ( kernel_linux? (
+ >=sys-apps/install-xattr-0.3
+ $(python_gen_cond_dep 'dev-python/pyxattr[${PYTHON_USEDEP}]' \
+ python2_7 pypy)
+ ) )
+ !prefix? ( !<app-admin/logrotate-3.8.0 )"
+PDEPEND="
+ !build? (
+ >=net-misc/rsync-2.6.4
+ userland_GNU? ( >=sys-apps/coreutils-6.4 )
+ )"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# NOTE: FEATURES=installsources requires debugedit and rsync
+
+REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )"
+
+SRC_ARCHIVES="https://dev.gentoo.org/~dolsen/releases/portage http://dev.gentoo.org/~grobian/distfiles"
+
+prefix_src_archives() {
+ local x y
+ for x in ${@}; do
+ for y in ${SRC_ARCHIVES}; do
+ echo ${y}/${x}
+ done
+ done
+}
+
+TARBALL_PV=${PV}
+SRC_URI="mirror://gentoo/prefix-${PN}-${TARBALL_PV}.tar.bz2
+ $(prefix_src_archives prefix-${PN}-${TARBALL_PV}.tar.bz2)"
+
+S="${WORKDIR}"/prefix-${PN}-${TARBALL_PV}
+
+pkg_setup() {
+ use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ epatch "${FILESDIR}"/${PN}-2.2.28-ebuildshell-r1.patch # 155161
+ use prefix-chaining &&
+ epatch "${FILESDIR}"/${PN}-2.2.14-prefix-chaining.patch
+
+ if use native-extensions; then
+ printf "[build_ext]\nportage-ext-modules=true\n" >> \
+ setup.cfg || die
+ fi
+
+ if ! use ipc ; then
+ einfo "Disabling ipc..."
+ sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
+ -i pym/_emerge/AbstractEbuildProcess.py || \
+ die "failed to patch AbstractEbuildProcess.py"
+ fi
+
+ if use xattr && use kernel_linux ; then
+ einfo "Adding FEATURES=xattr to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
+ if [[ -n ${EPREFIX} ]] ; then
+ # PREFIX LOCAL: only hack const_autotool
+ local extrapath="/usr/bin:/bin"
+ # ok, we can't rely on PORTAGE_ROOT_USER being there yet, as people
+ # tend not to update that often, as long as we are a separate ebuild
+ # we can assume when unset, it's time for some older trick
+ if [[ -z ${PORTAGE_ROOT_USER} ]] ; then
+ PORTAGE_ROOT_USER=$(python -c 'from portage.const import rootuser; print rootuser')
+ fi
+ # lazy check, but works for now
+ if [[ ${PORTAGE_ROOT_USER} == "root" ]] ; then
+ # we need this for e.g. mtree on FreeBSD (and Darwin) which is in
+ # /usr/sbin
+ extrapath="/usr/sbin:/usr/bin:/sbin:/bin"
+ fi
+ local defaultpath="${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin"
+ # We need to probe for bash in the Prefix, because it may not
+ # exist, in which case we fall back to the currently in use
+ # bash. This logic is necessary in particular during bootstrap,
+ # where we pull ourselves out of a temporary place with tools
+ local bash="${EPREFIX}/bin/bash"
+ [[ ! -x ${bash} ]] && bash=${BASH}
+
+ einfo "Adjusting sources for ${EPREFIX}"
+ find . -type f -exec \
+ sed -e "s|@PORTAGE_EPREFIX@|${EPREFIX}|" \
+ -e "s|@PORTAGE_MV@|$(type -P mv)|" \
+ -e "s|@PORTAGE_BASH@|${bash}|" \
+ -e "s|@PREFIX_PORTAGE_PYTHON@|$(type -P python)|" \
+ -e "s|@DEFAULT_PATH@|${defaultpath}|" \
+ -e "s|@EXTRA_PATH@|${extrapath}|" \
+ -e "s|@portagegroup@|${PORTAGE_GROUP:-portage}|" \
+ -e "s|@portageuser@|${PORTAGE_USER:-portage}|" \
+ -e "s|@rootuser@|${PORTAGE_ROOT_USER:-root}|" \
+ -e "s|@rootuid@|$(id -u ${PORTAGE_ROOT_USER:-root})|" \
+ -e "s|@rootgid@|$(id -g ${PORTAGE_ROOT_USER:-root})|" \
+ -e "s|@sysconfdir@|${EPREFIX}/etc|" \
+ -i '{}' + || \
+ die "Failed to patch sources"
+ # We don't need the below, since setup.py deal with this (and
+ # more) so we don't have to make this correct
+ # -e "s|@PORTAGE_BASE@|${EPREFIX}/usr/lib/portage/${EPYTHON}|" \
+
+ # remove Makefiles, or else they will get installed
+ find . -name "Makefile.*" -delete
+
+ einfo "Prefixing shebangs ..."
+ while read -r -d $'\0' ; do
+ local shebang=$(head -n1 "$REPLY")
+ if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
+ sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \
+ die "sed failed"
+ fi
+ done < <(find . -type f -print0)
+
+ einfo "Setting gentoo_prefix as reponame for emerge-webrsync"
+ sed -i -e 's/repo_name=gentoo/repo_name=gentoo_prefix/' \
+ bin/emerge-webrsync || die
+ # END PREFIX LOCAL
+ fi
+
+ # PREFIX LOCAL: make.conf is written by bootstrap-prefix.sh
+ if use !prefix ; then
+ cd "${S}/cnf" || die
+ if [ -f "make.conf.example.${ARCH}".diff ]; then
+ patch make.conf.example "make.conf.example.${ARCH}".diff || \
+ die "Failed to patch make.conf.example"
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ fi
+ fi
+}
+
+python_compile_all() {
+ local targets=()
+ use doc && targets+=( docbook )
+ use epydoc && targets+=( epydoc )
+
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local targets=()
+ use doc && targets+=( install_docbook )
+ use epydoc && targets+=( install_epydoc )
+
+ # install docs
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+
+ # Due to distutils/python-exec limitations
+ # these must be installed to /usr/bin.
+ local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
+ einfo "Moving admin scripts to the correct directory"
+ dodir /usr/sbin
+ for target in ${sbin_relocations}; do
+ einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
+ mv "${ED}usr/bin/${target}" "${ED}usr/sbin/${target}" || die "sbin scripts move failed!"
+ done
+}
+
+pkg_preinst() {
+ # comment out sanity test until it is fixed to work
+ # with the new PORTAGE_PYM_PATH
+ #if [[ $ROOT == / ]] ; then
+ ## Run some minimal tests as a sanity check.
+ #local test_runner=$(find "${ED}" -name runTests)
+ #if [[ -n $test_runner && -x $test_runner ]] ; then
+ #einfo "Running preinst sanity tests..."
+ #"$test_runner" || die "preinst sanity tests failed"
+ #fi
+ #fi
+
+ # elog dir must exist to avoid logrotate error for bug #415911.
+ # This code runs in preinst in order to bypass the mapping of
+ # portage:portage to root:root which happens after src_install.
+ keepdir /var/log/portage/elog
+ # This is allowed to fail if the user/group are invalid for prefix users.
+ if chown ${PORTAGE_USER}:${PORTAGE_GROUP} "${ED}"var/log/portage{,/elog} 2>/dev/null ; then
+ chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog}
+ fi
+}