summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2019-02-25 10:58:19 +0100
committerMichael Haubenwallner <haubi@gentoo.org>2019-02-25 10:58:35 +0100
commit2d8d447f040148e4374a00c9fca323e537a92cd1 (patch)
treebb8192c45fbc7728ea5a79188a5104b3b5bf1bbd
parentscripts/bootstrap-prefix: fix invalid atom, thanks Arfrever (diff)
downloadprefix-2d8d447f.tar.gz
prefix-2d8d447f.tar.bz2
prefix-2d8d447f.zip
dev-lang/python: drop .exe from script shebangs
Python creates symlink usr/bin/python3.6.exe->python3.6m.exe and uses usr/bin/python3.6.exe as shebang. As we recreate python3.6 without .exe and Cygwin would resolve python3.6 to both python3.6 and python3.6.exe, we can just drop the .exe extensions from shebangs, even if we won't recreate any symlink. Package-Manager: Portage-2.3.55.1-prefix, Repoman-2.3.12 Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
-rw-r--r--dev-lang/python/python-3.6.6.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-lang/python/python-3.6.6.ebuild b/dev-lang/python/python-3.6.6.ebuild
index 3003efd0da..78ddb6364b 100644
--- a/dev-lang/python/python-3.6.6.ebuild
+++ b/dev-lang/python/python-3.6.6.ebuild
@@ -308,6 +308,12 @@ src_install() {
# Fix collisions between different slots of Python.
rm -f "${ED}usr/$(get_libdir)/libpython3.so"
+ if use elibc_Cygwin; then
+ # We may recreate symlinks, but without any .exe extension. Cygwin
+ # can resolv either without it, so just drop .exe from shebangs:
+ sed -i -e '1s/\.exe//' "$ED"/usr/bin/* || die
+ fi
+
# Cheap hack to get version with ABIFLAGS
local abiver=$(cd "${ED}usr/include"; echo python*)
if [[ ${abiver} != python${PYVER} ]]; then