summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-10-30 17:53:17 +0100
committerFabian Groffen <grobian@gentoo.org>2017-10-30 17:53:17 +0100
commit538297eb9f73edee3a42d564deee08904ebd50f7 (patch)
tree3b794ceb194e272d1eb6088eed1821ba6a946d25
parentdev-lang/python: bump to 3.6.3 (diff)
downloadprefix-538297eb.tar.gz
prefix-538297eb.tar.bz2
prefix-538297eb.zip
dev-lang/python: fix install of 3.6.3 on Darwin
-rw-r--r--dev-lang/python/python-3.6.3.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.6.3.ebuild b/dev-lang/python/python-3.6.3.ebuild
index 6cf6bb0a9a..9a41e071f6 100644
--- a/dev-lang/python/python-3.6.3.ebuild
+++ b/dev-lang/python/python-3.6.3.ebuild
@@ -333,7 +333,7 @@ src_install() {
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local -x PYTHON=./python
+ local -x PYTHON=./python$(sed -n '/BUILDEXE=/s/^.*=\s\+//p' Makefile)
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
local -x DYLD_LIBRARY_PATH=${DYLD_LIBRARY_PATH+${DYLD_LIBRARY_PATH}:}.
else