summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-12-30 12:35:25 +0100
committerFabian Groffen <grobian@gentoo.org>2018-12-30 12:35:49 +0100
commit578a5b4f5715016adb421fbb274daefd9f80ff54 (patch)
tree4f73fbba4a53c0823def643424cd88352c9f66ba
parentRevert "scripts/bootstrap-prefix: add some dep-cycle workarounds from Sam Pfe... (diff)
downloadprefix-578a5b4f.tar.gz
prefix-578a5b4f.tar.bz2
prefix-578a5b4f.zip
sys-apps/coreutils: try and get 8.30 building on darwin9
Package-Manager: Portage-2.3.52.2-prefix, Repoman-2.3.12 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--sys-apps/coreutils/coreutils-8.30.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sys-apps/coreutils/coreutils-8.30.ebuild b/sys-apps/coreutils/coreutils-8.30.ebuild
index 7b19bd0c46..fb0b646972 100644
--- a/sys-apps/coreutils/coreutils-8.30.ebuild
+++ b/sys-apps/coreutils/coreutils-8.30.ebuild
@@ -70,6 +70,16 @@ src_prepare() {
# fixup libstdbuf non-libtool stuff
if [[ ${CHOST} == *-darwin* ]] ; then
+ if [[ ${CHOST} == *-darwin9* ]] ; then
+ # we need replacement libs from libcoreutils.a here in order
+ # to finish the linking
+ sed -i \
+ -e "/src_libstdbuf_so_LDADD/s:$: lib/libcoreutils.a:" \
+ Makefile.in \
+ || die
+ # and we need serial building :(
+ export MAKEOPTS+="-j1"
+ fi
sed -i \
-e "/src_libstdbuf_so_LDFLAGS = -shared/s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/libexec/coreutils/libstdbuf.dylib:" \
Makefile.in \