summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>2016-04-27 15:03:36 +0200
committerMichael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>2016-04-27 15:03:36 +0200
commit8c67d8b37ea1f8ce7e29233e80229fc8fbf9fd35 (patch)
treed98d8a7809f9795765154125cd008dc9f36daeaf
parentscripts/bootstrap-prefix: add libffi to stage2 for python's ctype in order to... (diff)
downloadprefix-8c67d8b3.tar.gz
prefix-8c67d8b3.tar.bz2
prefix-8c67d8b3.zip
prefix-portage: bump ebuildshell patch, bug#155161
-rw-r--r--sys-apps/portage/files/portage-2.2.28-ebuildshell.patch311
-rw-r--r--sys-apps/portage/portage-2.2.28-r1.ebuild259
2 files changed, 570 insertions, 0 deletions
diff --git a/sys-apps/portage/files/portage-2.2.28-ebuildshell.patch b/sys-apps/portage/files/portage-2.2.28-ebuildshell.patch
new file mode 100644
index 0000000000..7e7e71d960
--- /dev/null
+++ b/sys-apps/portage/files/portage-2.2.28-ebuildshell.patch
@@ -0,0 +1,311 @@
+From 096a74009cea9c79bcc2729d18a3cbcb99783aeb Mon Sep 17 00:00:00 2001
+From: Michael Haubenwallner <michael.haubenwallner@salomon.at>
+Date: Wed, 6 Nov 2013 12:40:05 +0100
+Subject: [PATCH] Add ebuildshell feature, bug#155161.
+
+---
+ bin/ebuild.sh | 102 ++++++++++++++++++++++++++++++++++-
+ bin/filter-bash-environment.py | 65 ++++++++++++++++------
+ bin/save-ebuild-env.sh | 2 +-
+ man/make.conf.5 | 6 +++
+ pym/_emerge/AbstractEbuildProcess.py | 1 +
+ pym/portage/const.py | 1 +
+ 6 files changed, 159 insertions(+), 18 deletions(-)
+
+diff --git a/bin/ebuild.sh b/bin/ebuild.sh
+index f1586b2..06c90df 100755
+--- a/bin/ebuild.sh
++++ b/bin/ebuild.sh
+@@ -130,7 +130,7 @@ __qa_source() {
+ __qa_call() {
+ local shopts=$(shopt) OLDIFS="$IFS"
+ local retval
+- "$@"
++ __call-ebuildshell "$@"
+ retval=$?
+ set +e
+ [[ $shopts != $(shopt) ]] &&
+@@ -537,6 +537,106 @@ if [[ -n ${QA_INTERCEPTORS} ]] ; then
+ unset BIN_PATH BIN BODY FUNC_SRC
+ fi
+
++__call-ebuildshell() {
++ if ! has ebuildshell ${FEATURES}; then
++ "$@"
++ return $?
++ fi
++ local __ebuildshell_args=( "$@" )
++ # These are the variables I have seen 'bash -i' maintaining the values for:
++ local __ebuildshell_bash_i_vars="__ebuildshell_.*
++ _ BASH_ARGC BASH_ARGV BASH_COMMAND BASH_LINENO BASH_SOURCE
++ BASH_VERSINFO BASH_SUBSHELL BASHOPTS BASHPID COMP_WORDBREAKS
++ DIRSTACK EUID FUNCNAME GROUPS HISTCMD HISTFILE LINENO
++ PIPESTATUS PPID PWD RANDOM SECONDS SHELLOPTS UID"
++ # Allow recursive ebuildshell, for use in multibuild.eclass and similar:
++ local __ebuildshell_pid=${BASHPID:-$(__bashpid)}
++ local __ebuildshell_tmpf="${T}/ebuildshell.${__ebuildshell_pid}"
++ rm -f "${__ebuildshell_tmpf}."{ebuild,return}-{env,rovars}
++ (
++ (
++ declare -p
++ declare -fp
++ shopt -p
++ [[ ${BASH_VERSINFO[0]} == 3 ]] && export
++ ) |
++ (
++ # we need everything but the bash vars after 'env -i'
++ 2>"${__ebuildshell_tmpf}.ebuild-rovars" \
++ "${PORTAGE_PYTHON:-/tools/haubi/gentoo/s01en24/usr/bin/python}" \
++ "${PORTAGE_BIN_PATH}"/filter-bash-environment.py \
++ --report-readonly-variables \
++ --preserve-readonly-attribute \
++ "${__ebuildshell_bash_i_vars}" \
++ || die "filter-bash-environment.py failed"
++ )
++ # The already readonly variables, without bash maintained ones:
++ __ebuildshell_ro_ebuild_vars=$(<"${__ebuildshell_tmpf}.ebuild-rovars")
++ cat <<-EOE
++ # properly quote the function arguments
++ $(declare -p __ebuildshell_args)
++ set -- "\${__ebuildshell_args[@]}"
++ unset __ebuildshell_args
++ # be informative about what to do
++ PS1="EBUILD ${PN} $1 \$ "
++ type $1
++ echo "WANTED: \$@"
++ echo "or use: \"\\\$@\""
++ # use bash history, but not the user's real one
++ HISTFILE=~/.bash_history
++ # for copy&paste function body lines containing: local
++ alias local=declare
++ # for copy&paste function body lines containing: !
++ set +H
++ # at exit, dump the current environment
++ trap "
++ rm -f '${__ebuildshell_tmpf}.return-'*
++ (
++ (
++ declare -p
++ declare -fp
++ shopt -p | grep -v 'extdebug$'
++ $([[ ${BASH_VERSINFO[0]} == 3 ]] && echo export)
++ ) |
++ (
++ # We may have more readonly variables now, but we
++ # need to filter variables that are readonly already.
++ 2>"${__ebuildshell_tmpf}.return-rovars" \
++ '${PORTAGE_PYTHON:-/tools/haubi/gentoo/s01en24/usr/bin/python}' \
++ '${PORTAGE_BIN_PATH}'/filter-bash-environment.py \\
++ --report-readonly-variables \
++ --preserve-readonly-attribute \
++ --export-into-global-scope \
++ '${__ebuildshell_bash_i_vars} ${__ebuildshell_ro_ebuild_vars}' \\
++ || die 'filter-bash-environment.py failed'
++ )
++ ) > '${__ebuildshell_tmpf}.return-env'
++ " EXIT
++ # this is a debugging shell already
++ shopt -u extdebug
++ trap - DEBUG
++ # can do some cleanup already
++ rm -f '${__ebuildshell_tmpf}.ebuild-'*
++ EOE
++ ) > "${__ebuildshell_tmpf}.ebuild-env"
++
++ # pre-fill the history with "$@"
++ echo '"$@"' >> ~/.bash_history
++
++ env -i ${BASH} --rcfile "${__ebuildshell_tmpf}.ebuild-env" -i
++
++ # The environment- and exit-status handling after leaving the ebuildshell
++ # prompt is expected to be identical as without the ebuildshell prompt.
++ local __ebuildshell_status=$?
++ source "${__ebuildshell_tmpf}.return-env"
++ # Portage does whitelist readonly variables. If an ebuild defines
++ # more readonly variables, their readonly attribute is removed.
++ # If we ever want to preserve additional readonly variables across
++ # phases, their names are in "${__ebuildshell_tmpf}.return-rovars".
++ rm -f "${__ebuildshell_tmpf}."{ebuild,return}-{env,rovars}
++ return ${__ebuildshell_status}
++}
++
+ # Subshell/helper die support (must export for the die helper).
+ export EBUILD_MASTER_PID=${BASHPID:-$(__bashpid)}
+ trap 'exit 1' SIGTERM
+diff --git a/bin/filter-bash-environment.py b/bin/filter-bash-environment.py
+index a4cdc54..a710e93 100755
+--- a/bin/filter-bash-environment.py
++++ b/bin/filter-bash-environment.py
+@@ -14,7 +14,8 @@ func_end_re = re.compile(r'^\}$')
+
+ var_assign_re = re.compile(r'(^|^declare\s+-\S+\s+|^declare\s+|^export\s+)([^=\s]+)=("|\')?.*$')
+ close_quote_re = re.compile(r'(\\"|"|\')\s*$')
+-readonly_re = re.compile(r'^declare\s+-(\S*)r(\S*)\s+')
++readonly_re = re.compile(r'^declare\s+-(\S*)r(\S*)\s+([^=\s]+)')
++export_re = re.compile(r'^declare\s+-(\S*x\S*)\s+')
+ # declare without assignment
+ var_declare_re = re.compile(r'^declare(\s+-\S+)?\s+([^=\s]+)\s*$')
+
+@@ -29,7 +30,7 @@ def have_end_quote(quote, line):
+ return close_quote_match is not None and \
+ close_quote_match.group(1) == quote
+
+-def filter_declare_readonly_opt(line):
++def filter_declare_readonly_opt(line, options):
+ readonly_match = readonly_re.match(line)
+ if readonly_match is not None:
+ declare_opts = ''
+@@ -37,14 +38,29 @@ def filter_declare_readonly_opt(line):
+ group = readonly_match.group(i)
+ if group is not None:
+ declare_opts += group
++ var = readonly_match.group(3)
++ if '--report-readonly-variables' in options:
++ sys.stderr.write(var + "\n")
++ if '--preserve-readonly-attribute' in options:
++ declare_opts += 'r'
+ if declare_opts:
+- line = 'declare -%s %s' % \
+- (declare_opts, line[readonly_match.end():])
++ line = 'declare -%s %s%s' % \
++ (declare_opts, var, line[readonly_match.end():])
+ else:
+- line = 'declare ' + line[readonly_match.end():]
++ line = 'declare ' + var + line[readonly_match.end():]
+ return line
+
+-def filter_bash_environment(pattern, file_in, file_out):
++def add_global_export_opt(line, options):
++ export_match = export_re.match(line)
++ if export_match is not None:
++ declare_opts = export_match.group(1)
++ if 'g' not in declare_opts and '--export-into-global-scope' in options:
++ declare_opts += 'g'
++ line = 'declare -%s %s' % \
++ (declare_opts, line[export_match.end():])
++ return line
++
++def filter_bash_environment(pattern, file_in, file_out, options):
+ # Filter out any instances of the \1 character from variable values
+ # since this character multiplies each time that the environment
+ # is saved (strange bash behavior). This can eventually result in
+@@ -77,7 +93,8 @@ def filter_bash_environment(pattern, file_in, file_out):
+ multi_line_quote = quote
+ multi_line_quote_filter = filter_this
+ if not filter_this:
+- line = filter_declare_readonly_opt(line)
++ line = filter_declare_readonly_opt(line, options)
++ line = add_global_export_opt(line, options)
+ file_out.write(line.replace("\1", ""))
+ continue
+ else:
+@@ -87,7 +104,8 @@ def filter_bash_environment(pattern, file_in, file_out):
+ filter_this = pattern.match(declare_match.group(2)) \
+ is not None
+ if not filter_this:
+- line = filter_declare_readonly_opt(line)
++ line = filter_declare_readonly_opt(line, options)
++ line = add_global_export_opt(line, options)
+ file_out.write(line)
+ continue
+
+@@ -124,13 +142,28 @@ if __name__ == "__main__":
+ "while leaving bash function definitions and here-documents " + \
+ "intact. The PATTERN is a space separated list of variable names" + \
+ " and it supports python regular expression syntax."
+- usage = "usage: %s PATTERN" % os.path.basename(sys.argv[0])
+- args = sys.argv[1:]
+-
+- if '-h' in args or '--help' in args:
+- sys.stdout.write(usage + "\n")
+- sys.stdout.flush()
+- sys.exit(os.EX_OK)
++ usage = "usage: %s [-h|<options>] PATTERN" % os.path.basename(sys.argv[0])
++ args = []
++ known_options = {
++ '--report-readonly-variables':
++ "Write names of readonly variables to stderr.",
++ '--preserve-readonly-attribute':
++ "Preserve the '-r' flag in 'declare -r'.",
++ '--export-into-global-scope':
++ "Add the '-g' flag to 'declare -x'.",
++ }
++ options = {}
++ for arg in sys.argv[1:]:
++ if arg in known_options.keys():
++ options[arg] = True
++ continue
++ if '-h' == arg or '--help' == arg:
++ sys.stdout.write(usage + "\n\nKnown <options>:\n\n")
++ for option, descr in known_options.items():
++ sys.stdout.write(" " + option + "\t" + descr + "\n")
++ sys.stdout.flush()
++ sys.exit(os.EX_OK)
++ args.append(arg)
+
+ if len(args) != 1:
+ sys.stderr.write(usage + "\n")
+@@ -154,5 +187,5 @@ if __name__ == "__main__":
+
+ var_pattern = "^(%s)$" % "|".join(var_pattern)
+ filter_bash_environment(
+- re.compile(var_pattern), file_in, file_out)
++ re.compile(var_pattern), file_in, file_out, options)
+ file_out.flush()
+diff --git a/bin/save-ebuild-env.sh b/bin/save-ebuild-env.sh
+index ddef1fd..7264ced 100644
+--- a/bin/save-ebuild-env.sh
++++ b/bin/save-ebuild-env.sh
+@@ -53,7 +53,7 @@ __save_ebuild_env() {
+ einfo einfon ewarn eerror ebegin __eend eend KV_major \
+ KV_minor KV_micro KV_to_int get_KV has \
+ __has_phase_defined_up_to \
+- hasv hasq __qa_source __qa_call \
++ hasv hasq __qa_source __qa_call __call-ebuildshell \
+ addread addwrite adddeny addpredict __sb_append_var \
+ use usev useq has_version portageq \
+ best_version use_with use_enable register_die_hook \
+diff --git a/man/make.conf.5 b/man/make.conf.5
+index 26bbf06..865ede9 100644
+--- a/man/make.conf.5
++++ b/man/make.conf.5
+@@ -382,6 +382,12 @@ exist). Also see the related \fIunmerge\-backup\fR feature.
+ Use locks to ensure that unsandboxed ebuild phases never execute
+ concurrently. Also see \fIparallel\-install\fR.
+ .TP
++.B ebuildshell
++Drop into an interactive shell for each phase function, meant for
++debugging. Because the shell would normally be used to execute the
++phase function, commands like src_unpack or epatch are available in the
++interactive shell. Use `die` to terminate the merge.
++.TP
+ .B fail\-clean
+ Clean up temporary files after a build failure. This is particularly useful
+ if you have \fBPORTAGE_TMPDIR\fR on tmpfs. If this feature is enabled, you
+diff --git a/pym/_emerge/AbstractEbuildProcess.py b/pym/_emerge/AbstractEbuildProcess.py
+index 8bd30a6..4ff78b4 100644
+--- a/pym/_emerge/AbstractEbuildProcess.py
++++ b/pym/_emerge/AbstractEbuildProcess.py
+@@ -161,6 +161,7 @@ class AbstractEbuildProcess(SpawnProcess):
+ self.fd_pipes = {}
+ null_fd = None
+ if 0 not in self.fd_pipes and \
++ "ebuildshell" not in self.settings.features and \
+ self.phase not in self._phases_interactive_whitelist and \
+ "interactive" not in self.settings.get("PROPERTIES", "").split():
+ null_fd = os.open('/dev/null', os.O_RDONLY)
+diff --git a/pym/portage/const.py b/pym/portage/const.py
+index 814d7f4..d84f9bf 100644
+--- a/pym/portage/const.py
++++ b/pym/portage/const.py
+@@ -142,6 +142,7 @@ SUPPORTED_FEATURES = frozenset([
+ "distlocks",
+ "downgrade-backup",
+ "ebuild-locks",
++ "ebuildshell",
+ "fail-clean",
+ "fakeroot",
+ "fixlafiles",
+--
+2.7.3
+
diff --git a/sys-apps/portage/portage-2.2.28-r1.ebuild b/sys-apps/portage/portage-2.2.28-r1.ebuild
new file mode 100644
index 0000000000..672b9daff2
--- /dev/null
+++ b/sys-apps/portage/portage-2.2.28-r1.ebuild
@@ -0,0 +1,259 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(
+ pypy
+ python3_3 python3_4 python3_5
+ python2_7
+)
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit eutils distutils-r1 multilib
+
+DESCRIPTION="Portage package manager used in Gentoo Prefix"
+HOMEPAGE="http://prefix.gentoo.org/"
+LICENSE="GPL-2"
+KEYWORDS="~ppc-aix ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="build doc epydoc +ipc linguas_ru selinux xattr prefix-chaining"
+
+DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
+ >=sys-devel/make-3.82
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ >=sys-apps/sed-4.0.5 sys-devel/patch
+ doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
+ epydoc? ( >=dev-python/epydoc-2.0[$(python_gen_usedep 'python2*')] )"
+# Require sandbox-2.2 for bug #288863.
+# For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
+# quite slow, so it's not considered in the dependencies as an alternative to
+# to python-3.3 / pyxattr. Also, xattr support is only tested with Linux, so
+# for now, don't pull in xattr deps for other kernels.
+# For whirlpool hash, require python[ssl] (bug #425046).
+# For compgen, require bash[readline] (bug #445576).
+RDEPEND="
+ >=app-arch/tar-1.27
+ dev-lang/python-exec:2
+ !build? (
+ >=sys-apps/sed-4.0.5
+ app-shells/bash:0[readline]
+ >=app-admin/eselect-1.2
+ )
+ elibc_FreeBSD? ( !prefix? ( sys-freebsd/freebsd-bin ) )
+ elibc_glibc? ( !prefix? ( >=sys-apps/sandbox-2.2 ) )
+ elibc_uclibc? ( !prefix? ( >=sys-apps/sandbox-2.2 ) )
+ kernel_linux? ( >=app-misc/pax-utils-0.1.17 )
+ kernel_SunOS? ( >=app-misc/pax-utils-0.1.17 )
+ kernel_FreeBSD? ( >=app-misc/pax-utils-0.1.17 )
+ kernel_Darwin? ( >=app-misc/pax-utils-0.1.18 )
+ kernel_HPUX? ( !hppa-hpux? ( >=app-misc/pax-utils-0.1.19 ) )
+ kernel_AIX? ( >=sys-apps/aix-miscutils-0.1.1634 )
+ selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
+ xattr? ( kernel_linux? (
+ >=sys-apps/install-xattr-0.3
+ $(python_gen_cond_dep 'dev-python/pyxattr[${PYTHON_USEDEP}]' \
+ python2_7 pypy)
+ ) )
+ !prefix? ( !<app-admin/logrotate-3.8.0 )"
+PDEPEND="
+ !build? (
+ >=net-misc/rsync-2.6.4
+ userland_GNU? ( >=sys-apps/coreutils-6.4 )
+ )"
+# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
+# NOTE: FEATURES=installsources requires debugedit and rsync
+
+REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )"
+
+SRC_ARCHIVES="https://dev.gentoo.org/~dolsen/releases/portage http://dev.gentoo.org/~grobian/distfiles"
+
+prefix_src_archives() {
+ local x y
+ for x in ${@}; do
+ for y in ${SRC_ARCHIVES}; do
+ echo ${y}/${x}
+ done
+ done
+}
+
+TARBALL_PV=${PV}
+SRC_URI="mirror://gentoo/prefix-${PN}-${TARBALL_PV}.tar.bz2
+ $(prefix_src_archives prefix-${PN}-${TARBALL_PV}.tar.bz2)"
+
+S="${WORKDIR}"/prefix-${PN}-${TARBALL_PV}
+
+pkg_setup() {
+ use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
+}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ epatch "${FILESDIR}"/${PN}-2.2.28-ebuildshell.patch # 155161
+ use prefix-chaining &&
+ epatch "${FILESDIR}"/${PN}-2.2.14-prefix-chaining.patch
+
+ # solved in git already, remove at next version
+ sed -i -e "s/version = '2.2.27'/version = '2.2.27-prefix'/" \
+ setup.py || die
+
+ if ! use ipc ; then
+ einfo "Disabling ipc..."
+ sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
+ -i pym/_emerge/AbstractEbuildProcess.py || \
+ die "failed to patch AbstractEbuildProcess.py"
+ fi
+
+ if use xattr && use kernel_linux ; then
+ einfo "Adding FEATURES=xattr to make.globals ..."
+ echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
+ || die "failed to append to make.globals"
+ fi
+
+ if [[ -n ${EPREFIX} ]] ; then
+ # PREFIX LOCAL: only hack const_autotool
+ local extrapath="/usr/bin:/bin"
+ # ok, we can't rely on PORTAGE_ROOT_USER being there yet, as people
+ # tend not to update that often, as long as we are a separate ebuild
+ # we can assume when unset, it's time for some older trick
+ if [[ -z ${PORTAGE_ROOT_USER} ]] ; then
+ PORTAGE_ROOT_USER=$(python -c 'from portage.const import rootuser; print rootuser')
+ fi
+ # lazy check, but works for now
+ if [[ ${PORTAGE_ROOT_USER} == "root" ]] ; then
+ # we need this for e.g. mtree on FreeBSD (and Darwin) which is in
+ # /usr/sbin
+ extrapath="/usr/sbin:/usr/bin:/sbin:/bin"
+ fi
+ local defaultpath="${EPREFIX}/usr/sbin:${EPREFIX}/usr/bin:${EPREFIX}/sbin:${EPREFIX}/bin"
+ # We need to probe for bash in the Prefix, because it may not
+ # exist, in which case we fall back to the currently in use
+ # bash. This logic is necessary in particular during bootstrap,
+ # where we pull ourselves out of a temporary place with tools
+ local bash="${EPREFIX}/bin/bash"
+ [[ ! -x ${bash} ]] && bash=${BASH}
+
+ einfo "Adjusting sources for ${EPREFIX}"
+ find . -type f -exec \
+ sed -e "s|@PORTAGE_EPREFIX@|${EPREFIX}|" \
+ -e "s|@PORTAGE_MV@|$(type -P mv)|" \
+ -e "s|@PORTAGE_BASH@|${bash}|" \
+ -e "s|@PREFIX_PORTAGE_PYTHON@|$(type -P python)|" \
+ -e "s|@DEFAULT_PATH@|${defaultpath}|" \
+ -e "s|@EXTRA_PATH@|${extrapath}|" \
+ -e "s|@portagegroup@|${PORTAGE_GROUP:-portage}|" \
+ -e "s|@portageuser@|${PORTAGE_USER:-portage}|" \
+ -e "s|@rootuser@|${PORTAGE_ROOT_USER:-root}|" \
+ -e "s|@rootuid@|$(id -u ${PORTAGE_ROOT_USER:-root})|" \
+ -e "s|@rootgid@|$(id -g ${PORTAGE_ROOT_USER:-root})|" \
+ -e "s|@sysconfdir@|${EPREFIX}/etc|" \
+ -i '{}' + || \
+ die "Failed to patch sources"
+ # We don't need the below, since setup.py deal with this (and
+ # more) so we don't have to make this correct
+ # -e "s|@PORTAGE_BASE@|${EPREFIX}/usr/lib/portage/${EPYTHON}|" \
+
+ # remove Makefiles, or else they will get installed
+ find . -name "Makefile.*" -delete
+
+ einfo "Prefixing shebangs ..."
+ while read -r -d $'\0' ; do
+ local shebang=$(head -n1 "$REPLY")
+ if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
+ sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \
+ die "sed failed"
+ fi
+ done < <(find . -type f -print0)
+ # END PREFIX LOCAL
+ fi
+
+ # PREFIX LOCAL: make.conf is written by bootstrap-prefix.sh
+ if use !prefix ; then
+ cd "${S}/cnf" || die
+ if [ -f "make.conf.${ARCH}".diff ]; then
+ patch make.conf "make.conf.${ARCH}".diff || \
+ die "Failed to patch make.conf.example"
+ else
+ eerror ""
+ eerror "Portage does not have an arch-specific configuration for this arch."
+ eerror "Please notify the arch maintainer about this issue. Using generic."
+ eerror ""
+ fi
+ fi
+}
+
+python_compile_all() {
+ local targets=()
+ use doc && targets+=( docbook )
+ use epydoc && targets+=( epydoc )
+
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install() {
+ # Install sbin scripts to bindir for python-exec linking
+ # they will be relocated in pkg_preinst()
+ distutils-r1_python_install \
+ --system-prefix="${EPREFIX}/usr" \
+ --bindir="$(python_get_scriptdir)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
+ --sbindir="$(python_get_scriptdir)" \
+ --sysconfdir="${EPREFIX}/etc" \
+ "${@}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ local targets=()
+ use doc && targets+=( install_docbook )
+ use epydoc && targets+=( install_epydoc )
+
+ # install docs
+ if [[ ${targets[@]} ]]; then
+ esetup.py "${targets[@]}"
+ fi
+
+ # Due to distutils/python-exec limitations
+ # these must be installed to /usr/bin.
+ local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
+ einfo "Moving admin scripts to the correct directory"
+ dodir /usr/sbin
+ for target in ${sbin_relocations}; do
+ einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
+ mv "${ED}usr/bin/${target}" "${ED}usr/sbin/${target}" || die "sbin scripts move failed!"
+ done
+}
+
+pkg_preinst() {
+ # comment out sanity test until it is fixed to work
+ # with the new PORTAGE_PYM_PATH
+ #if [[ $ROOT == / ]] ; then
+ ## Run some minimal tests as a sanity check.
+ #local test_runner=$(find "${ED}" -name runTests)
+ #if [[ -n $test_runner && -x $test_runner ]] ; then
+ #einfo "Running preinst sanity tests..."
+ #"$test_runner" || die "preinst sanity tests failed"
+ #fi
+ #fi
+
+ # elog dir must exist to avoid logrotate error for bug #415911.
+ # This code runs in preinst in order to bypass the mapping of
+ # portage:portage to root:root which happens after src_install.
+ keepdir /var/log/portage/elog
+ # This is allowed to fail if the user/group are invalid for prefix users.
+ if chown ${PORTAGE_USER}:${PORTAGE_GROUP} "${ED}"var/log/portage{,/elog} 2>/dev/null ; then
+ chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog}
+ fi
+}