summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-08-23 11:38:51 +0200
committerFabian Groffen <grobian@gentoo.org>2017-08-23 11:38:51 +0200
commit8edc6496b8efcfbbaf04e3ff51ff2c45f234eaff (patch)
treeb4f10c3693ee9842a18bf004950f156fb173c6bc
parentapp-shells/bash: sync, bug #628156 (diff)
downloadprefix-8edc6496.tar.gz
prefix-8edc6496.tar.bz2
prefix-8edc6496.zip
scripts/bootstrap-prefix: bump tree and portage snapshot
-rwxr-xr-xscripts/bootstrap-prefix.sh10
-rw-r--r--sys-devel/gcc/gcc-5.3.0.ebuild2
2 files changed, 4 insertions, 8 deletions
diff --git a/scripts/bootstrap-prefix.sh b/scripts/bootstrap-prefix.sh
index 335cb27cc4..185ddcae77 100755
--- a/scripts/bootstrap-prefix.sh
+++ b/scripts/bootstrap-prefix.sh
@@ -522,7 +522,7 @@ do_tree() {
bootstrap_tree() {
# RAP uses the latest gentoo main repo snapshot to bootstrap.
is-rap && LATEST_TREE_YES=1
- local PV="20170708"
+ local PV="20170822"
if [[ -n ${LATEST_TREE_YES} ]]; then
do_tree "${SNAPSHOT_URL}" portage-latest.tar.bz2
else
@@ -598,8 +598,8 @@ bootstrap_portage() {
# STABLE_PV that is known to work. Intended for power users only.
## It is critical that STABLE_PV is the lastest (non-masked) version that is
## included in the snapshot for bootstrap_tree.
- STABLE_PV="2.3.5"
- [[ ${TESTING_PV} == latest ]] && TESTING_PV="2.3.5"
+ STABLE_PV="2.3.8"
+ [[ ${TESTING_PV} == latest ]] && TESTING_PV="2.3.8"
PV="${TESTING_PV:-${STABLE_PV}}"
A=prefix-portage-${PV}.tar.bz2
einfo "Bootstrapping ${A%-*}"
@@ -616,10 +616,6 @@ bootstrap_portage() {
S="${S}/prefix-portage-${PV}"
cd "${S}"
- # Cygwin
- patch -p1 < "${PORTDIR}"/sys-apps/portage/files/portage-2.2.28-cygwin.patch
- patch -p1 < "${PORTDIR}"/sys-apps/portage/files/portage-2.3.4-mj-safe-econf.patch
-
# >=2.3
[[ -r bin/repoman ]] || sed -i -e '/repoman/d' {man,bin}/Makefile.in
diff --git a/sys-devel/gcc/gcc-5.3.0.ebuild b/sys-devel/gcc/gcc-5.3.0.ebuild
index e87fc86298..f214d0d327 100644
--- a/sys-devel/gcc/gcc-5.3.0.ebuild
+++ b/sys-devel/gcc/gcc-5.3.0.ebuild
@@ -127,7 +127,7 @@ src_configure() {
;;
*-solaris*)
# todo: some magic for native vs. GNU linking?
- myconf+=( --with-gnu-ld --with-gnu-as )
+ myconf+=( --with-gnu-ld --with-gnu-as --enable-largefile )
;;
*-aix*)
# AIX doesn't use GNU binutils, because it doesn't produce usable