summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>2017-03-03 12:34:51 +0100
committerMichael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>2017-03-03 12:34:51 +0100
commita29ef417327073769b4387a1e3785a06f07d4f5e (patch)
tree1bddb99ab5c5070451e98e954ed3aaed26caf104
parentbootstrap-prefix.sh: apply multijob-safe-econf portage patch (diff)
downloadprefix-a29ef417327073769b4387a1e3785a06f07d4f5e.tar.gz
prefix-a29ef417327073769b4387a1e3785a06f07d4f5e.tar.bz2
prefix-a29ef417327073769b4387a1e3785a06f07d4f5e.zip
bootstrap-prefix.sh: bump prefix-portage TESTING_PV=2.3.4
-rwxr-xr-xscripts/bootstrap-prefix.sh5
1 files changed, 4 insertions, 1 deletions
diff --git a/scripts/bootstrap-prefix.sh b/scripts/bootstrap-prefix.sh
index 0ed8672439..2483b05040 100755
--- a/scripts/bootstrap-prefix.sh
+++ b/scripts/bootstrap-prefix.sh
@@ -578,7 +578,7 @@ bootstrap_portage() {
## It is critical that STABLE_PV is the lastest (non-masked) version that is
## included in the snapshot for bootstrap_tree.
STABLE_PV="2.2.28"
- [[ ${TESTING_PV} == latest ]] && TESTING_PV="2.2.28"
+ [[ ${TESTING_PV} == latest ]] && TESTING_PV="2.3.4"
PV="${TESTING_PV:-${STABLE_PV}}"
A=prefix-portage-${PV}.tar.bz2
einfo "Bootstrapping ${A%-*}"
@@ -599,6 +599,9 @@ bootstrap_portage() {
patch -p1 < "${PORTDIR}"/sys-apps/portage/files/portage-2.2.28-cygwin.patch
patch -p1 < "${PORTDIR}"/sys-apps/portage/files/portage-2.3.4-mj-safe-econf.patch
+ # >=2.3
+ [[ -r bin/repoman ]] || sed -i -e '/repoman/d' {man,bin}/Makefile.in
+
# disable ipc
sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
-i pym/_emerge/AbstractEbuildProcess.py || \