summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2018-01-08 20:59:49 +0100
committerFabian Groffen <grobian@gentoo.org>2018-01-08 20:59:49 +0100
commita92c62593fcb6d0b62de8d1d615db1ecc6bb59da (patch)
tree9525acb54d76e86be25dbbc23526cebcd4821a92
parentsys-libs/libcxxabi: fix linking on ppc (need -fPIC explicitly) (diff)
downloadprefix-a92c62593fcb6d0b62de8d1d615db1ecc6bb59da.tar.gz
prefix-a92c62593fcb6d0b62de8d1d615db1ecc6bb59da.tar.bz2
prefix-a92c62593fcb6d0b62de8d1d615db1ecc6bb59da.zip
sys-libs/libcxx: fix linking on ppc (need -fPIC explicitly)
Package-Manager: Portage-2.3.18-prefix, Repoman-2.3.6
-rw-r--r--sys-libs/libcxx/libcxx-3.5.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-libs/libcxx/libcxx-3.5.1.ebuild b/sys-libs/libcxx/libcxx-3.5.1.ebuild
index 787a678359..66c8c8f018 100644
--- a/sys-libs/libcxx/libcxx-3.5.1.ebuild
+++ b/sys-libs/libcxx/libcxx-3.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id $
@@ -98,6 +98,10 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.5.1-eprintf.patch
fi
+ if [[ ${CHOST} == powerpc*-darwin* ]] ; then
+ sed -i -e '/RC_CFLAGS=""/s/""/"-fPIC"/' lib/buildit || die
+ fi
+
# fix library install names
sed -i \
-e "s,/usr/lib/libc++abi\.dylib,${EPREFIX}/usr/lib/libc++abi.dylib,g" \