summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2017-09-25 18:39:25 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2017-09-25 18:39:25 +0200
commitaedebf46c4e5e9c88097e000e7fc9133a5e51c3b (patch)
treebf976208d9d166f69f944d631b756f901e080755
parentdev-libs/libintl-0.19.8.1-r00.1: update winnt support (diff)
downloadprefix-aedebf46.tar.gz
prefix-aedebf46.tar.bz2
prefix-aedebf46.zip
sys-devel/gcc: build 5.3.0 with 7.1.0 host
Closes: https://bugs.gentoo.org/631976 Package-Manager: Portage-2.3.10-prefix, Repoman-2.3.3 RepoMan-Options: --force
-rw-r--r--sys-devel/gcc/files/gcc-5.3.0-libc_name_p.patch111
-rw-r--r--sys-devel/gcc/gcc-5.3.0.ebuild1
2 files changed, 112 insertions, 0 deletions
diff --git a/sys-devel/gcc/files/gcc-5.3.0-libc_name_p.patch b/sys-devel/gcc/files/gcc-5.3.0-libc_name_p.patch
new file mode 100644
index 0000000000..e87076b904
--- /dev/null
+++ b/sys-devel/gcc/files/gcc-5.3.0-libc_name_p.patch
@@ -0,0 +1,111 @@
+https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=233572
+
+--- a/gcc/cp/Make-lang.in
++++ b/gcc/cp/Make-lang.in
+@@ -111,7 +111,7 @@ else
+ # deleting the $(srcdir)/cp/cfns.h file.
+ $(srcdir)/cp/cfns.h:
+ endif
+- gperf -o -C -E -k '1-6,$$' -j1 -D -N 'libc_name_p' -L ANSI-C \
++ gperf -o -C -E -k '1-6,$$' -j1 -D -N 'libc_name_p' -L C++ \
+ $(srcdir)/cp/cfns.gperf --output-file $(srcdir)/cp/cfns.h
+
+ #
+--- a/gcc/cp/cfns.gperf
++++ b/gcc/cp/cfns.gperf
+@@ -1,3 +1,5 @@
++%language=C++
++%define class-name libc_name
+ %{
+ /* Copyright (C) 2000-2015 Free Software Foundation, Inc.
+
+@@ -16,14 +18,6 @@ for more details.
+ You should have received a copy of the GNU General Public License
+ along with GCC; see the file COPYING3. If not see
+ <http://www.gnu.org/licenses/>. */
+-#ifdef __GNUC__
+-__inline
+-#endif
+-static unsigned int hash (const char *, unsigned int);
+-#ifdef __GNUC__
+-__inline
+-#endif
+-const char * libc_name_p (const char *, unsigned int);
+ %}
+ %%
+ # The standard C library functions, for feeding to gperf; the result is used
+--- a/gcc/cp/cfns.h
++++ b/gcc/cp/cfns.h
+@@ -28,7 +28,7 @@
+ #error "gperf generated tables don't work with this execution character set. Please report a bug to <bug-gnu-gperf@gnu.org>."
+ #endif
+
+-#line 1 "cfns.gperf"
++#line 3 "cfns.gperf"
+
+ /* Copyright (C) 2000-2015 Free Software Foundation, Inc.
+
+@@ -47,25 +47,18 @@ for more details.
+ You should have received a copy of the GNU General Public License
+ along with GCC; see the file COPYING3. If not see
+ <http://www.gnu.org/licenses/>. */
+-#ifdef __GNUC__
+-__inline
+-#endif
+-static unsigned int hash (const char *, unsigned int);
+-#ifdef __GNUC__
+-__inline
+-#endif
+-const char * libc_name_p (const char *, unsigned int);
+ /* maximum key range = 391, duplicates = 0 */
+
+-#ifdef __GNUC__
+-__inline
+-#else
+-#ifdef __cplusplus
+-inline
+-#endif
+-#endif
+-static unsigned int
+-hash (register const char *str, register unsigned int len)
++class libc_name
++{
++private:
++ static inline unsigned int hash (const char *str, unsigned int len);
++public:
++ static const char *libc_name_p (const char *str, unsigned int len);
++};
++
++inline unsigned int
++libc_name::hash (register const char *str, register unsigned int len)
+ {
+ static const unsigned short asso_values[] =
+ {
+@@ -122,14 +115,8 @@ hash (register const char *str, register
+ return hval + asso_values[(unsigned char)str[len - 1]];
+ }
+
+-#ifdef __GNUC__
+-__inline
+-#ifdef __GNUC_STDC_INLINE__
+-__attribute__ ((__gnu_inline__))
+-#endif
+-#endif
+ const char *
+-libc_name_p (register const char *str, register unsigned int len)
++libc_name::libc_name_p (register const char *str, register unsigned int len)
+ {
+ enum
+ {
+--- a/gcc/cp/except.c
++++ b/gcc/cp/except.c
+@@ -1040,7 +1040,8 @@ nothrow_libfn_p (const_tree fn)
+ unless the system headers are playing rename tricks, and if
+ they are, we don't want to be confused by them. */
+ id = DECL_NAME (fn);
+- return !!libc_name_p (IDENTIFIER_POINTER (id), IDENTIFIER_LENGTH (id));
++ return !!libc_name::libc_name_p (IDENTIFIER_POINTER (id),
++ IDENTIFIER_LENGTH (id));
+ }
+
+ /* Returns nonzero if an exception of type FROM will be caught by a
diff --git a/sys-devel/gcc/gcc-5.3.0.ebuild b/sys-devel/gcc/gcc-5.3.0.ebuild
index b93e50955f..ad35214117 100644
--- a/sys-devel/gcc/gcc-5.3.0.ebuild
+++ b/sys-devel/gcc/gcc-5.3.0.ebuild
@@ -62,6 +62,7 @@ src_prepare() {
# make sure 64-bits native targets don't screw up the linker paths
#epatch "${FILESDIR}"/4.7.1/solaris-searchpath.patch
epatch "${FILESDIR}"/no-libs-for-startfile.patch
+ epatch "${FILESDIR}"/${P}-libc_name_p.patch #631976
if use prefix; then
epatch "${FILESDIR}"/4.5.2/prefix-search-dirs.patch
# try /usr/lib32 in 32bit profile on x86_64-linux (needs