summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2017-09-25 15:58:54 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2017-09-25 15:58:54 +0200
commitc6410bbd72268c09e5dba50f4bdd5eadba1c1419 (patch)
tree74711a808333bda96ac8bcd250842a678a5ca491
parentsys-libs/db-5.3.28-r3: apply prefix diffs (diff)
downloadprefix-c6410bbd.tar.gz
prefix-c6410bbd.tar.bz2
prefix-c6410bbd.zip
sys-libs/db-6.0.35-r1: fix for x86-winnt
Package-Manager: Portage-2.3.8-prefix, Repoman-2.3.3
-rw-r--r--sys-libs/db/db-6.0.35-r1.ebuild12
-rw-r--r--sys-libs/db/files/db-6.0.35-winnt.patch110
2 files changed, 121 insertions, 1 deletions
diff --git a/sys-libs/db/db-6.0.35-r1.ebuild b/sys-libs/db/db-6.0.35-r1.ebuild
index a9aafa91ce..7f2530ae61 100644
--- a/sys-libs/db/db-6.0.35-r1.ebuild
+++ b/sys-libs/db/db-6.0.35-r1.ebuild
@@ -27,7 +27,7 @@ done
LICENSE="AGPL-3"
SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE="doc java cxx tcl test"
REQUIRED_USE="test? ( tcl )"
@@ -93,6 +93,8 @@ src_prepare() {
# core, ~300MB each. This patch uses links instead, saves a lot of space.
epatch "${FILESDIR}"/${PN}-6.0.20-test-link.patch
+ epatch "${FILESDIR}"/${PN}-6.0.35-winnt.patch
+
# Upstream release script grabs the dates when the script was run, so lets
# end-run them to keep the date the same.
export REAL_DB_RELEASE_DATE="$(awk \
@@ -167,6 +169,14 @@ multilib_src_configure() {
myconf+=(--disable-tcl )
fi
+ if [[ ${CHOST} == *-winnt* ]]; then
+ # this one should really sound --enable-windows, but
+ # seems the db devs only support mingw ... doesn't enable
+ # anything too specific to mingw.
+ myconf+=(--enable-mingw)
+ myconf+=(--with-mutex=win32)
+ fi
+
# sql_compat will cause a collision with sqlite3
# --enable-sql_compat
# Don't --enable-sql* because we don't want to use bundled sqlite.
diff --git a/sys-libs/db/files/db-6.0.35-winnt.patch b/sys-libs/db/files/db-6.0.35-winnt.patch
new file mode 100644
index 0000000000..7b452960a7
--- /dev/null
+++ b/sys-libs/db/files/db-6.0.35-winnt.patch
@@ -0,0 +1,110 @@
+--- db-6.0.35/dist/aclocal/cxx.m4.orig 2017-09-21 14:38:27.091198600 +0200
++++ db-6.0.35/dist/aclocal/cxx.m4 2017-09-21 14:38:38.481785600 +0200
+@@ -171,6 +171,7 @@
+
+ t44 = t4;
+ t55 = t5;
++ return 0;
+ }
+
+ template <typename T4>
+@@ -178,6 +179,7 @@
+ {
+ T4 t44 = t4;
+ std::vector<T4> abc = t55;
++ return 0;
+ }
+
+ // maximum of two int values
+--- db-6.0.35/dist/aclocal/tls.m4.orig 2017-09-21 15:41:28.325565600 +0200
++++ db-6.0.35/dist/aclocal/tls.m4 2017-09-21 15:41:56.388089900 +0200
+@@ -21,10 +21,10 @@
+ class TLSClass2 {
+ public: static ] $ax_tls_decl_keyword [int tlsvar;
+ };
+- template<typename T> ] $ax_tls_defn_keyword [ T* TLSClass<T>::tlsvar = NULL;]
++ template<typename T> ] $ax_tls_defn_keyword [ T* TLSClass<T>::tlsvar = 0;]
+ $ax_tls_defn_keyword [int TLSClass2::tlsvar = 1;
+ static $ax_tls_decl_keyword int x = 0;],
+- [TLSClass<int>::tlsvar = NULL; TLSClass2::tlsvar = 1;],
++ [TLSClass<int>::tlsvar = 0; TLSClass2::tlsvar = 1;],
+ [ac_cv_tls=modifier ; break])
+ done
+ test "$ac_cv_tls" = none || break
+@@ -39,7 +39,7 @@
+ static pthread_key_t key;
+
+ static void init_once(void) {
+- pthread_key_create(&key, NULL);
++ pthread_key_create(&key, 0);
+ }
+ static void *get_tls() {
+ return (void *)pthread_getspecific(&key);
+--- db-6.0.35/dist/configure.ac.orig 2017-09-21 16:12:45.638028200 +0200
++++ db-6.0.35/dist/configure.ac 2017-09-21 16:13:11.731822700 +0200
+@@ -371,11 +371,11 @@
+ INSTALLER="\$(LIBTOOL) --mode=install cp -p"
+
+ MAKEFILE_CC="\$(LIBTOOL) --mode=compile ${MAKEFILE_CC}"
+-MAKEFILE_SOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} -avoid-version"
+-MAKEFILE_CCLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK}"
++MAKEFILE_SOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} -no-undefined -avoid-version"
++MAKEFILE_CCLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CCLINK} -no-undefined"
+ MAKEFILE_CXX="\$(LIBTOOL) --mode=compile ${MAKEFILE_CXX}"
+-MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -avoid-version"
+-MAKEFILE_CXXLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK}"
++MAKEFILE_XSOLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -no-undefined -avoid-version"
++MAKEFILE_CXXLINK="\$(LIBTOOL) --mode=link ${MAKEFILE_CXXLINK} -no-undefined"
+
+
+ case "$host_os" in
+@@ -411,9 +411,6 @@
+ o=".lo"
+ fi
+ INSTALL_LIBS="$DEFAULT_LIB"
+-if test "$enable_static" = "yes"; then
+- INSTALL_LIBS="$INSTALL_LIBS \$(libdb)"
+-fi
+
+ # Optional C++ API.
+ if test "$db_cv_cxx" = "yes"; then
+@@ -424,9 +421,6 @@
+ DEFAULT_LIB_CXX="\$(libxso_target)"
+ fi
+ INSTALL_LIBS="$INSTALL_LIBS $DEFAULT_LIB_CXX"
+- if test "$enable_static" = "yes"; then
+- INSTALL_LIBS="$INSTALL_LIBS \$(libcxx)"
+- fi
+ fi
+
+ # Optional Java API / JDBC.
+@@ -553,9 +547,6 @@
+ DEFAULT_LIB_SQL="\$(libsqlso_target)"
+ fi
+ INSTALL_LIBS="$INSTALL_LIBS $DEFAULT_LIB_SQL"
+- if test "$enable_static" = "yes"; then
+- INSTALL_LIBS="$INSTALL_LIBS \$(libsql)"
+- fi
+
+ if test "$db_cv_test" = "yes"; then
+ subdirs="$subdirs sql"
+@@ -593,9 +584,6 @@
+ if test "$enable_shared" = "yes"; then
+ INSTALL_LIBS_EXTRA="$INSTALL_LIBS_EXTRA \$(libsqliteso)"
+ fi
+- if test "$enable_static" = "yes"; then
+- INSTALL_LIBS="$INSTALL_LIBS \$(libsqlite)"
+- fi
+ fi
+
+ # Optional SQL code generation tool.
+@@ -619,9 +607,6 @@
+ ADDITIONAL_INCS="$ADDITIONAL_INCS \$(topdir)/lang/cxx/stl/$f"
+ done
+ INSTALL_LIBS="$INSTALL_LIBS $DEFAULT_LIB_STL"
+- if test "$enable_static" = "yes"; then
+- INSTALL_LIBS="$INSTALL_LIBS \$(libstl)"
+- fi
+ fi
+
+ # Checks for include files, structures, C types.