summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-23 01:37:28 +0000
committerSam James <sam@gentoo.org>2022-01-23 01:37:28 +0000
commite6dda27fc791345327bff060058538a4f487c72f (patch)
treead2730fb53e1cccc30ffce9d19fd62a7b5c7d518
parentpython-utils-r1.eclass: sync with ::gentoo (diff)
downloadprefix-e6dda27fc791345327bff060058538a4f487c72f.tar.gz
prefix-e6dda27fc791345327bff060058538a4f487c72f.tar.bz2
prefix-e6dda27fc791345327bff060058538a4f487c72f.zip
dev-lang/python: fix compatibility with >=setuptools-60; verify-sig
Closes: https://bugs.gentoo.org/831855 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-lang/python/python-3.8.8_p1-r1.ebuild5
-rw-r--r--dev-lang/python/python-3.9.6_p1-r1.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-lang/python/python-3.8.8_p1-r1.ebuild b/dev-lang/python/python-3.8.8_p1-r1.ebuild
index 1eb8bef62f..046cbbc700 100644
--- a/dev-lang/python/python-3.8.8_p1-r1.ebuild
+++ b/dev-lang/python/python-3.8.8_p1-r1.ebuild
@@ -61,7 +61,7 @@ DEPEND="${RDEPEND}
BDEPEND="
virtual/pkgconfig
sys-devel/autoconf-archive
- verify-sig? ( app-crypt/openpgp-keys-python )
+ verify-sig? ( sec-keys/openpgp-keys-python )
!sys-devel/gcc[libffi(-)]"
PDEPEND="app-eselect/eselect-python"
RDEPEND+=" !build? ( app-misc/mime-types )"
@@ -229,6 +229,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=
diff --git a/dev-lang/python/python-3.9.6_p1-r1.ebuild b/dev-lang/python/python-3.9.6_p1-r1.ebuild
index d818d00077..7885b7cfcc 100644
--- a/dev-lang/python/python-3.9.6_p1-r1.ebuild
+++ b/dev-lang/python/python-3.9.6_p1-r1.ebuild
@@ -61,7 +61,7 @@ DEPEND="${RDEPEND}
BDEPEND="
virtual/pkgconfig
sys-devel/autoconf-archive
- verify-sig? ( app-crypt/openpgp-keys-python )
+ verify-sig? ( sec-keys/openpgp-keys-python )
!sys-devel/gcc[libffi(-)]"
RDEPEND+=" !build? ( app-misc/mime-types )"
@@ -236,6 +236,9 @@ src_compile() {
# Ensure sed works as expected
# https://bugs.gentoo.org/594768
local -x LC_ALL=C
+ # Prevent using distutils bundled by setuptools.
+ # https://bugs.gentoo.org/823728
+ export SETUPTOOLS_USE_DISTUTILS=stdlib
emake CPPFLAGS= CFLAGS= LDFLAGS=