summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>2016-05-02 10:55:21 +0000
committerMichael Haubenwallner <michael.haubenwallner@ssi-schaefer.com>2016-05-02 10:55:44 +0000
commitf640c119b2d25a65f54f1b8a1d1293edeb590477 (patch)
treea0554570a909703a30d827da04630a142ff99a35
parentdev-libs/gmp: add fix for gcc-apple, bug #536894 (diff)
downloadprefix-f640c119.tar.gz
prefix-f640c119.tar.bz2
prefix-f640c119.zip
popt: Cygwin port, check for glob_pattern_p
-rw-r--r--dev-libs/popt/files/popt-1.16-glob_pattern_p.patch47
-rw-r--r--dev-libs/popt/popt-1.16-r02.1.ebuild41
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-libs/popt/files/popt-1.16-glob_pattern_p.patch b/dev-libs/popt/files/popt-1.16-glob_pattern_p.patch
new file mode 100644
index 0000000000..7fc3e2f6c2
--- /dev/null
+++ b/dev-libs/popt/files/popt-1.16-glob_pattern_p.patch
@@ -0,0 +1,47 @@
+http://rpm5.org/cvs/tktview?tn=93
+
+--- configure.ac
++++ configure.ac
+#@@ -82,7 +82,7 @@
+ AC_CHECK_FUNC(setreuid, [], [
+ AC_CHECK_LIB(ucb, setreuid, [if echo $LIBS | grep -- -lucb >/dev/null ;then :; else LIBS="$LIBS -lc -lucb" USEUCB=y;fi])
+ ])
+-AC_CHECK_FUNCS(getuid geteuid iconv mtrace __secure_getenv setregid stpcpy strerror vasprintf srandom)
++AC_CHECK_FUNCS(getuid geteuid glob_pattern_p iconv mtrace __secure_getenv setregid stpcpy strerror vasprintf srandom)
+
+ AM_GNU_GETTEXT([external])
+ AM_ICONV_LINK
+--- config.h.in
++++ config.h.in
+@@ -34,6 +34,9 @@
+ /* Define to 1 if you have the `getuid' function. */
+ #undef HAVE_GETUID
+
++/* Define to 1 if you have the `glob_pattern_p' function. */
++#undef HAVE_GLOB_PATTERN_P
++
+ /* Define to 1 if you have the <glob.h> header file. */
+ #undef HAVE_GLOB_H
+
+--- configure
++++ configure
+@@ -13505,7 +13505,7 @@
+
+
+
+-for ac_func in getuid geteuid iconv mtrace __secure_getenv setregid stpcpy strerror vasprintf srandom
++for ac_func in getuid geteuid glob_pattern_p iconv mtrace __secure_getenv setregid stpcpy strerror vasprintf srandom
+ do
+ as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ { $as_echo "$as_me:$LINENO: checking for $ac_func" >&5
+--- poptconfig.c
++++ poptconfig.c
+@@ -42,7 +42,7 @@
+ /*@=declundef =exportheader =incondefs =protoparammatch =redecl =type @*/
+ #endif /* __LCLINT__ */
+
+-#if !defined(__GLIBC__)
++#if !defined(HAVE_GLOB_PATTERN_P)
+ /* Return nonzero if PATTERN contains any metacharacters.
+ Metacharacters can be quoted with backslashes if QUOTE is nonzero. */
+ static int
diff --git a/dev-libs/popt/popt-1.16-r02.1.ebuild b/dev-libs/popt/popt-1.16-r02.1.ebuild
new file mode 100644
index 0000000000..0bc07be731
--- /dev/null
+++ b/dev-libs/popt/popt-1.16-r02.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/popt/popt-1.16-r2.ebuild,v 1.9 2015/03/13 19:55:13 zlogene Exp $
+
+EAPI=5
+
+inherit eutils libtool multilib-minimal
+
+DESCRIPTION="Parse Options - Command line parser"
+HOMEPAGE="http://rpm5.org/"
+SRC_URI="http://rpm5.org/files/popt/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~ppc-aix ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static-libs"
+
+RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-popt-pkgconfig-libdir.patch #349558
+ sed -i -e 's:lt-test1:test1:' testit.sh || die
+
+ epatch "${FILESDIR}"/${PN}-1.16-glob_pattern_p.patch # for MiNT and Cygwin
+ epatch "${FILESDIR}"/${PN}-1.13-no-wchar-hack.patch # for Interix and MiNT
+ elibtoolize # for FreeMiNT
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable nls)
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+ prune_libtool_files --all
+}