summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-02-18 18:28:28 +0100
committerFabian Groffen <grobian@gentoo.org>2016-02-18 18:28:28 +0100
commit907ea4521c9b1c382eaeec1b2c4be1d1922b18f5 (patch)
treef796e739c72b71aec10445647e8177de1b927231 /dev-lang
parentsys-libs/ncurses: fix installation location on Prefix (diff)
downloadprefix-907ea4521c9b1c382eaeec1b2c4be1d1922b18f5.tar.gz
prefix-907ea4521c9b1c382eaeec1b2c4be1d1922b18f5.tar.bz2
prefix-907ea4521c9b1c382eaeec1b2c4be1d1922b18f5.zip
dev-lang/python: fix 3.3 install, by Jacob Godserv in bug #574926
Package-Manager: portage-2.2.20-prefix
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.3.3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-lang/python/python-3.3.3.ebuild b/dev-lang/python/python-3.3.3.ebuild
index 16122b7cc5..8f989d864a 100644
--- a/dev-lang/python/python-3.3.3.ebuild
+++ b/dev-lang/python/python-3.3.3.ebuild
@@ -360,14 +360,17 @@ src_install() {
-i "${ED}etc/conf.d/pydoc-${SLOT}" "${ED}etc/init.d/pydoc-${SLOT}" || die "sed failed"
# for python-exec
- python_export python${SLOT} EPYTHON PYTHON PYTHON_SITEDIR
+ local vars=( EPYTHON PYTHON_SITEDIR PYTHON_SCRIPTDIR )
# if not using a cross-compiler, use the fresh binary
if ! tc-is-cross-compiler; then
- local PYTHON=./python
+ local -x PYTHON=./python
local -x LD_LIBRARY_PATH=${LD_LIBRARY_PATH+${LD_LIBRARY_PATH}:}.
+ else
+ vars=( PYTHON "${vars[@]}" )
fi
+ python_export "python${SLOT}" "${vars[@]}"
echo "EPYTHON='${EPYTHON}'" > epython.py
python_domodule epython.py
}