summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-01-24 13:00:36 +0100
committerFabian Groffen <grobian@gentoo.org>2016-01-24 13:00:36 +0100
commitad61c146388ee8214371d99feb07e92e01de4de4 (patch)
tree168a1ad59d68d6723408365af479bf1d83d153c9 /dev-lang
parentdev-lang/python: apply workaround for increased security in El Capitan (10.11... (diff)
downloadprefix-ad61c146388ee8214371d99feb07e92e01de4de4.tar.gz
prefix-ad61c146388ee8214371d99feb07e92e01de4de4.tar.bz2
prefix-ad61c146388ee8214371d99feb07e92e01de4de4.zip
dev-lang/python: disable building pythonlauncher and idle, for it gives problems on 10.11 and they are useless
Package-Manager: portage-2.2.20-prefix
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.4.3-r5.ebuild7
-rw-r--r--dev-lang/python/python-3.5.1.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-lang/python/python-3.4.3-r5.ebuild b/dev-lang/python/python-3.4.3-r5.ebuild
index b7f35bcd21..925d78fa44 100644
--- a/dev-lang/python/python-3.4.3-r5.ebuild
+++ b/dev-lang/python/python-3.4.3-r5.ebuild
@@ -278,9 +278,10 @@ src_install() {
# avoid config.status to be triggered
find Mac -name "Makefile" -exec touch \{\} + || die
- emake DESTDIR="${D}" -C Mac \
- install_Python install_PythonLauncher install_IDLE \
- || die
+ # Python_Launcher is kind of a wrapper, and we should fix it for
+ # Prefix (it uses /usr/bin/pythonw) so useless
+ # IDLE doesn't run, no idea, but definitely not used
+ emake DESTDIR="${D}" -C Mac install_Python || die
local fwdir=/usr/$(get_libdir)/Python.framework/Versions/${PYVER}
ln -s "${EPREFIX}"/usr/include/python${PYVER} \
diff --git a/dev-lang/python/python-3.5.1.ebuild b/dev-lang/python/python-3.5.1.ebuild
index f81884e2c8..31eae0e327 100644
--- a/dev-lang/python/python-3.5.1.ebuild
+++ b/dev-lang/python/python-3.5.1.ebuild
@@ -287,9 +287,10 @@ src_install() {
# avoid config.status to be triggered
find Mac -name "Makefile" -exec touch \{\} + || die
- emake DESTDIR="${D}" -C Mac \
- install_Python install_PythonLauncher install_IDLE \
- || die
+ # Python_Launcher is kind of a wrapper, and we should fix it for
+ # Prefix (it uses /usr/bin/pythonw) so useless
+ # IDLE doesn't run, no idea, but definitely not used
+ emake DESTDIR="${D}" -C Mac install_Python || die
local fwdir=/usr/$(get_libdir)/Python.framework/Versions/${PYVER}
ln -s "${EPREFIX}"/usr/include/python${PYVER} \