summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2023-05-30 19:25:28 +0200
committerFabian Groffen <grobian@gentoo.org>2023-05-31 12:27:16 +0200
commit8833389084f0eb3b79f4dde59fe9f5b9866c4eba (patch)
tree080b1834aa92b1eaa3a848013118893e6e910407 /scripts/bootstrap-prefix.sh
parentscripts/dobootstrap: force bitwidth to supported configs (diff)
downloadprefix-8833389084f0eb3b79f4dde59fe9f5b9866c4eba.tar.gz
prefix-8833389084f0eb3b79f4dde59fe9f5b9866c4eba.tar.bz2
prefix-8833389084f0eb3b79f4dde59fe9f5b9866c4eba.zip
scripts/bootstrap-prefix: fix Python bootstrap on Solaris
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'scripts/bootstrap-prefix.sh')
-rwxr-xr-xscripts/bootstrap-prefix.sh5
1 files changed, 4 insertions, 1 deletions
diff --git a/scripts/bootstrap-prefix.sh b/scripts/bootstrap-prefix.sh
index f7cb6208fa..45cf2f4e2c 100755
--- a/scripts/bootstrap-prefix.sh
+++ b/scripts/bootstrap-prefix.sh
@@ -1005,7 +1005,10 @@ bootstrap_python() {
# OpenIndiana/Solaris 11 defines inet_aton no longer in
# libresolv, so use hstrerror to check if we need -lresolv
sed -i -e '/AC_CHECK_LIB/s/inet_aton/hstrerror/' \
- configure || die
+ configure.ac || die
+ # we don't regenerate configure at this point, so just force the
+ # fix result
+ export LIBS="${LIBS} -lresolv"
;;
(*-darwin9)
# Darwin 9's kqueue seems to act up (at least at this stage), so