summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/files')
-rw-r--r--dev-lang/python/files/python-2.7.10-cross-compile-warn-test.patch24
-rw-r--r--dev-lang/python/files/python-2.7.10-system-libffi.patch36
-rw-r--r--dev-lang/python/files/python-2.7.14-libffi-pkgconfig.patch44
-rw-r--r--dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch18
-rw-r--r--dev-lang/python/files/python-2.7.9-ncurses-pkg-config.patch13
-rw-r--r--dev-lang/python/files/python-3.4-pyfpe-dll.patch24
6 files changed, 0 insertions, 159 deletions
diff --git a/dev-lang/python/files/python-2.7.10-cross-compile-warn-test.patch b/dev-lang/python/files/python-2.7.10-cross-compile-warn-test.patch
deleted file mode 100644
index 38433de925..0000000000
--- a/dev-lang/python/files/python-2.7.10-cross-compile-warn-test.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-https://bugs.python.org/issue25397
-
-improve the cross-compile tests to be more focused
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1339,7 +1339,7 @@ if test "$GCC" = "yes"
- then
- AC_MSG_CHECKING(whether gcc supports ParseTuple __format__)
- save_CFLAGS=$CFLAGS
-- CFLAGS="$CFLAGS -Werror -Wformat"
-+ CFLAGS="$CFLAGS -Werror=format"
- AC_COMPILE_IFELSE([
- AC_LANG_PROGRAM([[void f(char*,...)__attribute((format(PyArg_ParseTuple, 1, 2)));]], [[]])
- ],[
-@@ -4458,7 +4458,7 @@ then
- [ac_cv_have_long_long_format="cross -- assuming no"
- if test x$GCC = xyes; then
- save_CFLAGS=$CFLAGS
-- CFLAGS="$CFLAGS -Werror -Wformat"
-+ CFLAGS="$CFLAGS -Werror=format"
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- #include <stdio.h>
- #include <stddef.h>
diff --git a/dev-lang/python/files/python-2.7.10-system-libffi.patch b/dev-lang/python/files/python-2.7.10-system-libffi.patch
deleted file mode 100644
index 0b49b794bd..0000000000
--- a/dev-lang/python/files/python-2.7.10-system-libffi.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-make sure we respect the system libffi setting in our build config.
-the compiler probing is fragile and can break in some situations.
-
---- a/setup.py
-+++ b/setup.py
-@@ -2069,7 +2069,7 @@ class PyBuildExt(build_ext):
- return True
-
- def detect_ctypes(self, inc_dirs, lib_dirs):
-- self.use_system_libffi = False
-+ self.use_system_libffi = ('--with-system-ffi' in sysconfig.get_config_var("CONFIG_ARGS"))
- include_dirs = []
- extra_compile_args = []
- extra_link_args = []
-@@ -2113,7 +2113,7 @@ class PyBuildExt(build_ext):
- sources=['_ctypes/_ctypes_test.c'])
- self.extensions.extend([ext, ext_test])
-
-- if not '--with-system-ffi' in sysconfig.get_config_var("CONFIG_ARGS"):
-+ if not self.use_system_libffi:
- return
-
- if host_platform == 'darwin':
-@@ -2141,10 +2141,10 @@ class PyBuildExt(build_ext):
- ffi_lib = lib_name
- break
-
-- if ffi_inc and ffi_lib:
-+ if ffi_inc:
- ext.include_dirs.extend(ffi_inc)
-+ if ffi_lib:
- ext.libraries.append(ffi_lib)
-- self.use_system_libffi = True
-
-
- class PyBuildInstall(install):
diff --git a/dev-lang/python/files/python-2.7.14-libffi-pkgconfig.patch b/dev-lang/python/files/python-2.7.14-libffi-pkgconfig.patch
deleted file mode 100644
index 85abb1b56b..0000000000
--- a/dev-lang/python/files/python-2.7.14-libffi-pkgconfig.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -u -r Python-2.7.5-orig//configure.ac Python-2.7.5/configure.ac
---- Python-2.7.5-orig//configure.ac 2014-03-06 04:35:31.000000000 +0100
-+++ Python-2.7.5/configure.ac 2014-03-06 04:58:10.000000000 +0100
-@@ -2300,10 +2300,13 @@
-
- if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
- LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
-+ LIBFFI_LIB="`"$PKG_CONFIG" libffi --libs-only-l 2>/dev/null | sed -e 's/^-l//;s/ *$//'`"
- else
- LIBFFI_INCLUDEDIR=""
-+ LIBFFI_LIB=""
- fi
- AC_SUBST(LIBFFI_INCLUDEDIR)
-+AC_SUBST(LIBFFI_LIB)
-
- AC_MSG_RESULT($with_system_ffi)
-
-diff -u -r Python-2.7.5-orig//Makefile.pre.in Python-2.7.5/Makefile.pre.in
---- Python-2.7.5-orig//Makefile.pre.in 2014-03-06 04:35:31.000000000 +0100
-+++ Python-2.7.5/Makefile.pre.in 2014-03-06 05:03:59.000000000 +0100
-@@ -224,6 +224,7 @@
-
-
- LIBFFI_INCLUDEDIR= @LIBFFI_INCLUDEDIR@
-+LIBFFI_LIB= @LIBFFI_LIB@
-
- ##########################################################################
- # Parser
-diff -u -r Python-2.7.5-orig//setup.py Python-2.7.5/setup.py
---- Python-2.7.5-orig//setup.py 2014-03-06 04:35:31.000000000 +0100
-+++ Python-2.7.5/setup.py 2014-03-06 04:56:15.000000000 +0100
-@@ -1893,8 +1893,10 @@
- ffi_inc = None
- print('Header file {} does not define LIBFFI_H or '
- 'ffi_wrapper_h'.format(ffi_h))
-- ffi_lib = None
-- if ffi_inc is not None:
-+ ffi_lib = sysconfig.get_config_var("LIBFFI_LIB")
-+ if not ffi_lib or ffi_lib == '':
-+ ffi_lib = None
-+ if ffi_inc is not None and ffi_lib is None:
- for lib_name in ('ffi_convenience', 'ffi_pic', 'ffi'):
- if (self.compiler.find_library_file(lib_dirs, lib_name)):
- ffi_lib = lib_name
diff --git a/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch b/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch
deleted file mode 100644
index a762dfb108..0000000000
--- a/dev-lang/python/files/python-2.7.5-nonfatal-compileall.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/Makefile.pre.in b/Makefile.pre.in
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -1000,12 +1000,12 @@
- $(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
- $(DESTDIR)$(LIBDEST)/distutils/tests ; \
- fi
-- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-+ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
- $(PYTHON_FOR_BUILD) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST) -f \
- -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
- $(DESTDIR)$(LIBDEST)
-- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-+ -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
- $(PYTHON_FOR_BUILD) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST) -f \
- -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
diff --git a/dev-lang/python/files/python-2.7.9-ncurses-pkg-config.patch b/dev-lang/python/files/python-2.7.9-ncurses-pkg-config.patch
deleted file mode 100644
index 38ce6f78b9..0000000000
--- a/dev-lang/python/files/python-2.7.9-ncurses-pkg-config.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-do not hardcode /usr/include paths
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -4316,7 +4316,7 @@ fi
-
- # first curses configure check
- ac_save_cppflags="$CPPFLAGS"
--CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
-+CPPFLAGS="$CPPFLAGS `$PKG_CONFIG --cflags ncursesw`"
-
- AC_CHECK_HEADERS(curses.h ncurses.h)
-
diff --git a/dev-lang/python/files/python-3.4-pyfpe-dll.patch b/dev-lang/python/files/python-3.4-pyfpe-dll.patch
deleted file mode 100644
index 401529d830..0000000000
--- a/dev-lang/python/files/python-3.4-pyfpe-dll.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- Python-3.4.3/Include/pyfpe.h
-+++ Python-3.4.3/Include/pyfpe.h
-@@ -129,9 +129,9 @@
- #include <signal.h>
- #include <setjmp.h>
- #include <math.h>
--extern jmp_buf PyFPE_jbuf;
--extern int PyFPE_counter;
--extern double PyFPE_dummy(void *);
-+PyAPI_DATA(jmp_buf) PyFPE_jbuf;
-+PyAPI_DATA(int) PyFPE_counter;
-+PyAPI_FUNC(double) PyFPE_dummy(void *);
-
- #define PyFPE_START_PROTECT(err_string, leave_stmt) \
- if (!PyFPE_counter++ && setjmp(PyFPE_jbuf)) { \
---- Python-3.4.3/Python/pyfpe.c
-+++ Python-3.4.3/Python/pyfpe.c
-@@ -1,5 +1,4 @@
--#include "pyconfig.h"
--#include "pyfpe.h"
-+#include "Python.h"
- /*
- * The signal handler for SIGFPE is actually declared in an external
- * module fpectl, or as preferred by the user. These variable