summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild
deleted file mode 100644
index 00233a5c4d..0000000000
--- a/dev-libs/libgcrypt/libgcrypt-1.8.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools flag-o-matic ltprune multilib-minimal
-
-DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
-HOMEPAGE="http://www.gnupg.org/"
-SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1 MIT"
-SLOT="0/20" # subslot = soname major version
-KEYWORDS="~ppc-aix ~x64-cygwin ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc static-libs"
-
-RDEPEND=">=dev-libs/libgpg-error-1.25[${MULTILIB_USEDEP}]
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
- )"
-DEPEND="${RDEPEND}
- doc? ( virtual/texi2dvi )"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.6.1-uscore.patch
- "${FILESDIR}"/${PN}-multilib-syspath.patch
-)
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/libgcrypt-config
-)
-
-src_prepare() {
- # missing attribute(sysv_abi) for Cygwin?
- [[ ${CHOST} == *-cygwin* ]] && rm -f mpi/*/*.S
- default
- # always use -no-undefined even if upstream is not convinced yet
- sed -i -e 's/^no_undefined\s*=\s*$/& -no-undefined/' src/Makefile.am || die
- eautoreconf
-}
-
-multilib_src_configure() {
- if [[ ${CHOST} == *86*-solaris* ]] ; then
- # ASM code uses GNU ELF syntax, divide in particular, we need to
- # allow this via ASFLAGS, since we don't have a flag-o-matic
- # function for that, we'll have to abuse cflags for this
- append-cflags -Wa,--divide
- fi
- local myeconfargs=(
- --disable-dependency-tracking
- --enable-noexecstack
- --disable-O-flag-munging
- $(use_enable static-libs static)
-
- # disabled due to various applications requiring privileges
- # after libgcrypt drops them (bug #468616)
- --without-capabilities
-
- $([[ ${CHOST} == sparcv9-*-solaris* ]] && echo "--disable-asm")
- # no cygwin patch yet
- $([[ ${CHOST} == *-cygwin* ]] && echo gcry_cv_gcc_win64_platform_as_ok=no)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
- default
- multilib_is_native_abi && use doc && VARTEXFONTS="${T}/fonts" emake -C doc gcrypt.pdf
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
- multilib_is_native_abi && use doc && dodoc doc/gcrypt.pdf
-}
-
-multilib_src_install_all() {
- default
- prune_libtool_files
-}