aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucian Poston <lucian.poston@gmail.com>2018-02-02 12:45:16 -0800
committerNP-Hardass <NP-Hardass@gentoo.org>2018-03-01 17:25:19 -0500
commit67d3fdb4c4df6e58046dfd955260fcf398c99151 (patch)
treeaf53c7b65871aa8adcab53b53c1f1ff8ae4e70fb
parentapp-emulation/wine-vanilla: Drop old (diff)
downloadwine-67d3fdb4.tar.gz
wine-67d3fdb4.tar.bz2
wine-67d3fdb4.zip
app-emulation/wine-vanilla: Add gssapi USE flag to 9999
Package-Manager: Portage-2.3.19, Repoman-2.3.6 Closes: https://github.com/gentoo/repo-proj-wine/pull/2 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org>
-rw-r--r--app-emulation/wine-vanilla/metadata.xml1
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/wine-vanilla/metadata.xml b/app-emulation/wine-vanilla/metadata.xml
index 411d8ae..b3a7a03 100644
--- a/app-emulation/wine-vanilla/metadata.xml
+++ b/app-emulation/wine-vanilla/metadata.xml
@@ -21,6 +21,7 @@ This variant of the Wine packaging does not include external patchsets
<flag name="custom-cflags">Bypass strip-flags; use at your own peril</flag>
<flag name="dos">Pull in <pkg>games-emulation/dosbox</pkg> to run DOS applications</flag>
<flag name="gecko">Add support for the Gecko engine when using iexplore</flag>
+ <flag name="gssapi">Use GSSAPI (Kerberos SSP support)</flag>
<flag name="gstreamer">Use <pkg>media-libs/gstreamer</pkg> to provide DirectShow functionality;</flag>
<flag name="mono">Add support for .NET using Wine's Mono add-on</flag>
<flag name="netapi">Use libnetapi from <pkg>net-fs/samba</pkg> to support Windows networks in netapi32.dll</flag>
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 55dd4ba..1c122ab 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -35,7 +35,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="${PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap +png prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype udev +udisks v4l +X +xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gsm gssapi gstreamer +jpeg kerberos kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap +png prelink pulseaudio +realtime +run-exes samba scanner selinux +ssl test +threads +truetype udev +udisks v4l +X +xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -61,6 +61,7 @@ COMMON_DEPEND="
fontconfig? ( media-libs/fontconfig:=[${MULTILIB_USEDEP}] )
gphoto2? ( media-libs/libgphoto2:=[${MULTILIB_USEDEP}] )
gsm? ( media-sound/gsm:=[${MULTILIB_USEDEP}] )
+ gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
gstreamer? (
media-libs/gstreamer:1.0[${MULTILIB_USEDEP}]
media-plugins/gst-plugins-meta:1.0[${MULTILIB_USEDEP}]
@@ -396,6 +397,7 @@ multilib_src_configure() {
$(use_enable gecko mshtml)
$(use_with gphoto2 gphoto)
$(use_with gsm)
+ $(use_with gssapi)
$(use_with gstreamer)
--without-hal
$(use_with jpeg)