summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-12-14 13:33:42 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2015-12-14 13:34:09 -0800
commit00309c45af7f470ea9604f52d8a4bdeae56442a6 (patch)
treee2b099e11376b98b58629a5bedb7657ecf31fe90
parentapp-admin/lastpass: bump to 3.2.16 #550834 #551312 (diff)
downloadgentoo-00309c45af7f470ea9604f52d8a4bdeae56442a6.tar.gz
gentoo-00309c45af7f470ea9604f52d8a4bdeae56442a6.tar.bz2
gentoo-00309c45af7f470ea9604f52d8a4bdeae56442a6.zip
app-admin/lastpass: Fixup chrome/chromium install destinations.
Package-Manager: portage-2.2.24
-rw-r--r--app-admin/lastpass/Manifest2
-rw-r--r--app-admin/lastpass/lastpass-3.2.16.ebuild33
2 files changed, 17 insertions, 18 deletions
diff --git a/app-admin/lastpass/Manifest b/app-admin/lastpass/Manifest
index d9d86df089ed..6b2dbc17caf3 100644
--- a/app-admin/lastpass/Manifest
+++ b/app-admin/lastpass/Manifest
@@ -1,3 +1,3 @@
-DIST lastpass-3.2.16.tar.bz2 1621919 SHA256 c06fd97e74298c5e7d698b2c8cffce7d79f0c45126daeb27bca91d3403fd893c SHA512 ed77f3ca979d84021e27088a5d1d7e0b102f6ce15f675a7b99810e88760844182b8597670bbe45c9436b42889597c8c421d1acb6abe24085bbd2623b7984d37d WHIRLPOOL 192d332348db9ad68a5e63441e17c0ef954de058376f110dcd05dfe261d54f1c9a179a9c647dc9d5090ffefe8af68a9dbe446dea7a1fb46b1f6c2e458752417d
DIST lp_linux-3.2.16.xpi 6328266 SHA256 e06364ce631f436246cfca19ff24a2483bc459a5e31178f2c6acd57c1f408f81 SHA512 343d0763f25c31fb7dbde2c9aa19d797431ee9f7bb1f8ae220fd4cac2cc8f439813d92ecb432047f5889967eca7bd4197a7f2725fc52669d022c9f44b7d4945e WHIRLPOOL 5b64cdf371b9ff9ac46030393b22fd92c4fa6493947f47d91a2f44c7019ffcfe1344447456398c2991aee5cbc45bf95b39d90a6a423f6a2e284ac88d2d75d2f8
DIST lpchrome_linux-3.2.16.crx 5310273 SHA256 58ec7c7dfa735c5d052b0ca253f85654fd381952533a4a2b125d3abb88e77d39 SHA512 a7d3198ace665bcbbe0a7bdc9dcb4dc165aaa39214df798fe28930d3cc340976a476b8afc4f19af1acc6cbbe61feff8dfa5cc6c2b4c6d4a04b0377752ce1ca54 WHIRLPOOL 9b281945cd8603516e11a9a2f4869622d6783a56670253cdcc4a51a7ddae84a1a5297956d491b4e17e449a01acf6e8a4e3cc0a8b494f973078e617fe041ed615
+DIST lplinux-3.2.16.tar.bz2 1621919 SHA256 c06fd97e74298c5e7d698b2c8cffce7d79f0c45126daeb27bca91d3403fd893c SHA512 ed77f3ca979d84021e27088a5d1d7e0b102f6ce15f675a7b99810e88760844182b8597670bbe45c9436b42889597c8c421d1acb6abe24085bbd2623b7984d37d WHIRLPOOL 192d332348db9ad68a5e63441e17c0ef954de058376f110dcd05dfe261d54f1c9a179a9c647dc9d5090ffefe8af68a9dbe446dea7a1fb46b1f6c2e458752417d
diff --git a/app-admin/lastpass/lastpass-3.2.16.ebuild b/app-admin/lastpass/lastpass-3.2.16.ebuild
index c5047a64ec1c..98e32455a92c 100644
--- a/app-admin/lastpass/lastpass-3.2.16.ebuild
+++ b/app-admin/lastpass/lastpass-3.2.16.ebuild
@@ -8,11 +8,13 @@ inherit eutils
DESCRIPTION="Online password manager and form filler that makes web browsing easier and more secure"
HOMEPAGE="https://lastpass.com/misc_download2.php"
# sadly, upstream has no versioned distfiles
-MAINDISTFILE=lplinux.tar.bz2
+DIST_MAIN=lplinux-${PV}.tar.bz2
+DIST_CRX=lpchrome_linux-${PV}.crx # Use by both firefox+chrome/chromimum code
+DIST_XPI=lp_linux-${PV}.xpi
SRC_URI="
- https://lastpass.com/${MAINDISTFILE} -> ${P}.tar.bz2
- https://lastpass.com/lpchrome_linux.crx -> lpchrome_linux-${PV}.crx
- firefox? ( https://lastpass.com/lp_linux.xpi -> lp_linux-${PV}.xpi )"
+ https://lastpass.com/lplinux.tar.bz2 -> ${DIST_MAIN}
+ https://lastpass.com/lpchrome_linux.crx -> ${DIST_CRX}
+ firefox? ( https://lastpass.com/lp_linux.xpi -> ${DIST_XPI} )"
LICENSE="LastPass"
SLOT="0"
@@ -43,11 +45,11 @@ QA_PREBUILT="
S="${WORKDIR}"
src_unpack() {
- unpack ${P}.tar.bz2
+ unpack ${DIST_MAIN}
mkdir -p "${S}"/crx || die
# bug #524864: strip Chrome CRX header
# otherwise the unzip warning can be fatal in some cases
- dd bs=306 skip=1 if="${DISTDIR}"/lpchrome_linux-${PV}.crx of="${T}"/lpchrome_linux.zip 2>/dev/null || die
+ dd bs=306 skip=1 if="${DISTDIR}"/${DIST_CRX} of="${T}"/lpchrome_linux.zip 2>/dev/null || die
unzip -qq -o "${T}"/lpchrome_linux.zip -d "${S}"/crx || die
}
@@ -85,23 +87,20 @@ src_install() {
}
EOF
- if use chromium; then
- insinto /etc/chromium/policies/managed
+ for d in \
+ $(usex chromium /etc/chromium '') \
+ $(usex chrome /etc/opt/chrome '') \
+ ; do
+ insinto ${d}/policies/managed
doins "${T}"/lastpass_policy.json
- insinto /etc/opt/chrome/native-messaging-hosts/
+ insinto ${d}/native-messaging-hosts
doins "${T}"/com.lastpass.nplastpass.json
- fi
- if use chrome; then
- insinto /etc/opt/chrome/policies/managed/
- doins "${T}"/lastpass_policy.json
- insinto /etc/chromium/native-messaging-hosts
- doins "${T}"/com.lastpass.nplastpass.json
- fi
+ done
if use firefox; then
d="$D/usr/$(get_libdir)/firefox/browser/extensions/support@lastpass.com"
mkdir -p $d || die
- unzip -qq -o "${DISTDIR}/lp_linux-${PV}.xpi" -d "$d" || die
+ unzip -qq -o "${DISTDIR}/${DIST_XPI}" -d "$d" || die
fi
}