summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-02 10:33:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-02 10:36:49 +0200
commit00aef80d1201c5e7658aa7093f3744872713e022 (patch)
tree119a7279af2cd19c9d9d5f32d1fed2677afb5f17
parentdev-python/pipfile: Remove py2.7 (diff)
downloadgentoo-00aef80d1201c5e7658aa7093f3744872713e022.tar.gz
gentoo-00aef80d1201c5e7658aa7093f3744872713e022.tar.bz2
gentoo-00aef80d1201c5e7658aa7093f3744872713e022.zip
dev-python/pmw: Remove old (py2.7)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pmw/Manifest1
-rw-r--r--dev-python/pmw/files/pmw-1.3.3-install-no-docs.patch17
-rw-r--r--dev-python/pmw/pmw-1.3.3-r3.ebuild56
3 files changed, 0 insertions, 74 deletions
diff --git a/dev-python/pmw/Manifest b/dev-python/pmw/Manifest
index 8965646b1334..42cbe402c60e 100644
--- a/dev-python/pmw/Manifest
+++ b/dev-python/pmw/Manifest
@@ -1,2 +1 @@
DIST Pmw-2.0.1.tar.gz 830448 BLAKE2B c78fef1570a34b9784f936f16856c4450164d8a232770e59cc084c1113888af8ee002cd1c7ddeadcddaacb5eae9ff58fcbfc270fc066875523e31a9d26770cd3 SHA512 99654e961aa40a64eebc08fe473e94da0ce431e6465255c68c251dfd544a51edef1a5d97dfd89ce756eb5f7fcf917dbef27f646ba9451ab72f3d460daa09a556
-DIST Pmw.1.3.3.tar.gz 451232 BLAKE2B 2ea74cf010b094539b1e052850b358e05a561aee1990de7184244b77a4133c1259ff54fa6e47c5368dac4bf81bf23e9217742ef1327ab7e20b8dca27ebf5f333 SHA512 d63fad8f8c5bb9b8cb940b10bdf9e3bc1dabe714e10f32c587d5e1097ef0767492602984089172d85cf57c8ebf34acf555b8fe73a2157c6f734ee36042803668
diff --git a/dev-python/pmw/files/pmw-1.3.3-install-no-docs.patch b/dev-python/pmw/files/pmw-1.3.3-install-no-docs.patch
deleted file mode 100644
index bbfd0f35f1c4..000000000000
--- a/dev-python/pmw/files/pmw-1.3.3-install-no-docs.patch
+++ /dev/null
@@ -1,17 +0,0 @@
- src/setup.py | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index a5f9039..cfcf8a2 100755
---- a/setup.py
-+++ b/setup.py
-@@ -16,9 +16,7 @@ setup(name="Pmw",
- 'Pmw.Pmw_1_3_3.lib',],
-
- package_data={'Pmw': ['Pmw_1_3_3/lib/Pmw.def',
-- 'Pmw_1_3_3/doc/*',
- 'Pmw_1_3_3/contrib/*',
-- 'Pmw_1_3_3/demos/*',
- 'Pmw_1_3_3/tests/*',
- 'Pmw_1_3_3/bin/*',
- ]
diff --git a/dev-python/pmw/pmw-1.3.3-r3.ebuild b/dev-python/pmw/pmw-1.3.3-r3.ebuild
deleted file mode 100644
index 882fea57a9a2..000000000000
--- a/dev-python/pmw/pmw-1.3.3-r3.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="tk"
-
-inherit distutils-r1
-
-MY_P="Pmw.${PV}"
-
-DESCRIPTION="Toolkit for building high-level compound Python widgets using the Tkinter module"
-HOMEPAGE="http://pmw.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="py2"
-KEYWORDS="~alpha amd64 ~ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="doc examples"
-
-DEPEND="!dev-python/pmw:0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/src"
-
-DOCS="Pmw/README"
-# https://sourceforge.net/p/pmw/bugs/39/
-RESTRICT="test"
-
-PATCHES=( "${FILESDIR}"/${P}-install-no-docs.patch )
-
-python_test() {
- cd "${BUILD_DIR}/lib/Pmw/Pmw_1_3_3/" || die
- PYTHONPATH=PYTHONPATH=tests:../../
- cp tests/{flagup.bmp,earthris.gif} . || die
- for test in tests/*_test.py; do
- echo "running test "$test
- PYTHONPATH=tests:../../ "${PYTHON}" $test || die
- done
-}
-
-python_install_all() {
- local DIR="Pmw/Pmw_1_3_3"
-
- if use doc; then
- dodoc -r ${DIR}/doc/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins ${DIR}/demos/*
- fi
-
- distutils-r1_python_install_all
-}