summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Günzler <r@gnzler.io>2021-03-04 16:18:42 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-04-10 10:36:45 +0300
commit01f423197df089f0689748ad2d6edd61bf16230c (patch)
tree2bcd1cb1fa104cd5ef0713a362fb59143da476b2
parentapp-text/master-pdf-editor: drop 5.7.20 (diff)
downloadgentoo-01f423197df089f0689748ad2d6edd61bf16230c.tar.gz
gentoo-01f423197df089f0689748ad2d6edd61bf16230c.tar.bz2
gentoo-01f423197df089f0689748ad2d6edd61bf16230c.zip
app-emulation/crun: bump to 0.18
Signed-off-by: Robert Günzler <r@gnzler.io> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-emulation/crun/Manifest1
-rw-r--r--app-emulation/crun/crun-0.18.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
index f13ef6520147..d49ac8fea825 100644
--- a/app-emulation/crun/Manifest
+++ b/app-emulation/crun/Manifest
@@ -1,2 +1,3 @@
DIST crun-0.16.tar.gz 1370194 BLAKE2B c2a2450518226421b43d93597b38da80ca330cb3d8d9c259f323d49561e93dc3d003a25599eb8e918888dd824037c53bd0a07624c3154fa3778cc6dad37ac04b SHA512 f5a0d19c037af55478ee5f83b63d74277c8640f715b81a8233d3f1acd4cdfdad491e5c1f5beda04d0d7aa16693e9a004b0bde71343b082aa514ae76e5907d029
DIST crun-0.17.tar.gz 1385658 BLAKE2B 3d4c30989b9e79d02bf9a6c298daa8d0b5b6b8bfcfaca8ae9e27ad865762a32b6af2c8806586bba2ab94271446a93c34e8f2d465cc008c41bbe69e565556a1b1 SHA512 b095a3c4fca8ae683553805de468594e8dd891cc9911b56e8be7c429584e71fb40a364cf55a6a829950078a539d35308310f53f57b8fb40d483d394e91b20b01
+DIST crun-0.18.tar.gz 1394857 BLAKE2B db4f0407aaf5e4c5b9069ad5ae6a76308665d91559d92bf370b964e0914f337a84af896f1c1e00184ef4b0625bd1c0f1e2fc3295074c7f5524c5359ce54ba6b4 SHA512 94610d9d4ef95a9be708c6cf8cc38587c9c3b847d9da5cf9dfa4a2eddddb7e6724e39ffb222ed5d6c61bad8374ae50dc9e92d95b6d03ce0b185d5123afeeca46
diff --git a/app-emulation/crun/crun-0.18.ebuild b/app-emulation/crun/crun-0.18.ebuild
new file mode 100644
index 000000000000..bc97b2bddb13
--- /dev/null
+++ b/app-emulation/crun/crun-0.18.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
+HOMEPAGE="https://github.com/containers/crun"
+SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="+bpf +caps criu +seccomp systemd static-libs"
+
+DEPEND="
+ sys-kernel/linux-headers
+ >=dev-libs/yajl-2.0.0
+ caps? ( sys-libs/libcap )
+ criu? ( >=sys-process/criu-3.15 )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+# the crun test suite is comprehensive to the extent that tests will fail
+# within a sandbox environment, due to the nature of the privileges
+# required to create linux "containers".
+RESTRICT="test"
+
+DOCS=( README.md )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable bpf)
+ $(use_enable caps)
+ $(use_enable criu)
+ $(use_enable seccomp)
+ $(use_enable systemd)
+ $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake -C libocispec
+ emake crun
+}
+
+src_install() {
+ emake "DESTDIR=${D}" install-exec
+ doman crun.1
+ einstalldocs
+}