summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-05 14:07:48 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-05 14:08:30 +0200
commit020c1d32e52f5abe09c168f60e7ab943bdd24ea1 (patch)
tree06c094503c9a89fdf4e7a618215a1448144e6613
parentprofiles/package.mask: mask xca snapshot for testing (diff)
downloadgentoo-020c1d32e52f5abe09c168f60e7ab943bdd24ea1.tar.gz
gentoo-020c1d32e52f5abe09c168f60e7ab943bdd24ea1.tar.bz2
gentoo-020c1d32e52f5abe09c168f60e7ab943bdd24ea1.zip
app-crypt/xca: add 2.4.0_p20230526
This is an upstream snapshot that does compile against openssl-3 but also has known defects. Currently masked for testing. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--app-crypt/xca/Manifest1
-rw-r--r--app-crypt/xca/xca-2.4.0_p20230526.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index c574d0033cc0..278f8001cb02 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1 +1,2 @@
DIST xca-2.4.0.tar.gz 1778572 BLAKE2B 2e90ef264dc53019cc37700b37d5eb0c48904ca371ae1ce0cfe2ad61be8765951ea918d356c1f2764e73d846693a66c903cba1381df5d1a588aae8bb45f8c195 SHA512 e93e2cf9dc48ed43ee9b51e977f825d81ff08835eb4d77fcbe8f9dc8ce31c77c1da879b48c25ab535717542d1fe84faa6e46c410c116edbee02072040c59667c
+DIST xca-2.4.0_p20230526.tar.gz 1818483 BLAKE2B bac990117d1d6a4f80d4ad2317653d8817c7d97e3ea4e92e6fcb6a1531eb782ead4a0504748107697be6e98816e89f33f43de1a8073394e4ead39c16dee3987e SHA512 1252a8230149b04c98dab6ec5fc7f424b6eb1552553831e1c53690fa55ce919537d20741dd9f0e9ac7495d3f80503d2b6b5f0c9322912226363e2b5feb66e416
diff --git a/app-crypt/xca/xca-2.4.0_p20230526.ebuild b/app-crypt/xca/xca-2.4.0_p20230526.ebuild
new file mode 100644
index 000000000000..3945599273e0
--- /dev/null
+++ b/app-crypt/xca/xca-2.4.0_p20230526.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake xdg-utils
+
+COMMIT=8983e5010d99c8d37bc7e316bf3ef00265763027
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="https://hohnstaedt.de/xca/"
+#SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+SRC_URI="https://github.com/chris2511/xca/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/xca-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qthelp:5
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-libs/openssl:*
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQTFIXEDVERSION=Qt5
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ ewarn "Make a backup copy of your database!"
+ ewarn "Version 2 completely changes the database format to SQL(ite)"
+ ewarn "Don't try to open it with older versions of XCA (< 1.4.0). They will corrupt the database."
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}