summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-13 18:42:05 +0100
committerSam James <sam@gentoo.org>2023-06-13 18:59:50 +0100
commit02512e1d120272ad4e035959fa4014a8df7a28fc (patch)
tree713770e3eafb2aa534688028932b2c24e38e3239
parentnet-vpn/openvpn: dekeyword ia64 (diff)
downloadgentoo-02512e1d120272ad4e035959fa4014a8df7a28fc.tar.gz
gentoo-02512e1d120272ad4e035959fa4014a8df7a28fc.tar.bz2
gentoo-02512e1d120272ad4e035959fa4014a8df7a28fc.zip
sys-cluster/drbd-utils: add 9.23.1
Bug: https://bugs.gentoo.org/863728 Closes: https://bugs.gentoo.org/828057 Closes: https://bugs.gentoo.org/828058 Closes: https://bugs.gentoo.org/832021 Closes: https://bugs.gentoo.org/880973 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-cluster/drbd-utils/Manifest1
-rw-r--r--sys-cluster/drbd-utils/drbd-utils-9.23.1.ebuild129
-rw-r--r--sys-cluster/drbd-utils/files/drbd-utils-9.23.1-respect-flags.patch21
3 files changed, 151 insertions, 0 deletions
diff --git a/sys-cluster/drbd-utils/Manifest b/sys-cluster/drbd-utils/Manifest
index e6ad5260cac6..86c5b2f714f3 100644
--- a/sys-cluster/drbd-utils/Manifest
+++ b/sys-cluster/drbd-utils/Manifest
@@ -1,2 +1,3 @@
DIST drbd-utils-9.15.1.tar.gz 1229196 BLAKE2B c73cb624e4c35f2c5c001b4545c2ad806d3f13471aa25b0941d923020fe01a73405d1ed7c2ab2efe3afee0e59b8e9d401072edb788c57dc338fe3ddb4eebebf3 SHA512 bf9c46335500c0dd7afdc160221acaf8fd053afc453cb26cd76ef085c41580be5a62021ef1f1a57eac9df70d1158a008f489d1a8bb5c3329c5a187f79e4942de
DIST drbd-utils-9.19.1.tar.gz 1265184 BLAKE2B b26fd9abd6408df4ccaa46c4713ece1743386bb4727ad8206498c30189d6c119ced57ec2d528c0575c5192cf366998b5f7db99aaecf1a2ba6af028b87c4ae082 SHA512 65d8f5802c541781895c59a5f631b222746b21615049e53f77d6c36a7255c51fe5d062984174ab8578d64af104fe9d66df5ae185ba50a8c38813c12a69fceb22
+DIST drbd-utils-9.23.1.tar.gz 1279916 BLAKE2B f631473d7ff2d569e2e5dc61940085f4d575baaa1e02eaba50f37b15e9b381afb9089d4e50fbd511dc7c73350a9e5552b16a1e80742151801e5068c12830a469 SHA512 8befaa20f4217fb83b127bad332a96be61ffd0cefca78b298dbede4c7f33424e8f27aeb251bb022bb4e1ade11307448cdf39d5750924fcf2711141a29e7a81f0
diff --git a/sys-cluster/drbd-utils/drbd-utils-9.23.1.ebuild b/sys-cluster/drbd-utils/drbd-utils-9.23.1.ebuild
new file mode 100644
index 000000000000..1ca0cd8e56f3
--- /dev/null
+++ b/sys-cluster/drbd-utils/drbd-utils-9.23.1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1 linux-info tmpfiles udev
+
+DESCRIPTION="mirror/replicate block-devices across a network-connection"
+HOMEPAGE="https://www.linbit.com/drbd"
+SRC_URI="https://pkg.linbit.com/downloads/drbd/utils/${P}.tar.gz"
+S="${WORKDIR}/${P/_/}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pacemaker split-usr +udev xen"
+
+DEPEND="
+ pacemaker? ( sys-cluster/pacemaker )
+ udev? ( virtual/udev )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="sys-devel/flex"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.15.1-run-lock.patch
+ "${FILESDIR}"/${PN}-9.23.1-respect-flags.patch
+)
+
+pkg_setup() {
+ # verify that CONFIG_BLK_DEV_DRBD is enabled in the kernel or
+ # warn otherwise
+ linux-info_pkg_setup
+ elog "Checking for suitable kernel configuration options..."
+ if linux_config_exists; then
+ if ! linux_chkconfig_present BLK_DEV_DRBD; then
+ ewarn "CONFIG_BLK_DEV_DRBD: is not set when it should be."
+ elog "Please check to make sure these options are set correctly."
+ fi
+ else
+ ewarn "Could not check if CONFIG_BLK_DEV_DRBD is enabled in your kernel."
+ elog "Please check to make sure these options are set correctly."
+ fi
+}
+
+src_prepare() {
+ # Respect LDFLAGS, bug #453442
+ sed -e "s/\$(CC) -o/\$(CC) \$(LDFLAGS) -o/" \
+ -e "/\$(DESTDIR)\$(localstatedir)\/lock/d" \
+ -i user/*/Makefile.in || die
+
+ # Respect multilib, bug #698304
+ sed -i -e "s:/lib/:/$(get_libdir)/:g" \
+ Makefile.in scripts/{Makefile.in,global_common.conf,drbd.conf.example} || die
+ sed -e "s:@prefix@/lib:@prefix@/$(get_libdir):" \
+ -e "s:(DESTDIR)/lib:(DESTDIR)/$(get_libdir):" \
+ -i user/*/Makefile.in || die
+ sed -i -e "s/lib/$(get_libdir)/" scripts/drbd.service || die
+
+ # Correct install paths (really correct this time)
+ sed -i -e "s:\$(sysconfdir)/bash_completion.d:$(get_bashcompdir):" \
+ scripts/Makefile.in || die
+
+ # Don't participate in user survey, bug #360483
+ sed -i -e '/usage-count/ s/yes/no/' scripts/global_common.conf || die
+ sed -i -e "s:\$(sysconfdir)/udev:$(get_udevdir):" scripts/Makefile.in || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}"/var
+ --with-bashcompletion
+ --with-distro=gentoo
+ --with-prebuiltman
+ --without-rgmanager
+ $(use_with pacemaker)
+ $(use_with udev)
+ $(use_with xen)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Only compile the tools
+ emake CXXFLAGS="${CXXFLAGS}" OPTFLAGS="${CFLAGS}" tools doc
+}
+
+src_install() {
+ # Only install the tools
+ emake DESTDIR="${D}" install-tools install-doc
+
+ # Install our own init script
+ newinitd "${FILESDIR}"/${PN}-8.0.rc ${PN/-utils/}
+
+ dodoc scripts/drbd.conf.example
+
+ keepdir /var/lib/drbd
+ rm -r "${ED}"/var/run || die
+
+ newtmpfiles scripts/drbd.tmpfiles.conf drbd.conf
+
+ # bug #698304
+ dodir /lib/drbd
+ local i
+ for i in drbdadm-83 drbdadm-84 drbdsetup-83 drbdsetup-84; do
+ dosym -r /$(get_libdir)/drbd/"${i}" /lib/drbd/"${i}"
+ done
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ tmpfiles_process drbd.conf
+
+ einfo
+ einfo "Please copy and gunzip the configuration file:"
+ einfo "from ${EROOT}/usr/share/doc/${PF}/${PN/-utils/}.conf.example.bz2 to ${EROOT}/etc/${PN/-utils/}.conf"
+ einfo "and edit it to your needs. Helpful commands:"
+ einfo "man 5 drbd.conf"
+ einfo "man 8 drbdsetup"
+ einfo "man 8 drbdadm"
+ einfo "man 8 drbddisk"
+ einfo "man 8 drbdmeta"
+ einfo
+}
diff --git a/sys-cluster/drbd-utils/files/drbd-utils-9.23.1-respect-flags.patch b/sys-cluster/drbd-utils/files/drbd-utils-9.23.1-respect-flags.patch
new file mode 100644
index 000000000000..259f6aa35632
--- /dev/null
+++ b/sys-cluster/drbd-utils/files/drbd-utils-9.23.1-respect-flags.patch
@@ -0,0 +1,21 @@
+--- a/user/drbdmon/Makefile.in
++++ b/user/drbdmon/Makefile.in
+@@ -1,6 +1,6 @@
+-CXXFLAGS=-std=c++11 -I. -I../shared -Icppdsaext/src -Wall -Werror -pedantic-errors -fPIC -O2 \
+--Wsign-compare -Wpointer-arith -Wswitch-default -Wswitch-enum -Wtype-limits \
+--Wmissing-declarations -Wshadow
++CPPFLAGS = -I. -I../shared -Icppdsaext/src
++CXXFLAGS ?= -Wall -Werror -pedantic-errors -fPIC -O2 -Wsign-compare -Wpointer-arith -Wswitch-default -Wswitch-enum -Wtype-limits -Wmissing-declarations -Wshadow
++CXXFLAGS += -std=c++11 -O2 -fPIC
+ CXX = @CXX@
+ LIBS = @LIBS@
+
+@@ -51,7 +51,7 @@ $(dsaext-obj): $(basename $(dsaext-obj)).cpp $(basename $(dsaext-obj)).h
+ $(integerparse-obj): $(basename $(integerparse-obj)).cpp $(basename $(integerparse-obj)).h
+
+ drbdmon: $(ls-obj)
+- $(CXX) -o $@ $(CPPFLAGS) $(CXXFLAGS) $^ $(LIBS)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ # do not try to rebuild Makefile itself
+ Makefile: ;