summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-13 06:19:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-13 06:19:54 +0200
commit02954f971f9383a6ba8107d815d915b21a84535c (patch)
treeb8c9bbcdecaa0eddae049c69a40df495fabb401b
parentdev-python/hypothesis: Bump to 6.87.4 (diff)
downloadgentoo-02954f971f9383a6ba8107d815d915b21a84535c.tar.gz
gentoo-02954f971f9383a6ba8107d815d915b21a84535c.tar.bz2
gentoo-02954f971f9383a6ba8107d815d915b21a84535c.zip
dev-python/pycodestyle: Bump to 2.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycodestyle/Manifest1
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.11.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index 7fd01a012004..bbeca403b2b5 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1 +1,2 @@
DIST pycodestyle-2.11.0.gh.tar.gz 79772 BLAKE2B 5995cae91a9e1109b697fae840d1dccd4778096dded7357bdbca1a56b06a031fc524f638e91192564f127b2bc52e94c9e80b2437daac5a129db48f99ca701e48 SHA512 fd688544a7fb01a7e3f4f8cb411cf7bc5b6dfc357de616a2ef61944748ad670c239148766b8ea48a3c316396251ed8a8d8937446f400c28e631621a0d16d3cf5
+DIST pycodestyle-2.11.1.gh.tar.gz 79865 BLAKE2B b4d9ab3d50aba87e7194abd6b3b317183932cd9e5331c95b57f498704643bce2f459ca9fa2016cc2544f31fb9cbe3390c083fd651ede10f131bc1d6f5e462f23 SHA512 8e1f302d7e26d56edd924202435caef32369ea13eb4a0fdfb48c06bb5d77fd7a5aef92d470eef3e6fdd9c3b298751a52a83317e9ddf8b2aa7e3fedc75fb5151a
diff --git a/dev-python/pycodestyle/pycodestyle-2.11.1.ebuild b/dev-python/pycodestyle/pycodestyle-2.11.1.ebuild
new file mode 100644
index 000000000000..efb9462cf118
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="
+ https://pycodestyle.pycqa.org/en/latest/
+ https://github.com/PyCQA/pycodestyle/
+ https://pypi.org/project/pycodestyle/
+"
+# 2.11.0 broke sdist
+# https://github.com/PyCQA/pycodestyle/issues/1183
+SRC_URI="
+ https://github.com/PyCQA/pycodestyle/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest