summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-05 10:38:42 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-05 10:38:42 +0100
commit037b54872972f77b1ee67a826b333742e38d365e (patch)
treefe85bd5b4459bb43a9a750c2443e776da6a11294
parentapp-forensics/honggfuzz: add a binutils-libs version cap (diff)
downloadgentoo-037b54872972f77b1ee67a826b333742e38d365e.tar.gz
gentoo-037b54872972f77b1ee67a826b333742e38d365e.tar.bz2
gentoo-037b54872972f77b1ee67a826b333742e38d365e.zip
net-proxy/obfs4proxy: add 0.0.14
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-proxy/obfs4proxy/Manifest2
-rw-r--r--net-proxy/obfs4proxy/obfs4proxy-0.0.14.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/net-proxy/obfs4proxy/Manifest b/net-proxy/obfs4proxy/Manifest
index a7e861df32c2..2a680ef9d002 100644
--- a/net-proxy/obfs4proxy/Manifest
+++ b/net-proxy/obfs4proxy/Manifest
@@ -1,2 +1,4 @@
DIST obfs4proxy-0.0.13-vendor.tar.xz 77920 BLAKE2B 72a41e4d103d55382d275f4e55915916c2f291a73052f519eebd3f7b864cbbe7784a8b1904a946f658e2a3f6ba3705ea1aa7149fdff5f4fbb5a2977e83ca6719 SHA512 7153130fdf13aefcd10d98a240d7f2f85e8ce1a5333ba2f68daee8fe03967b67f96442d5473804b9744ca782732c86265b3661378848669cb187938d8e1acdba
DIST obfs4proxy-0.0.13.tar.gz 86593 BLAKE2B 1ac3adaa0c1c4169635abc511f3232d22c3164ec28305725c1b3d64b5d61b8f30296d3bd6633ad81030f017e32b0b49fc6487784d2c39b0ac7e8075504519b1b SHA512 5be0eacba6848ba89e7b7b873741e39e7807745f4648af63a81000ce1d2380fb0632d4b04e832071ca8051312360a0b79bb8d86f1e0f02a8bb5344fbfeeaf3fe
+DIST obfs4proxy-0.0.14-deps.tar.xz 23134868 BLAKE2B befa45afeb9566dbf46be07ae469dca305d91584b04f6cb8529c50c2d1b3fb94e0adc6434ffa069b8fa1af6be2a29ffc550a7bcf1aa45eac0ed66252e37a31f8 SHA512 81f4bb778230c2f040dd1682ffaff3a635d4a57a5cef42b9d4ff7df486476cb037d7851d6e8ce5bb021c6a9a5116355e963eccfc2d1fd94cbc24df21bff7ff2e
+DIST obfs4proxy-0.0.14.tar.gz 88649 BLAKE2B 6d2198dee67998b1793c28d77dbfd8f922248e8acba481ea9496567652e132fe45c09061b3052dcdebe0dbc356744ea454641789dc688ed333ede73186b8c69a SHA512 2e28516ab888485d14d7f60fc0bee9a8268faf681803c71faff49185b7870cc0c5a6df3dbbb2a4d446307997812092ca64070be978997bc82cc89ee435698feb
diff --git a/net-proxy/obfs4proxy/obfs4proxy-0.0.14.ebuild b/net-proxy/obfs4proxy/obfs4proxy-0.0.14.ebuild
new file mode 100644
index 000000000000..bc418d43c1b7
--- /dev/null
+++ b/net-proxy/obfs4proxy/obfs4proxy-0.0.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="An obfuscating proxy supporting Tor's pluggable transport protocol obfs4"
+HOMEPAGE="https://gitlab.com/yawning/obfs4"
+SRC_URI="https://gitlab.com/yawning/obfs4/-/archive/${P}/obfs4-${P}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+# See https://gitlab.com/yawning/obfs4/-/issues/5#note_573104796 for licence clarification
+LICENSE="BSD CC0-1.0 BZIP2 GPL-3+ MIT public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+S="${WORKDIR}/obfs4-${P}"
+
+DOCS=( README.md ChangeLog LICENSE-GPL3.txt doc/obfs4-spec.txt )
+
+src_compile() {
+ go build -o ${PN}/${PN} ./${PN} || die
+}
+
+src_install() {
+ default
+ dobin ${PN}/${PN}
+ doman doc/${PN}.1
+}