summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-04-26 15:46:19 +0800
committerYixun Lan <dlan@gentoo.org>2022-04-26 16:01:35 +0800
commit04fada8afec829dc4b26d4bcc0707a2b66609498 (patch)
treeb423fbb3e11782f4530b1b18badb42e14bbb2353
parentapp-admin/exo: remove old (diff)
downloadgentoo-04fada8afec829dc4b26d4bcc0707a2b66609498.tar.gz
gentoo-04fada8afec829dc4b26d4bcc0707a2b66609498.tar.bz2
gentoo-04fada8afec829dc4b26d4bcc0707a2b66609498.zip
dev-util/lttng-modules: add 2.13.3
Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--dev-util/lttng-modules/Manifest1
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.13.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/lttng-modules/Manifest b/dev-util/lttng-modules/Manifest
index 0e177e347bf5..560b650579fa 100644
--- a/dev-util/lttng-modules/Manifest
+++ b/dev-util/lttng-modules/Manifest
@@ -4,3 +4,4 @@ DIST lttng-modules-2.11.8.tar.bz2 316947 BLAKE2B 61dc2abe8d61242b5157fcc93d8b6cb
DIST lttng-modules-2.12.5.tar.bz2 317002 BLAKE2B 9f42f8641dca7ce55e7445495c747ce340919458a23b4d471998fe2a28dd26bc7dfa5edbccf0b11877176091dee0c4d63fdda919c03afc8dad3fcfb7e9529c33 SHA512 81524dac513384852555a6f5619dc10286a2f7d4e3032ee9ca33705e830ee3bc3dc8c96b89a9c09dd5df2bf29944e3e566d1ac1a6cd6be83718af9836e043991
DIST lttng-modules-2.12.6.tar.bz2 318479 BLAKE2B 7cac6dd7dcb12801a32179ced4bb141a7af87c864eb71b793e65b905e4a0ba3d3273609bd3cd80c9c1251914a39e62da0a85e18058480da0c4eb2d6eb44f851c SHA512 608112b960d47ed5f979c7f2de2886d3fbe78a0d2eaec0892bfbca92bdad423e8ba8c3960836f71045c79d9c1b9eac88757400726656e98fb0ae70035e0073aa
DIST lttng-modules-2.13.0.tar.bz2 342499 BLAKE2B 81feb1b93972ab5605b40db4acc46ba9c9383211b3b176b14301c302b68d76b4490bc433176073b4ee9bde4c2ad66ebd6c1d4aeec359cc4dc8b0f26525ef9a5d SHA512 f2fcc8c16867fb79061a46381d27b26a8f49000475cd2f6ad8a9ebc1d8b11cab840d62e38df1aaad68908aa5a29c62c47c986eb281027b226e115dd4a25cd611
+DIST lttng-modules-2.13.3.tar.bz2 343593 BLAKE2B a0c914af0118327cb6d785c7c018d2d9cbd2139bbc3e0524a9c96832c7214fea7fc2a0dd8a8770db0728aba6ca3e9f30ea6e790575fb4d3492d9a7485993f293 SHA512 a0329c4709cc1a5fcc8d667d7435bc57b37cfa95da5451a8ee6ab700f334365e2d78e085e537376948dfe95d433016be5f6e3b5e5aa34a05948d4fa42f9102a1
diff --git a/dev-util/lttng-modules/lttng-modules-2.13.3.ebuild b/dev-util/lttng-modules/lttng-modules-2.13.3.ebuild
new file mode 100644
index 000000000000..de25ec1df638
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.13.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 3 0; then
+ eerror "${PN} require Linux kernel >= 3.0"
+ die "Please update your kernel!"
+ fi
+}
+
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README.md
+}