summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerb Miller Jr <herb@hlmjr.com>2018-03-03 15:40:31 -0500
committerMichał Górny <mgorny@gentoo.org>2018-03-03 22:47:37 +0100
commit051d4c7a76f6c431b9610b54cf8a73e593ef8ccc (patch)
tree345f7b32eedb88cad54dfee24910908ae10ba52e
parentpackage.mask: mask net-libs/librpcsecgss for removal (diff)
downloadgentoo-051d4c7a76f6c431b9610b54cf8a73e593ef8ccc.tar.gz
gentoo-051d4c7a76f6c431b9610b54cf8a73e593ef8ccc.tar.bz2
gentoo-051d4c7a76f6c431b9610b54cf8a73e593ef8ccc.zip
sys-apps/miller: Bump to version 5.3.0.
Closes: https://github.com/gentoo/gentoo/pull/7344 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sys-apps/miller/Manifest1
-rw-r--r--sys-apps/miller/miller-5.3.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/miller/Manifest b/sys-apps/miller/Manifest
index 9f489d900d01..45a1a89c3258 100644
--- a/sys-apps/miller/Manifest
+++ b/sys-apps/miller/Manifest
@@ -1,2 +1,3 @@
DIST miller-4.2.0.tar.gz 3373505 BLAKE2B 5051f310a70ad151aa8fd80dd4b885e78561dfb1fd14fa3a49ffb9928ce55acb59220b2b122b798256a0d258fbe4216470cdf8aec37be2fd26ac5ecb1f80e982 SHA512 f176dc2ce4e733ac1e4e331f17554d4ed089344a5f571bcc9d4b3b227f6c950fa0355f1a5b934e4f9467d9a22448e2842c586a4e6c424a98ec89170cd70b1714
DIST miller-5.2.2.tar.gz 5024653 BLAKE2B c13b6fb03404ae93f436997510aaaced2e11616b42fe132b9a267b1e71c2b7ada5bd310a20bd0bbd50ca6edaac915ebd68885ef4de1558aea63d9753b9f69125 SHA512 64ab35db6382cd9bf819249a57b88a142fccf7d6facdc6b9fdf3005b82bb2567f57b64d52a29b5f9d44c941974803339eb4a34c6648fdde2c82cc7c2f98e727c
+DIST miller-5.3.0.tar.gz 4940072 BLAKE2B 2e34ae010d409877040a60b08dd615f32e6945ca3bf97c078c89b9d2811067fa4bca2403f8ad239f8245e050acb10305d351b1db4177541a4fa9ed9a4bc1396c SHA512 4c557d97eb1cda2e52093fa097677602491895dea3093776a03af56114022b8c0917df9fbf26071d4d1a3c1360f520c82e33b32635c7b4207fa62869ab564712
diff --git a/sys-apps/miller/miller-5.3.0.ebuild b/sys-apps/miller/miller-5.3.0.ebuild
new file mode 100644
index 000000000000..97912f6bbd6d
--- /dev/null
+++ b/sys-apps/miller/miller-5.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A tool like sed, awk, cut, join, and sort for name-indexed data (CSV, JSON, ..)"
+HOMEPAGE="http://johnkerl.org/miller"
+SRC_URI="https://github.com/johnkerl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+DEPEND="sys-devel/flex"
+
+src_prepare() {
+ default
+
+ # respect flags
+ find -type f -name "Makefile.am" -exec sed -i -r -e '/.*FLAGS[^=]*=/ s:(-g|-pg|-O[0-9]) ::g' -- {} \; || die
+
+ # disable docs rebuilding as they're shipped prebuilt
+ sed -e '/SUBDIRS[^=]*=/ s:doc::g' -i -- Makefile.am || die
+
+ # disable building tests automagically
+ if ! use test; then
+ sed -e '/SUBDIRS[^=]*=/ s:[^ ]*_test::g' -i -- c/Makefile.am || die
+ fi
+
+ eautoreconf
+}
+
+src_test() {
+ emake -C c/reg_test
+ emake -C c/unit_test
+}
+
+src_install() {
+ local HTML_DOCS=( $(usev doc) )
+
+ default
+
+ doman 'doc/mlr.1'
+}