summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-09-09 00:38:19 +0100
committerIonen Wolkens <ionen@gentoo.org>2023-09-08 20:46:17 -0400
commit05c2df081afa33374ebdf5405f43819578a06c65 (patch)
tree0a09505cdc0998a2ec7d5836bc1f633a3d997405
parentgames-engines/openmw: don't download gtest (diff)
downloadgentoo-05c2df081afa33374ebdf5405f43819578a06c65.tar.gz
gentoo-05c2df081afa33374ebdf5405f43819578a06c65.tar.bz2
gentoo-05c2df081afa33374ebdf5405f43819578a06c65.zip
games-engines/openmw: drop 0.47.0-r2
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/32696 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-engines/openmw/Manifest1
-rw-r--r--games-engines/openmw/files/openmw-0.47.0-gcc12.patch33
-rw-r--r--games-engines/openmw/files/openmw-0.47.0-gcc13.patch22
-rw-r--r--games-engines/openmw/files/openmw-0.47.0-mygui-license.patch16
-rw-r--r--games-engines/openmw/files/openmw-0.47.0-sigstksz.patch42
-rw-r--r--games-engines/openmw/openmw-0.47.0-r2.ebuild145
6 files changed, 0 insertions, 259 deletions
diff --git a/games-engines/openmw/Manifest b/games-engines/openmw/Manifest
index 0bfdae772a9c..1146884524c0 100644
--- a/games-engines/openmw/Manifest
+++ b/games-engines/openmw/Manifest
@@ -1,3 +1,2 @@
-DIST openmw-0.47.0.tar.gz 5156857 BLAKE2B 40e8b9670423259fa0cc03ef000c17ebe06d1d58c2527b51b25cea3b54978b8a698984371eac14ff212f9550253ab17d41b83d37426371f12f5ce2d30b240d3d SHA512 517e650d0054cdba8d38de05ed3975b0fcf8de32fda59c8df7c34b973e5390efa0dd9ec79babdfdaa79dee7aa8a75009776f62fad91b9aa9aa28016c5032652b
DIST openmw-0.48.0.tar.gz 6020423 BLAKE2B 6a6f710f06efc0e844115018365db8148e9f6acefd453df74904144f53f5e896e9ab4d4f563ab95a3231500a2c1a5e1f8c5b6d6ac5c1315805c61657d13a7aa8 SHA512 969c10b285c039b54810c56f202f9c33bd03c83d87fec722c3389525e87fc7104760ea12527be5fb19a3f7ae2dc9aef0e4c6b7375d8bbcd6eb726e1d7859b833
DIST openmw-template-8966dab24692555eec720c854fb0f73d108070cd.omwgame 139730 BLAKE2B bf7f96912fd828078c62d112f3ff83e9a35298516135fb46b15ed01fc0260247cc0cba4aa3bbc55bf6a688f216384dbd9a5aa3328c4387b9b180b80f7463963e SHA512 6e38642bcf013c5f496a9cb0bf3ec7c9553b6e86b836e7844824c5a05f556c9391167214469b6318401684b702d7569896bf743c85aee4198612b3315ba778d6
diff --git a/games-engines/openmw/files/openmw-0.47.0-gcc12.patch b/games-engines/openmw/files/openmw-0.47.0-gcc12.patch
deleted file mode 100644
index 4c04d7b25c78..000000000000
--- a/games-engines/openmw/files/openmw-0.47.0-gcc12.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Backport missing includes causing issues with gcc12.
-https://bugs.gentoo.org/858725
-https://gitlab.com/OpenMW/openmw/-/commit/5f2e282359
-From: elsid <elsid.mail@gmail.com>
-Date: Tue, 17 May 2022 00:58:24 +0200
-Subject: [PATCH] Add includes for used types and functions
---- a/components/myguiplatform/myguidatamanager.cpp
-+++ b/components/myguiplatform/myguidatamanager.cpp
-@@ -1,8 +1,11 @@
- #include "myguidatamanager.hpp"
-
-+#include <memory>
-+#include <string>
-+
- #include <MyGUI_DataFileStream.h>
-
--#include <boost/filesystem.hpp>
-+#include <boost/filesystem/operations.hpp>
- #include <boost/filesystem/fstream.hpp>
-
- #include <components/debug/debuglog.hpp>
---- a/components/myguiplatform/myguidatamanager.hpp
-+++ b/components/myguiplatform/myguidatamanager.hpp
-@@ -3,6 +3,8 @@
-
- #include <MyGUI_DataManager.h>
-
-+#include <string>
-+
- namespace osgMyGUI
- {
-
-GitLab
diff --git a/games-engines/openmw/files/openmw-0.47.0-gcc13.patch b/games-engines/openmw/files/openmw-0.47.0-gcc13.patch
deleted file mode 100644
index bb99b7c77880..000000000000
--- a/games-engines/openmw/files/openmw-0.47.0-gcc13.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Fix missing includes causing issues with gcc13.
-https://bugs.gentoo.org/905337
---- a/apps/openmw/mwinput/controlswitch.hpp
-+++ b/apps/openmw/mwinput/controlswitch.hpp
-@@ -3,6 +3,7 @@
-
- #include <map>
- #include <string>
-+#include <cinttypes>
-
- namespace ESM
- {
---- a/components/misc/utf8stream.hpp
-+++ b/components/misc/utf8stream.hpp
-@@ -3,6 +3,7 @@
-
- #include <cstring>
- #include <tuple>
-+#include <cinttypes>
-
- class Utf8Stream
- {
diff --git a/games-engines/openmw/files/openmw-0.47.0-mygui-license.patch b/games-engines/openmw/files/openmw-0.47.0-mygui-license.patch
deleted file mode 100644
index 3bf5915bb65d..000000000000
--- a/games-engines/openmw/files/openmw-0.47.0-mygui-license.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-We don't install license files
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index d69352c94..5f97c86e9 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -856,9 +856,6 @@ elseif(NOT APPLE)
- INSTALL(PROGRAMS "${INSTALL_SOURCE}/openmw-wizard" DESTINATION "${BINDIR}" )
- ENDIF(BUILD_WIZARD)
-
-- # Install licenses
-- INSTALL(FILES "files/mygui/DejaVuFontLicense.txt" DESTINATION "${LICDIR}" )
--
- # Install icon and desktop file
- INSTALL(FILES "${OpenMW_BINARY_DIR}/org.openmw.launcher.desktop" DESTINATION "${DATAROOTDIR}/applications" COMPONENT "openmw")
- INSTALL(FILES "${OpenMW_SOURCE_DIR}/files/launcher/images/openmw.png" DESTINATION "${ICONDIR}" COMPONENT "openmw")
diff --git a/games-engines/openmw/files/openmw-0.47.0-sigstksz.patch b/games-engines/openmw/files/openmw-0.47.0-sigstksz.patch
deleted file mode 100644
index 588d6d639726..000000000000
--- a/games-engines/openmw/files/openmw-0.47.0-sigstksz.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 98a7d90ee258ceef9c70b0b2955d0458ec46f048 Mon Sep 17 00:00:00 2001
-From: elsid <elsid.mail@gmail.com>
-Date: Fri, 24 Sep 2021 19:40:29 +0200
-Subject: [PATCH] Assume SIGSTKSZ is not a constant
-
-SIGSTKSZ is not defined as constant since glibc 2.34:
-https://sourceware.org/git/?p=glibc.git;a=commit;h=6c57d320484988e87e446e2e60ce42816bf51d53
-
-Upstream-Status: Submitted
-[https://gitlab.com/OpenMW/openmw/-/merge_requests/1239]
----
- components/crashcatcher/crashcatcher.cpp | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
-diff --git a/components/crashcatcher/crashcatcher.cpp b/components/crashcatcher/crashcatcher.cpp
-index 86571e1e3a..c828e1ca81 100644
---- a/components/crashcatcher/crashcatcher.cpp
-+++ b/components/crashcatcher/crashcatcher.cpp
-@@ -56,8 +56,6 @@ static const char exec_err[] = "!!! Failed to exec debug process\n";
-
- static char argv0[PATH_MAX];
-
--static char altstack[SIGSTKSZ];
--
-
- static struct {
- int signum;
-@@ -475,9 +473,10 @@ int crashCatcherInstallHandlers(int argc, char **argv, int num_signals, int *sig
-
- /* Set an alternate signal stack so SIGSEGVs caused by stack overflows
- * still run */
-+ static char* altstack = new char [SIGSTKSZ];
- altss.ss_sp = altstack;
- altss.ss_flags = 0;
-- altss.ss_size = sizeof(altstack);
-+ altss.ss_size = SIGSTKSZ;
- sigaltstack(&altss, nullptr);
-
- memset(&sa, 0, sizeof(sa));
---
-GitLab
-
diff --git a/games-engines/openmw/openmw-0.47.0-r2.ebuild b/games-engines/openmw/openmw-0.47.0-r2.ebuild
deleted file mode 100644
index 98cbd99efd3a..000000000000
--- a/games-engines/openmw/openmw-0.47.0-r2.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake readme.gentoo-r1 xdg
-
-DESCRIPTION="Open source reimplementation of TES III: Morrowind"
-HOMEPAGE="https://openmw.org/ https://gitlab.com/OpenMW/openmw"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/OpenMW/openmw.git"
-else
- SRC_URI="https://github.com/OpenMW/openmw/archive/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
- S="${WORKDIR}/${PN}-${P}"
-fi
-
-LICENSE="GPL-3 MIT BitstreamVera ZLIB"
-SLOT="0"
-IUSE="doc devtools +osg-fork test +qt5"
-RESTRICT="!test? ( test )"
-
-# FIXME: Unbundle dev-games/openscenegraph-qt in extern/osgQt directory,
-# used when BUILD_OPENCS flag is enabled. See bug #676266.
-
-RDEPEND="
- app-arch/lz4:=
- dev-games/mygui
- dev-games/recastnavigation:=
- dev-libs/boost:=[zlib]
- dev-libs/tinyxml[stl]
- media-libs/libsdl2[joystick,opengl,video]
- media-libs/openal
- <media-video/ffmpeg-5:=
- >=sci-physics/bullet-2.86:=[double-precision]
- virtual/opengl
- osg-fork? ( >=dev-games/openscenegraph-openmw-3.6:=[collada(-),jpeg,png,sdl,svg,truetype,zlib] )
- !osg-fork? ( >=dev-games/openscenegraph-3.5.5:=[collada(-),jpeg,png,sdl,svg,truetype,zlib] )
- qt5? (
- app-arch/unshield
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtwidgets:5
- )
-"
-
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- app-doc/doxygen[dot]
- dev-python/sphinx
- )
- test? (
- dev-cpp/gtest
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/openmw-0.47.0-mygui-license.patch
- "${FILESDIR}"/openmw-0.47.0-sigstksz.patch
- "${FILESDIR}"/openmw-0.47.0-gcc12.patch
- "${FILESDIR}"/openmw-0.47.0-gcc13.patch
-)
-
-src_prepare() {
- cmake_src_prepare
-
- # Use the system tinyxml headers
- rm -v extern/oics/tiny{str,xml}* || die
-}
-
-src_configure() {
- use devtools && ! use qt5 &&
- elog "'qt5' USE flag is disabled, 'openmw-cs' will not be installed"
-
- local mycmakeargs=(
- -DBUILD_BSATOOL=$(usex devtools)
- -DBUILD_DOCS=$(usex doc)
- -DBUILD_ESMTOOL=$(usex devtools)
- -DBUILD_LAUNCHER=$(usex qt5)
- -DBUILD_NIFTEST=$(usex devtools)
- -DBUILD_OPENCS=$(usex devtools $(usex qt5))
- -DBUILD_WIZARD=$(usex qt5)
- -DBUILD_UNITTESTS=$(usex test)
- -DGLOBAL_DATA_PATH="${EPREFIX}/usr/share"
- -DICONDIR="${EPREFIX}/usr/share/icons/hicolor/256x256/apps"
- -DMORROWIND_DATA_FILES="${EPREFIX}/usr/share/morrowind-data"
- -DUSE_SYSTEM_TINYXML=ON
- -DOPENMW_USE_SYSTEM_RECASTNAVIGATION=ON
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
-
- if use doc ; then
- cmake_src_compile doc
- find "${BUILD_DIR}"/docs/Doxygen/html \
- -name '*.md5' -type f -delete || die
- HTML_DOCS=( "${BUILD_DIR}"/docs/Doxygen/html/. )
- fi
-}
-
-src_test() {
- "${BUILD_DIR}/openmw_test_suite" || die
-}
-
-src_install() {
- cmake_src_install
-
- local DOC_CONTENTS="
- You need the original Morrowind data files. If you haven't
- installed them yet, you can install them straight via the
- installation wizard which is the officially supported method
- (either by using the launcher or by calling 'openmw-wizard'
- directly).\n"
-
- if ! use qt5; then
- DOC_CONTENTS+="\n\n
- USE flag 'qt5' is disabled, 'openmw-launcher' and
- 'openmw-wizard' are not available. You are on your own for
- making the Morrowind data files available and pointing
- openmw at them.\n\n
- Additionally; you must import the Morrowind.ini file before
- running openmw with the Morrowind data files for the first
- time. Typically this can be done like so:\n\n
- \t mkdir -p ~/.config/openmw\n
- \t openmw-iniimporter /path/to/Morrowind.ini ~/.config/openmw/openmw.cfg"
- fi
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- readme.gentoo_print_elog
-}