summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-06-28 02:34:24 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:08:37 +0200
commit07d085fc169d0f605e7f16ebbe9c4f3521ac2691 (patch)
tree616d156fc7ccc09a2880e7ffcb832c4c9ffd4a81
parentsys-apps/pv: Version bump. (diff)
downloadgentoo-07d085fc169d0f605e7f16ebbe9c4f3521ac2691.tar.gz
gentoo-07d085fc169d0f605e7f16ebbe9c4f3521ac2691.tar.bz2
gentoo-07d085fc169d0f605e7f16ebbe9c4f3521ac2691.zip
net-analyzer/sinfo: Fix building with GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=594990 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5001
-rw-r--r--net-analyzer/sinfo/files/sinfo-0.0.48-gcc6.patch24
-rw-r--r--net-analyzer/sinfo/sinfo-0.0.48.ebuild3
2 files changed, 26 insertions, 1 deletions
diff --git a/net-analyzer/sinfo/files/sinfo-0.0.48-gcc6.patch b/net-analyzer/sinfo/files/sinfo-0.0.48-gcc6.patch
new file mode 100644
index 000000000000..0b8f4a347fe0
--- /dev/null
+++ b/net-analyzer/sinfo/files/sinfo-0.0.48-gcc6.patch
@@ -0,0 +1,24 @@
+Bug: https://bugs.gentoo.org/594990
+
+--- a/libmessageio/tcpmessageserverconnection.cc
++++ b/libmessageio/tcpmessageserverconnection.cc
+@@ -91,7 +91,7 @@
+ }
+
+
+-void TCPMessageServerConnection::queueAndSendMessageSlot(Message & message)
++void TCPMessageServerConnection::queueAndSendMessageSlot(const Message & message)
+ {
+
+ if (sendQueue.size()<maxSendQueueSize)
+--- a/libmessageio/tcpmessageserverconnection.h
++++ b/libmessageio/tcpmessageserverconnection.h
+@@ -32,7 +32,7 @@
+ void handleReadMessageSize(const boost::system::error_code& err, size_t length);
+ void handleReadMessage(const boost::system::error_code& err, size_t length);
+
+- void queueAndSendMessageSlot(Message & message);
++ void queueAndSendMessageSlot(const Message & message);
+ std::list<Message> sendQueue;
+ bool sendQueueCurrentlySending;
+ void startNewTransmission();
diff --git a/net-analyzer/sinfo/sinfo-0.0.48.ebuild b/net-analyzer/sinfo/sinfo-0.0.48.ebuild
index bbee5392b743..ef6d765d62a3 100644
--- a/net-analyzer/sinfo/sinfo-0.0.48.ebuild
+++ b/net-analyzer/sinfo/sinfo-0.0.48.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,6 +26,7 @@ DEPEND="
src_prepare() {
cp "${FILESDIR}"/${P}-acinclude.m4 acinclude.m4 || die
epatch "${FILESDIR}"/${PN}-0.0.47-tinfo.patch
+ epatch "${FILESDIR}"/${P}-gcc6.patch
eautoreconf
}