summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-25 18:12:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-25 18:12:58 +0200
commit0a043fe8d3da7913d3c64e0848eb0fd79902ec3f (patch)
treefe85f5afc49895651ce82681c6673ef669336148
parentdev-python/cryptography: Remove old (diff)
downloadgentoo-0a043fe8d3da7913d3c64e0848eb0fd79902ec3f.tar.gz
gentoo-0a043fe8d3da7913d3c64e0848eb0fd79902ec3f.tar.bz2
gentoo-0a043fe8d3da7913d3c64e0848eb0fd79902ec3f.zip
dev-python/geventhttpclient: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/geventhttpclient/Manifest2
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.5.3.ebuild49
-rw-r--r--dev-python/geventhttpclient/geventhttpclient-1.5.4.ebuild52
3 files changed, 0 insertions, 103 deletions
diff --git a/dev-python/geventhttpclient/Manifest b/dev-python/geventhttpclient/Manifest
index 7635b374a973..0697e6a0ca7c 100644
--- a/dev-python/geventhttpclient/Manifest
+++ b/dev-python/geventhttpclient/Manifest
@@ -1,3 +1 @@
-DIST geventhttpclient-1.5.3.tar.gz 58447 BLAKE2B a1cf529c6d40ee81ebe17cb066f2d837cf3d5ce2511bb735c1a63503b612c98c17c91f08de99d604c9ff6ebfa7e6502c338e7fbbc86de954ae7e559966aa8006 SHA512 9a0ed907f73f7f5ff8675502ef6fc82bff7b543d0a2d22e1eca5aba3592675a87fe09c48981f496b7f63a660e7eab5f68801ae74da8c33ac9d9bf55a0425eed1
-DIST geventhttpclient-1.5.4.tar.gz 59551 BLAKE2B d1bda5315a92afeb408f33043c8ccf5911d6519dbe50266688f0b123fd92a95f1cb9cea449676117ea051af1400c656fe47d241b6e4e03803dc017806b5e0be4 SHA512 10d9ace4a555a5c39d8b737d96484041f9e704df41b8a3cca3b05b3c9ccb30d0490d154fa47a45edcad762a2e0807ca89425ed484275ee1b3098f0094fd6d166
DIST geventhttpclient-1.5.5.tar.gz 59566 BLAKE2B f43ffe9880eefe77f19adc00bcef612df057f96e256f50ca4081658d7e0d01deca2473da3d2055dbc1cb98fc4f7f0a7442809fdcab635c43042792e2601efdb9 SHA512 89efe008099935ac8715ddf09c13e70c1a3552da50c495522b2a62e1ff51a407808e6b797f8fd3b0863a3a59e5b03e604bda8b1027c0326da75cb1fddb5d0fa3
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.5.3.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.5.3.ebuild
deleted file mode 100644
index 60cf23a6fc98..000000000000
--- a/dev-python/geventhttpclient/geventhttpclient-1.5.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
-HOMEPAGE="https://github.com/gwik/geventhttpclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- app-arch/brotli[python,${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/gevent[events(+),${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Avoid ModuleNotFoundError for tests we skip later
- sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # These SNI tests require dpkt which is not in the tree
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
- )
- # Append to sys.path to avoid ImportError
- # https://bugs.gentoo.org/667758
- # Skip tests which require internet access
- epytest --import-mode=append -m "not online"
-}
diff --git a/dev-python/geventhttpclient/geventhttpclient-1.5.4.ebuild b/dev-python/geventhttpclient/geventhttpclient-1.5.4.ebuild
deleted file mode 100644
index d4807ee44f57..000000000000
--- a/dev-python/geventhttpclient/geventhttpclient-1.5.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="A high performance, concurrent HTTP client library for Python using gevent"
-HOMEPAGE="
- https://github.com/geventhttpclient/geventhttpclient/
- https://pypi.org/project/geventhttpclient/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- app-arch/brotli[python,${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/gevent[events(+),${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Avoid ModuleNotFoundError for tests we skip later
- sed -i '/^import dpkt.ssl/d' src/geventhttpclient/tests/test_ssl.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # These SNI tests require dpkt which is not in the tree
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_host_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_implicit_sni_from_header_in_ssl
- src/geventhttpclient/tests/test_ssl.py::test_explicit_sni_in_ssl
- )
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- # Skip tests which require internet access
- epytest -m "not online"
-}