summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-05-06 11:32:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-05-06 11:32:57 -0500
commit0a3a711dce02952f2c9386834e180979e7e78c85 (patch)
tree52be0c921c537983bc1e769dd689916eda44bdb1
parentdev-python/numpy: Stabilize 1.24.2 arm, #902071 (diff)
downloadgentoo-0a3a711dce02952f2c9386834e180979e7e78c85.tar.gz
gentoo-0a3a711dce02952f2c9386834e180979e7e78c85.tar.bz2
gentoo-0a3a711dce02952f2c9386834e180979e7e78c85.zip
net-misc/openvswitch: switch all runtime dirs to /run
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--net-misc/openvswitch/files/openvswitch.tmpfiles2
-rw-r--r--net-misc/openvswitch/files/ovs-vswitchd-r14
-rw-r--r--net-misc/openvswitch/files/ovs-vswitchd-r3.service4
-rw-r--r--net-misc/openvswitch/files/ovs-vswitchd.confd-r22
-rw-r--r--net-misc/openvswitch/files/ovsdb-server-r14
-rw-r--r--net-misc/openvswitch/files/ovsdb-server-r3.service2
-rw-r--r--net-misc/openvswitch/files/ovsdb-server_conf22
-rw-r--r--net-misc/openvswitch/openvswitch-2.17.6.ebuild2
8 files changed, 11 insertions, 11 deletions
diff --git a/net-misc/openvswitch/files/openvswitch.tmpfiles b/net-misc/openvswitch/files/openvswitch.tmpfiles
index 58c583ee4747..f99f19f89fb2 100644
--- a/net-misc/openvswitch/files/openvswitch.tmpfiles
+++ b/net-misc/openvswitch/files/openvswitch.tmpfiles
@@ -1 +1 @@
-d /var/run/openvswitch 0770 root root -
+d /run/openvswitch 0770 root root -
diff --git a/net-misc/openvswitch/files/ovs-vswitchd-r1 b/net-misc/openvswitch/files/ovs-vswitchd-r1
index bc5602a60030..f7da8e846789 100644
--- a/net-misc/openvswitch/files/ovs-vswitchd-r1
+++ b/net-misc/openvswitch/files/ovs-vswitchd-r1
@@ -10,12 +10,12 @@ command_args="
--detach
--monitor
${OPTIONS} ${DATABASE}"
-pidfile="/var/run/openvswitch/ovs-vswitchd.pid"
+pidfile="/run/openvswitch/ovs-vswitchd.pid"
depend() {
use ovsdb-server logger
}
start_pre() {
- checkpath -d "/var/run/openvswitch" -m 0750
+ checkpath -d "/run/openvswitch" -m 0750
}
diff --git a/net-misc/openvswitch/files/ovs-vswitchd-r3.service b/net-misc/openvswitch/files/ovs-vswitchd-r3.service
index 165ea3bfbf81..8f157cfdd870 100644
--- a/net-misc/openvswitch/files/ovs-vswitchd-r3.service
+++ b/net-misc/openvswitch/files/ovs-vswitchd-r3.service
@@ -6,12 +6,12 @@ Before=network.target network.service
Requires=ovsdb-server.service
After=ovsdb-server.service network-pre.target systemd-udev-settle.service
ReloadPropagatedFrom=ovsdb-server.service
-AssertPathIsReadWrite=/var/run/openvswitch/db.sock
+AssertPathIsReadWrite=/run/openvswitch/db.sock
[Service]
Type=forking
Restart=on-failure
-Environment=HOME=/var/run/openvswitch
+Environment=HOME=/run/openvswitch
EnvironmentFile=-/etc/conf.d/ovs-vswitchd
ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \
--no-ovsdb-server --no-monitor --system-id=random \
diff --git a/net-misc/openvswitch/files/ovs-vswitchd.confd-r2 b/net-misc/openvswitch/files/ovs-vswitchd.confd-r2
index eb4b6c2f2831..6f383500fe7a 100644
--- a/net-misc/openvswitch/files/ovs-vswitchd.confd-r2
+++ b/net-misc/openvswitch/files/ovs-vswitchd.confd-r2
@@ -1,5 +1,5 @@
# Connection string for the configuration database (usually a unix socket)
-DATABASE="unix:/var/run/openvswitch/db.sock"
+DATABASE="unix:/run/openvswitch/db.sock"
# Additional options
OPTIONS="--mlockall"
diff --git a/net-misc/openvswitch/files/ovsdb-server-r1 b/net-misc/openvswitch/files/ovsdb-server-r1
index f7360adbb4c8..5fc2716d91d5 100644
--- a/net-misc/openvswitch/files/ovsdb-server-r1
+++ b/net-misc/openvswitch/files/ovsdb-server-r1
@@ -22,7 +22,7 @@ command_args="
${bootstrap_ca_cert}
${DATABASE}
${OPTIONS}"
-pidfile="/var/run/openvswitch/ovsdb-server.pid"
+pidfile="/run/openvswitch/ovsdb-server.pid"
depend() {
need localmount
@@ -30,5 +30,5 @@ depend() {
}
start_pre() {
- checkpath -d "/var/run/openvswitch" -m 0750
+ checkpath -d "/run/openvswitch" -m 0750
}
diff --git a/net-misc/openvswitch/files/ovsdb-server-r3.service b/net-misc/openvswitch/files/ovsdb-server-r3.service
index a1d308478daa..8b779964ee06 100644
--- a/net-misc/openvswitch/files/ovsdb-server-r3.service
+++ b/net-misc/openvswitch/files/ovsdb-server-r3.service
@@ -9,7 +9,7 @@ Wants=ovs-delete-transient-ports.service
Type=forking
Restart=on-failure
EnvironmentFile=-/etc/conf.d/ovsdb-server
-ExecStartPre=/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch
+ExecStartPre=/bin/chown ${OVS_USER_ID} /run/openvswitch /var/log/openvswitch
ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \
--no-ovs-vswitchd --no-monitor --system-id=random \
--ovs-user=${OVS_USER_ID} \
diff --git a/net-misc/openvswitch/files/ovsdb-server_conf2 b/net-misc/openvswitch/files/ovsdb-server_conf2
index 07eca5e6c9f7..0ffb63c21ccd 100644
--- a/net-misc/openvswitch/files/ovsdb-server_conf2
+++ b/net-misc/openvswitch/files/ovsdb-server_conf2
@@ -1,5 +1,5 @@
# Socket for bringing the server up
-DB_SOCKET="/var/run/openvswitch/db.sock"
+DB_SOCKET="/run/openvswitch/db.sock"
# Remote sockets are defined in the database by default
REMOTE_DB="db:Open_vSwitch,Open_vSwitch,manager_options"
diff --git a/net-misc/openvswitch/openvswitch-2.17.6.ebuild b/net-misc/openvswitch/openvswitch-2.17.6.ebuild
index c17e37e3f3bb..f6fd673f3545 100644
--- a/net-misc/openvswitch/openvswitch-2.17.6.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.17.6.ebuild
@@ -87,7 +87,7 @@ src_configure() {
# Need PYTHON3 variable for bug #860240
PYTHON3="${PYTHON}" CONFIG_SHELL="${BROOT}"/bin/bash SHELL="${BROOT}"/bin/bash econf ${linux_config} \
- --with-rundir=/var/run/openvswitch \
+ --with-rundir=/run/openvswitch \
--with-logdir=/var/log/openvswitch \
--with-pkidir=/etc/ssl/openvswitch \
--with-dbdir=/var/lib/openvswitch \