summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-12 06:32:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-12 07:59:34 -0400
commit0be708479981a08b1ff4987955c778a1c318f7e3 (patch)
tree51174139a416edc2beacdfa4f9598fa13f33ed9b
parentdev-qt/qtshadertools: add 6.7.0_rc (diff)
downloadgentoo-0be708479981a08b1ff4987955c778a1c318f7e3.tar.gz
gentoo-0be708479981a08b1ff4987955c778a1c318f7e3.tar.bz2
gentoo-0be708479981a08b1ff4987955c778a1c318f7e3.zip
dev-qt/qtspeech: add 6.7.0_rc
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtspeech/Manifest1
-rw-r--r--dev-qt/qtspeech/qtspeech-6.7.0_rc.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtspeech/Manifest b/dev-qt/qtspeech/Manifest
index 0f64fbd25d8e..22ac8c938cad 100644
--- a/dev-qt/qtspeech/Manifest
+++ b/dev-qt/qtspeech/Manifest
@@ -1,3 +1,4 @@
DIST qtspeech-5.15.12-gentoo-kde-1.tar.xz 1044 BLAKE2B 680ec75681359279fab886816c078b3178e6b29af257d5163b9f5794e5ee90ad186d13029ff9a806e55f5c28d66b8e8870b15d531af8067fbed4ac86646bb00b SHA512 7773439748b85d2dd0c4d21d9e1a5e574eae848087d25b89c2cb07240021d73ea6fe62627ab061a049f7062a4b97a4316871873decc2abe0ea2cdad29ed88b1d
DIST qtspeech-everywhere-opensource-src-5.15.12.tar.xz 104816 BLAKE2B 8a64688c8ee24788498ad8eb3827cf55d4ba124230ef5f451cbf7720808d6586e48e5f0344b8546fceaf7fe048243b940f8c0bd6b44fcd5d303a1749c380ca7c SHA512 960eb661cfeb8a4fc01337ac998bc8ce101da73782155e75a7b128987d9809fa1e4cc6fee30cfa3cbd39f7fff9bbe7e49e55430681ac6582e7c8110242d7183a
DIST qtspeech-everywhere-src-6.6.2.tar.xz 262008 BLAKE2B 6d9ae5b42f96fa02a15ac82e9e1c6a378c3b0ceccd278af9ef99346ad79a256e41d1d2ae10cfef75f311bdfad457271357b09fd067ddc902bff3e4ee31eda12e SHA512 e43793931b81bb86cc074a2153ec0160991c86bc255ea1b11e5b4a272b8d067fcfc6788261d4b2f6f7630eadbcab7be23249b980d2792cb9a109137af614601e
+DIST qtspeech-everywhere-src-6.7.0-rc.tar.xz 261612 BLAKE2B 4e60ca59cf511b4bb7455dce3af5f76bd1973428eae2b9c8753b1ab8bdc33b50fb0c71bb6a75b0894b54e70f632ccd737f7027e1a90aa5eff82af172207a27f1 SHA512 3be97469fbc1f5880afe5aa7f42a974c3cb1832830542685480a2ae698dd8f81c1705dd89f3b50cfbc7a0db38d2c6b1a6ef0625dd7a2f965f59f7643af654b3f
diff --git a/dev-qt/qtspeech/qtspeech-6.7.0_rc.ebuild b/dev-qt/qtspeech/qtspeech-6.7.0_rc.ebuild
new file mode 100644
index 000000000000..867d3ddc19b8
--- /dev/null
+++ b/dev-qt/qtspeech/qtspeech-6.7.0_rc.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Text-to-speech library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm64 ~loong"
+fi
+
+IUSE="flite qml +speechd"
+# can build with neither, but then it is just mock tts and may be confusing
+REQUIRED_USE="|| ( flite speechd )"
+
+# TODO: tests are known failing with clang and needs looking into, albeit
+# it is still usable at runtime save for applications segfaulting on exit
+# similarly to QTBUG-90626 (not that this has in-tree revdeps as of writing
+# of this). Restricting because also seen this result in hanging. Note that
+# qtspeech:6 is still somewhat new (started in 6.4.0), and should review
+# status on new major versions.
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6
+ ~dev-qt/qtmultimedia-${PV}:6
+ flite? ( app-accessibility/flite )
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ speechd? ( app-accessibility/speech-dispatcher )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ $(qt_feature flite)
+ $(qt_feature speechd)
+
+ # flite_alsa was likely to work around old issues in flite, it does
+ # nothing but add -lasound (no code change, and is unneeded)
+ -DQT_FEATURE_flite_alsa=OFF
+ )
+
+ qt6-build_src_configure
+}