summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-03 05:42:33 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-03 06:01:12 +0200
commit0c761a80160b2103f39e625fd6069b061f1ce3b9 (patch)
treeb32986cea1258e4cb00ee7b37500e6d9c96d07bb
parentdev-libs/redland-bindings: removed obsolete 1.0.17.1-r100 (diff)
downloadgentoo-0c761a80160b2103f39e625fd6069b061f1ce3b9.tar.gz
gentoo-0c761a80160b2103f39e625fd6069b061f1ce3b9.tar.bz2
gentoo-0c761a80160b2103f39e625fd6069b061f1ce3b9.zip
dev-python/logutils: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/logutils/logutils-0.3.5-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/logutils/logutils-0.3.5-r1.ebuild b/dev-python/logutils/logutils-0.3.5-r1.ebuild
index 78283ceaa872..a16f629634b3 100644
--- a/dev-python/logutils/logutils-0.3.5-r1.ebuild
+++ b/dev-python/logutils/logutils-0.3.5-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -16,4 +16,8 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s tests
+}