summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 18:42:42 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 18:53:45 +0200
commit0ce07a8c456354c7a9e1e8e6d8d626afa331fd46 (patch)
treed21c433ecfd8176b840597292d296fd21dcb07f5
parentdev-python/pysyck: Use append-cflags (diff)
downloadgentoo-0ce07a8c456354c7a9e1e8e6d8d626afa331fd46.tar.gz
gentoo-0ce07a8c456354c7a9e1e8e6d8d626afa331fd46.tar.bz2
gentoo-0ce07a8c456354c7a9e1e8e6d8d626afa331fd46.zip
dev-python/python-daap: Use append-cflags
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/python-daap/python-daap-0.7.1-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/python-daap/python-daap-0.7.1-r1.ebuild b/dev-python/python-daap/python-daap-0.7.1-r1.ebuild
index 3fc3cbb84be2..660608e3483e 100644
--- a/dev-python/python-daap/python-daap-0.7.1-r1.ebuild
+++ b/dev-python/python-daap/python-daap-0.7.1-r1.ebuild
@@ -3,9 +3,10 @@
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
MY_P="PythonDaap-${PV}"
@@ -18,12 +19,12 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-DEPEND=""
-RDEPEND=""
-
S="${WORKDIR}/${MY_P}"
-CFLAGS="${CFLAGS} -fno-strict-aliasing"
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ append-cflags -fno-strict-aliasing
+}
python_install_all() {
use examples && local EXAMPLES=( examples/. )