summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-16 19:40:53 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-16 18:53:46 -0400
commit0f8c85c8cc39932b978a44dfc1f6e3e889dd773e (patch)
tree222251a87d52ff1c39633d2e6e539eb84588a49c
parentx11-wm/mutter: Version bump to 45.0 (diff)
downloadgentoo-0f8c85c8cc39932b978a44dfc1f6e3e889dd773e.tar.gz
gentoo-0f8c85c8cc39932b978a44dfc1f6e3e889dd773e.tar.bz2
gentoo-0f8c85c8cc39932b978a44dfc1f6e3e889dd773e.zip
net-irc/polari: Version bump to 45.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32858 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-irc/polari/Manifest1
-rw-r--r--net-irc/polari/polari-45.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-irc/polari/Manifest b/net-irc/polari/Manifest
index cc54967398b0..b6a9f40b8c1b 100644
--- a/net-irc/polari/Manifest
+++ b/net-irc/polari/Manifest
@@ -1 +1,2 @@
DIST polari-43.0.tar.xz 1128316 BLAKE2B 224c70d77ad772aacc5264b2ff15b9371cbfb47bcdaef3b3fd6b55b86e48947b960773e9568f3a6830b1958b2d901ec9d3e3da3cd3fb1c6341a5fa7d34ab5014 SHA512 ff1d96f7e464043616760f378136c3dfb1b5fc3fce3d24fe067540ce0a306d76027681f085ad0030959a6b1653d9f0291e108457305c16849936ab25861fe285
+DIST polari-45.0.tar.xz 1060220 BLAKE2B cca8d79a33b3874d9f13b9110687e0fac3cbc1a9b7a2652f2e315d0ee0b996263946e209da3141763f18293e77127d843beac96155168cb5a24af88ff1de3f85 SHA512 33a3a0ef6960d2ac11fc312efc859a5ea75198c4ae8e74ff0885f9d0aa04f4e59d84be1495db3f498486b595aac66a91ec63d121a92557d9386dfbaed60bb409
diff --git a/net-irc/polari/polari-45.0.ebuild b/net-irc/polari/polari-45.0.ebuild
new file mode 100644
index 000000000000..4c0fce257d1b
--- /dev/null
+++ b/net-irc/polari/polari-45.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="An IRC client for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Polari https://gitlab.gnome.org/GNOME/polari"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.43.4:2
+ net-libs/telepathy-glib[introspection]
+ >=dev-libs/gobject-introspection-1.50:=
+ >=dev-libs/gjs-1.73.1
+
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=app-text/gspell-1.4.0[introspection]
+ x11-libs/pango[introspection]
+ app-crypt/libsecret[introspection]
+ net-libs/libsoup:3.0[introspection]
+ net-im/telepathy-logger[introspection]
+"
+RDEPEND="${DEPEND}
+ >=net-irc/telepathy-idle-0.2
+"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ dev-libs/json-glib
+ )
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}