summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-29 02:06:50 +0100
committerSam James <sam@gentoo.org>2023-03-29 13:55:46 +0100
commit110a89906641440706697fbedc4faaa7441a0a18 (patch)
tree91f9c496fc7738d00f31f467b1e7f5ad06b21e5d
parentdev-ruby/x25519: drop 1.0.9 (diff)
downloadgentoo-110a89906641440706697fbedc4faaa7441a0a18.tar.gz
gentoo-110a89906641440706697fbedc4faaa7441a0a18.tar.bz2
gentoo-110a89906641440706697fbedc4faaa7441a0a18.zip
dev-ruby/webmock: drop 3.14.0, 3.14.0-r1, 3.15.0, 3.17.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/webmock/Manifest3
-rw-r--r--dev-ruby/webmock/webmock-3.14.0-r1.ebuild67
-rw-r--r--dev-ruby/webmock/webmock-3.14.0.ebuild63
-rw-r--r--dev-ruby/webmock/webmock-3.15.0.ebuild63
-rw-r--r--dev-ruby/webmock/webmock-3.17.1.ebuild63
5 files changed, 0 insertions, 259 deletions
diff --git a/dev-ruby/webmock/Manifest b/dev-ruby/webmock/Manifest
index 06b4a78d5e8c..b53da88ebad4 100644
--- a/dev-ruby/webmock/Manifest
+++ b/dev-ruby/webmock/Manifest
@@ -1,4 +1 @@
-DIST webmock-3.14.0.gem 126976 BLAKE2B 20dd463c8b784869d4379aeabf892a6b4602091a4cc01a4002161d88f24781bb2bae1e50bd0ce8077c40aab73a2243835d99551bd04d808ffdf019df071c2b01 SHA512 0c9ea5b29446de7619c45d0fb72ab305bf68150c9d657ddc223d0d258a400dc730e3fe401b46c994a5c8eb450db5ee8f7021fe8d2d6c85bc4723c657799c5ccc
-DIST webmock-3.15.0.gem 128000 BLAKE2B 10587fd127fe61076d34a36f71e6e61f43d6019a01d1906e1fa501697791deeb89a8a2cdc5fa92dee1b001cdd22055db913ae20414342faf0ae11cc301bf0e6e SHA512 9f2e6404b617cc1aa67dcaef941046f82e4602eaeef77084714a451be513fdbd6e6c54c090842c5519009d2ca0533b30ad17d225d3738cde526d037d3fe3335b
-DIST webmock-3.17.1.gem 128512 BLAKE2B 176eefbf9523ac7c22e66d6aebc669d91c5545bd5889cd69f5543eac22d06a92e53ec9544f21bc883776ef712d410b0602db81a1e21929d0e02ce826f758aae9 SHA512 3814e8d6d65cea330618fde7ade54e83eee71466354fd295b2acfd8a1a637daad193073d21ec832edf6864fc3019c24501882aab4fba48dddeb9ff2d57cdc9f2
DIST webmock-3.18.1.gem 128000 BLAKE2B 792622ef256e5b106e480f40fbec06bfb970b41d5745dc50be125143b925f5ba1fb7c28173d39268550076d6bd5803a0150740ecdcc31537415af3fb1da9e7d6 SHA512 109f1ced28c4c273f75378e193b772314854fdb5ceea2ef1926d8b790169d07cdb30fdbe1c12e3461a9307f3fea073aa90cfe7421379bf36fa0d550d4bb93c5a
diff --git a/dev-ruby/webmock/webmock-3.14.0-r1.ebuild b/dev-ruby/webmock/webmock-3.14.0-r1.ebuild
deleted file mode 100644
index 88ea1f1c3ef3..000000000000
--- a/dev-ruby/webmock/webmock-3.14.0-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.8.0
- >=dev-ruby/crack-0.3.2
- >=dev-ruby/hashdiff-0.4.0:0
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- >=dev-ruby/test-unit-3.0.0
- dev-ruby/rack
-)"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
- # There is now optional support for curb and typhoeus which we don't
- # have in Gentoo yet. em_http_request is available in Gentoo but its
- # version is too old. patron's latest version is not compatible.
- # httpclient is no longer maintained and has various test failures.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\|httpclient\)/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client,httpclient}/* || die
-
- # Drop tests for dev-ruby/http for now since this package only works with ruby26
- sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/http_rb/* || die
-
- # Avoid specs that require network access
- sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-
- # Fix specs with kwargs confusion on ruby30
- sed -i -e "21 s/'A' => 'a'/{'A' => 'a'}/" spec/unit/request_signature_spec.rb || die
- sed -i -e "34 s/'A' => 'a'/{'A' => 'a'}/" spec/unit/response_spec.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rake test NO_CONNECTION=true || die
- ${RUBY} -S rspec-3 spec || die
-
- einfo "Delay to allow the test server to stop"
- sleep 10
-}
diff --git a/dev-ruby/webmock/webmock-3.14.0.ebuild b/dev-ruby/webmock/webmock-3.14.0.ebuild
deleted file mode 100644
index 5414fe1d25de..000000000000
--- a/dev-ruby/webmock/webmock-3.14.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.8.0
- >=dev-ruby/crack-0.3.2
- >=dev-ruby/hashdiff-0.4.0:0
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- >=dev-ruby/test-unit-3.0.0
- dev-ruby/rack
-)"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
- # There is now optional support for curb and typhoeus which we don't
- # have in Gentoo yet. em_http_request is available in Gentoo but its
- # version is too old. patron's latest version is not compatible.
- # httpclient is no longer maintained and has various test failures.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\|httpclient\)/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client,httpclient}/* || die
-
- # Drop tests for dev-ruby/http for now since this package only works with ruby26
- sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/http_rb/* || die
-
- # Avoid specs that require network access
- sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
- ${RUBY} -S rake test NO_CONNECTION=true || die
- ${RUBY} -S rspec-3 spec || die
-
- einfo "Delay to allow the test server to stop"
- sleep 10
-}
diff --git a/dev-ruby/webmock/webmock-3.15.0.ebuild b/dev-ruby/webmock/webmock-3.15.0.ebuild
deleted file mode 100644
index ff18bc5ed6e0..000000000000
--- a/dev-ruby/webmock/webmock-3.15.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.8.0
- >=dev-ruby/crack-0.3.2
- >=dev-ruby/hashdiff-0.4.0:0
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- >=dev-ruby/test-unit-3.0.0
- dev-ruby/rack
-)"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
- # There is now optional support for curb and typhoeus which we don't
- # have in Gentoo yet. em_http_request is available in Gentoo but its
- # version is too old. patron's latest version is not compatible.
- # httpclient is no longer maintained and has various test failures.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\|httpclient\)/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client,httpclient}/* || die
-
- # Drop tests for dev-ruby/http for now since this package only works with ruby26
- sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/http_rb/* || die
-
- # Avoid specs that require network access
- sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
- ${RUBY} -S rake test NO_CONNECTION=true || die
- ${RUBY} -S rspec-3 spec || die
-
- einfo "Delay to allow the test server to stop"
- sleep 10
-}
diff --git a/dev-ruby/webmock/webmock-3.17.1.ebuild b/dev-ruby/webmock/webmock-3.17.1.ebuild
deleted file mode 100644
index ff18bc5ed6e0..000000000000
--- a/dev-ruby/webmock/webmock-3.17.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
-HOMEPAGE="https://github.com/bblimke/webmock"
-
-LICENSE="GPL-2"
-SLOT="3"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/addressable-2.8.0
- >=dev-ruby/crack-0.3.2
- >=dev-ruby/hashdiff-0.4.0:0
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- >=dev-ruby/test-unit-3.0.0
- dev-ruby/rack
-)"
-
-all_ruby_prepare() {
- # Remove bundler support
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
- sed -i -e '1igem "test-unit"' test/test_helper.rb || die
-
- # There is now optional support for curb and typhoeus which we don't
- # have in Gentoo yet. em_http_request is available in Gentoo but its
- # version is too old. patron's latest version is not compatible.
- # httpclient is no longer maintained and has various test failures.
- sed -i -e '/\(curb\|typhoeus\|em-http\|patron\|httpclient\)/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client,httpclient}/* || die
-
- # Drop tests for dev-ruby/http for now since this package only works with ruby26
- sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
- rm -f spec/acceptance/http_rb/* || die
-
- # Avoid specs that require network access
- sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
-}
-
-each_ruby_test() {
- ${RUBY} -S rake test NO_CONNECTION=true || die
- ${RUBY} -S rspec-3 spec || die
-
- einfo "Delay to allow the test server to stop"
- sleep 10
-}