summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-15 15:30:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-15 16:44:57 +0300
commit12f1e77dbf7e281fc3e28c86b4b8bcfd80113295 (patch)
tree86626113d4a9684b1ab886a1fff3d6b59b43dc1f
parentdev-python/oslo-serialization: enable py3.11 (diff)
downloadgentoo-12f1e77dbf7e281fc3e28c86b4b8bcfd80113295.tar.gz
gentoo-12f1e77dbf7e281fc3e28c86b4b8bcfd80113295.tar.bz2
gentoo-12f1e77dbf7e281fc3e28c86b4b8bcfd80113295.zip
dev-python/pyinotify: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..c91436e1f04b
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="
+ https://pypi.org/project/pyinotify/
+ https://github.com/seb-m/pyinotify/"
+SRC_URI="https://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ if use examples; then
+ dodoc -r python3/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}